# Can’t select database after Docker upgrade

**URL:** https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773
**Category:** Bug Reports
**Created:** [June 15, 2021, 11:57am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773 "2021-06-15T11:57:05Z")
**Posts on this page:** 20
**Page:** 2

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [April 19, 2021, 4:43pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/22 "2021-04-19T16:43:17Z")

</div>

Hi @hcmendez . Welcome to DevKinsta! I’m sorry to hear you’re having trouble. Let’s see if we can figure out what happened here.

Could you tell me if your files exist within `c:\User\Hen_1\DevKinsta`? Do you see your sites under the public directory?

---

<div class="post-metadata">

### Author: ![hcmendez](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hcmendez/32/438_2.png) [@hcmendez](https://community.kinsta.com/u/hcmendez)
#### Post date: [April 19, 2021, 5:00pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/23 "2021-04-19T17:00:51Z")

</div>

Hello, thanks for answering, that directory exists and this is the content inside:

 ![kinsta user folder](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/00aa23190422bd2037c1de5fc951f06bae7cf78d.png)

And on the public directory:

 ![kinsta user folder 2](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/9bfb5b8f503b38f06a2a93a52de062cba52775a9.png)

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [April 19, 2021, 11:56pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/24 "2021-04-19T23:56:09Z")

</div>

Would you be able to provide a screenshot of Docker as well?

---

<div class="post-metadata">

### Author: ![hcmendez](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hcmendez/32/438_2.png) [@hcmendez](https://community.kinsta.com/u/hcmendez)
#### Post date: [April 20, 2021, 1:14am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/25 "2021-04-20T01:14:37Z")

</div>

![docker 1](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/aa1d59124c3d607ed727a46c480e4cfa81076948.png)

 ![docker 2](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/a395cacb4d9c0e79868f090afd08a2f600fe55d8.png)

---

<div class="post-metadata">

### Author: ![onebigidea](https://avatars.discourse-cdn.com/v4/letter/o/df705f/32.png) [@onebigidea](https://community.kinsta.com/u/onebigidea)
#### Post date: [April 20, 2021, 11:30am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/26 "2021-04-20T11:30:54Z")

</div>

I’ll throw in my $.02 here also - same thing is happening to me after the most recent update.  
I am on Mac OS X -

I am sort of happy to hear I am not the only facing this issue - it just started after the automatic update that installed 04/19/2021

I can “fix” it - the same way - tear down DevKinsta as well as Docker - and throw in a re-boot to ensure I am starting over again.  
Then I have to recreate the site - and re upload the DB  
but shortly there after - it will go boom

---

<div class="post-metadata">

### Author: ![hcmendez](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hcmendez/32/438_2.png) [@hcmendez](https://community.kinsta.com/u/hcmendez)
#### Post date: [April 20, 2021, 3:15pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/27 "2021-04-20T15:15:11Z")

</div>

Do you mean, deleting the created site, creating it again with the same name and db?

---

<div class="post-metadata">

### Author: ![onebigidea](https://avatars.discourse-cdn.com/v4/letter/o/df705f/32.png) [@onebigidea](https://community.kinsta.com/u/onebigidea)
#### Post date: [April 20, 2021, 4:21pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/28 "2021-04-20T16:21:13Z")

</div>

Yes - I can recover (sort of) by re-creating the site. HOWEVER - be sure to copy/backup your site’s folder before deleting (because devKinsta wipes it out!)

BUT this doesn’t fix the underlying problem - it is clear that something changed for the worse in the latest update.

---

<div class="post-metadata">

### Author: ![hcmendez](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hcmendez/32/438_2.png) [@hcmendez](https://community.kinsta.com/u/hcmendez)
#### Post date: [April 21, 2021, 3:55am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/29 "2021-04-21T03:55:33Z")

</div>

Tried that, didn’t work. Too bad for DevKinsta that this issues are happening. I just lost a 3 weeks work for an unknown reason they don’t even know why. This database problems are probably the most important ones, if your database gets deleted, everything will get deleted as well. No matter what you do. This issue comes from DevKinsta and not from other place. I don’t really thing docker might caused and issue, because the database is managed by DevKinsta. I trusted in this tool but it’s just disappointing.

---

<div class="post-metadata">

### Author: ![onebigidea](https://avatars.discourse-cdn.com/v4/letter/o/df705f/32.png) [@onebigidea](https://community.kinsta.com/u/onebigidea)
#### Post date: [April 25, 2021, 9:50pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/30 "2021-04-25T21:50:10Z")

</div>

Note - one of my database keeps disappearing.

It appears to be related to typing this command in wp-cli (but not always!)  
wp db reset --yes  
I know it fails when the response I get is:  
www-data@edeeeb29b62d:/www/kinsta/public/homesites$ wp db reset --yes  
ERROR 1006 (HY000) at line 1: Can’t create database ‘homesites’ (errno: 28 “No space left on device”)

I then need to delete this site from devKinsta, and restart my computer (restarting docker). Looking at the Docker console - I see that the Mailhog container has exited - but the rest of the containers are still running (see screenshot - [Dropbox - Screen Shot 2021-04-25 at 5.48.54 PM.png - Simplify your life](https://www.dropbox.com/s/9ve5spizbdxvyxh/Screen%20Shot%202021-04-25%20at%205.48.54%20PM.png?dl=0) )

This behavior is “new” as of the Version 1.1.5 (1.1.5.1559) of devKinsta

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [April 26, 2021, 4:15pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/31 "2021-04-26T16:15:22Z")

</div>

@onebigidea I’m sorry to hear you’re still having trouble. To clarify on that WP CLI command, that’s to completely drop the database and create a new one. Don’t do that unless you’re attempting to delete your database. If you’re looking to reset your database, it’d be best to keep the database in place and instead go into the database manager and drop all the tables.

---

<div class="post-metadata">

### Author: ![onebigidea](https://avatars.discourse-cdn.com/v4/letter/o/df705f/32.png) [@onebigidea](https://community.kinsta.com/u/onebigidea)
#### Post date: [April 26, 2021, 5:36pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/32 "2021-04-26T17:36:33Z")

</div>

Thanks - I’ll modify our procedures accordingly.

---

<div class="post-metadata">

### Author: ![VeVas](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vevas/32/414_2.png) [@VeVas](https://community.kinsta.com/u/VeVas)
#### Post date: [June 29, 2021, 7:41am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/33 "2021-06-29T07:41:02Z")

</div>

Hi @michael ! Any updates on this issue? I see that it’s several topics with similar issues, and this just happened to me today as well. Closed down my computer last night and when I started it this morning all databases where gone.  
Until this issue is fixed, do you have any recommendation in retrieving the database?

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [June 29, 2021, 4:07pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/34 "2021-06-29T16:07:07Z")

</div>

Hi @VeVas . I’m sorry about the issues. No updates at this time to provide, but if you could share further information on your configuration, that’d be super helpful to the dev team here. Do you happen to know if Docker updated?

---

<div class="post-metadata">

### Author: ![onebigidea](https://avatars.discourse-cdn.com/v4/letter/o/df705f/32.png) [@onebigidea](https://community.kinsta.com/u/onebigidea)
#### Post date: [June 30, 2021, 4:17pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/35 "2021-06-30T16:17:49Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:** 30 June 2021 12noon (EDT)

**Q: DevKinsta Version**  
\*\*A:\*\*1.1.7 (1645)

**Q: OS Version**  
**A:** Mac OS X Catalina (10.15.7)

**Q: Docker Desktop Version**  
\*\*A:\*\*3.4.0(5223)

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** See notes below - no visibile errors in WordPress itself

**Q: Detailed Description of the Problem**  
**A:** site stopped working and providing info from DB

From Docker (devkinsta\_db)

2021-06-28 13:53:07 4 [ERROR] mysqld: Table ‘./tributology/wp\_nbjcnm\_options’ is marked as crashed and should be repaired

2021-06-28 13:53:07 4 [Warning] Checking table: ‘./tributology/wp\_nbjcnm\_options’

2021-06-28 13:53:19 4 [ERROR] mysqld: Table ‘./tributology/wp\_nbjcnm\_usermeta’ is marked as crashed and should be repaired

2021-06-28 13:53:19 4 [Warning] Checking table: ‘./tributology/wp\_nbjcnm\_usermeta’

2021-06-29 20:53:38 355 [Warning] Aborted connection 355 to db: ‘tributology’ user: ‘root’ host: ‘172.18.0.1’ (Got an error reading communication packets)

2021-06-30 15:58:35 630 [ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)

2021-06-30 15:58:35 630 [ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)

2021-06-30 16:05:06 632 [ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)

2021-06-30 16:05:07 631 [ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-1.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)

2021-06-30 16:05:09 634 [ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)

From Adminer

Warning: session\_regenerate\_id(): write failed: No space left on device (28) in /var/www/html/adminer.php on line 1467

Warning: session\_regenerate\_id(): Session write failed. ID: files (path: ) in /var/www/html/adminer.php on line 1467

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/adminer.php:1467) in /var/www/html/adminer.php on line 77

From WP\_DEBUG

[30-Jun-2021 15:58:35 UTC] WordPress database error Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”) for query SHOW FULL COLUMNS FROM `wp_options` made by require(‘wp-blog-header.php’), require\_once(‘wp-load.php’), require\_once(‘wp-config.php’), require\_once(‘wp-settings.php’), do\_action(‘wp\_loaded’), WP\_Hook-\>do\_action, WP\_Hook-\>apply\_filters, \_wp\_cron, spawn\_cron, set\_transient, update\_option

On Restart of DevKinsta  
[![](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/639005476e1b05f215d90c9d02f7d14f77fd7c06.jpeg) ](https://dl.dropboxusercontent.com/s/l0apx98asdpg4cs/Screen%20Shot%202021-06-30%20at%2012.09.51%20PM.png?dl=0)

Used Docker Desktop to delete all the exited containers

Restarted DevKinsta (rebuilt Containers - back to working )

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [June 30, 2021, 4:34pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/36 "2021-06-30T16:34:08Z")

</div>

Hi @onebigidea .I’m sorry for the trouble. I’ve merged your bug report with an existing bug to consolidate the same issue.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [July 1, 2021, 4:23pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/37 "2021-07-01T16:23:13Z")

</div>

Hi everyone. Apologies for the trouble here. Here’s how to fix this:

 ![Screen Shot 2021-07-01 at 5.32.22 PM](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/f8b92f75634b2ff8b0d05e6ed0450594bbb23b5c.png)

You’ll need to open Docker then navigate to Preferences. Within that window, you should see a Resources tab. Try increasing the **Disk Image Size** to a higher value.

We’re looking at solving this in a future update to detect usage. We’ll keep this thread open and let you know once it’s solved on DevKinsta itself.

---

<div class="post-metadata">

### Author: ![VeVas](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vevas/32/414_2.png) [@VeVas](https://community.kinsta.com/u/VeVas)
#### Post date: [September 8, 2021, 8:19am UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/39 "2021-09-08T08:19:30Z")

</div>

Hi @michael!  
Any updates on this? (it just happened again 😣)

We really need a solution for this. The “Docker Wipe” has happened to me on several occasions now, and it’s extremely frustrating. This is an issue that renders DevKinsta almost unusable as long as these troubles persist.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [September 8, 2021, 2:29pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/40 "2021-09-08T14:29:54Z")

</div>

Hi @VeVas . No updates yet on this here, but it sounds like perhaps you may have a different issue. Are you seeing the error `[ERROR] mysqld: Disk full (/tmp/#sql-temptable-1-0.MAI); waiting for someone to free some space… (errno: 28 “No space left on device”)` as reported by others above? If you’re seeing a different message, would you mind creating a new topic here for us to troubleshoot together?

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [October 11, 2021, 3:46pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/41 "2021-10-11T15:46:23Z")

</div>

[DevKinsta 2.2.0](https://kinsta.com/devkinsta/) addresses the issue of checking to ensure that Docker has enough disk space available for DevKinsta to run. 2.2.0 also corrects database password creation when new containers are created. If you still experience any issues here, please let us know by creating a new post here. Thanks again for using DevKinsta!

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [October 11, 2021, 3:46pm UTC](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773/42 "2021-10-11T15:46:30Z")

</div>



[Previous page](https://community.kinsta.com/t/can-t-select-database-after-docker-upgrade/773.md?page=1)
