# Cant create mysql dump DK0029 Again

**URL:** https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598
**Category:** Bug Reports
**Created:** [July 6, 2022, 4:17am UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598 "2022-07-06T04:17:28Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![sonicviz](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/sonicviz/32/391_2.png) [@sonicviz](https://community.kinsta.com/u/sonicviz)
#### Post date: [July 6, 2022, 4:17am UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/1 "2022-07-06T04:17:28Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:**

1.14pm Tokyo time 6.7.2022 (that’s ddmmyyyy) JST

**Q: DevKinsta Version**  
**A:**

2.6.0

**Q: OS Version**  
**A:**

Win 11 X64 latest

**Q: Docker Desktop Version**  
**A:**

V4.10.1

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:**

DK0029

**Q: Detailed Description of the Problem**  
**A:**

I’ve had no problem creating sites locally from remote staging before with this one site, but recently it never works, and I continually get Cant create mysql dump DK0029

This impacts workflow dramatically, as devKinsta is not reliable enough just to quickly pull down a site to work on.

The main error from the log file is:  
[2022-07-06 14:30:12.407] [warn] [dumpSiteDatabase] Some warnings from mysql: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ WARNING: UNPROTECTED PRIVATE KEY FILE! @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@Permissions 0755 for ‘/root/.ssh/id\_rsa’ are too open.It is required that your private key files are NOT accessible by others.This private key will be ignored.Load key “/root/.ssh/id\_rsa”: bad permissions  
[2022-07-06 14:13:45.200] [error] Error - DK0029: MYSQL\_DUMP\_COMMON: Error (255): G[site name redacted for public use xxx@yy.zz.ee.rr]: Permission denied (publickey,password).

So I think the “This private key will be ignored.” is what is causing the persmission denied.  
But I haven’t done anything on either the staging site configuration or the local end, just using DevKinsta bog standard install to try and clone a remote local site.

From what I can see permissions on ‘/root/.ssh/id\_rsa’ are not 0755 anyway, but 0644

Really frustrating, as it was a great tool when it worked reliably.

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 6, 2022, 5:46pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/2 "2022-07-06T17:46:57Z")

</div>

Hi @sonicviz, thanks for reaching out, can you try the following steps:

1. Log out of MyKinsta within DevKinsta’s settings.
2. Completely close DevKinsta
3. Go to ~/DevKinsta/ and delete the .ssh folder.
4. Open Docker Desktop and delete the “Image” for ‘kinsta/devkinsta\_rsync-ssh’ (optional but might help)
5. Open DevKinsta, log back in, then try the process again.

Please let me know if it keeps giving you this error. Also, are you using WSL2 or Hyper-V for this installation?

---

<div class="post-metadata">

### Author: ![sonicviz](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/sonicviz/32/391_2.png) [@sonicviz](https://community.kinsta.com/u/sonicviz)
#### Post date: [July 6, 2022, 10:08pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/3 "2022-07-06T22:08:22Z")

</div>

HI Kevin,

I’m using Hyper-V.  
I don’t have any kinsta/devkinsta\_rsync-ssh’ rsync image though.  
Only adminer, fpm, mailhog, and nginx.

If I just delete the .ssh folder in my working DevKinsta directory I still get the same error.

[2022-07-07 07:33:07.459] [warn] [dumpSiteDatabase] Some warnings from mysql: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ WARNING: UNPROTECTED PRIVATE KEY FILE! @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@Permissions 0755 for ‘/root/.ssh/id\_rsa’ are too open.It is required that your private key files are NOT accessible by others.This private key will be ignored.Load key “/root/.ssh/id\_rsa”: bad permissions  
[2022-07-07 07:33:07.459] [warn] [dumpSiteDatabase] Some warnings from mysql: G[REDACTED]: Permission denied (publickey,password).  
[2022-07-07 07:33:07.460] [error] Error - DK0029: MYSQL\_DUMP\_COMMON: Error (255): G[REDACTED]: Permission denied (publickey,password).

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 6, 2022, 10:48pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/4 "2022-07-06T22:48:43Z")

</div>

Thanks for confirming, @sonicviz This is an issue that began happening with Hyper-V a few months ago. Our developers are working on a fix for it that should be released later this month. I would suggest switching to WSL2 in order to get this right now if you cannot wait.

The issue is with how Hyper-V is setting the permissions for `~/DevKinsta/.ssh/id_rsa`  
When the file is read by Linux, the permissions appear as 0755. I haven’t been able to find an immediate fix for this but I will update you here if I find something.

I will also update you when the Fix has been released for Hyper-V.

---

<div class="post-metadata">

### Author: ![sonicviz](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/sonicviz/32/391_2.png) [@sonicviz](https://community.kinsta.com/u/sonicviz)
#### Post date: [July 6, 2022, 10:52pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/5 "2022-07-06T22:52:14Z")

</div>

Thanks. I’ll have to wait, as I’m unable to switch to WSL atm.

---

<div class="post-metadata">

### Author: ![sonicviz](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/sonicviz/32/391_2.png) [@sonicviz](https://community.kinsta.com/u/sonicviz)
#### Post date: [July 28, 2022, 5:32am UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/6 "2022-07-28T05:32:14Z")

</div>

Hi,

I installed V2.7.0 via [DevKinsta Releases (Minor) - #12 by Kevin](https://community.kinsta.com/t/devkinsta-releases-minor/371/12)  
and managed to successfully pull a site down

However, it won’t let me connect to the local clone now, the local site url and the admin url continually redirect to the remote site, so I can’t use the local clone.

I checked the WP-Options table, and both siteURL and home are both set to the remote URL, so looks like the clone process has skipped the URL rewrite step.

Bug?

I’ve tried to change the url’s but no matter which method I use I’m getting 504 Gateway Timeouts.  
This has turned into a bit of a nightmare timesink now, when it really should be all done automatically via DevKinsta as it used to (when it worked).

Thanks,  
Paul

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 28, 2022, 4:45pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029-again/1598/7 "2022-07-28T16:45:27Z")

</div>

Hi @sonicviz, can you please privately share you [main.log file](https://kinsta.com/knowledgebase/devkinsta/error-codes/#info) with me for that Pull? The search and replace action is logged/shows what is attempted. Sometimes it fails due to a WP CLI error.
