# Can't Create MySQL Dump -- DK0029

**URL:** https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309
**Category:** Bug Reports
**Created:** [April 16, 2024, 5:18pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309 "2024-04-16T17:18:10Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![mcd](https://avatars.discourse-cdn.com/v4/letter/m/ecb155/32.png) [@mcd](https://community.kinsta.com/u/mcd)
#### Post date: [April 16, 2024, 5:18pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/1 "2024-04-16T17:18:10Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:** 04/16/2024

**Q: DevKinsta Version**  
**A:** 2.13.2

**Q: OS Version**  
**A:** Windows 11

**Q: Docker Desktop Version**  
**A:** 4.29.0

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** DK0029 Can’t Create MySQL Dump

**Q: Detailed Description of the Problem**  
**A:** When I try ‘Import from Kinsta’ to pull down my live or staging site, it fails with the above error. Looking at main.log, I see that it gets a ‘Connection refused’ when it attempts to ssh to my site. The IP address it is using is different from the one on MyKinsta.

---

<div class="post-metadata">

### Author: ![Daniel\_O](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/daniel_o/32/2812_2.png) [@Daniel\_O](https://community.kinsta.com/u/Daniel_O)
#### Post date: [April 17, 2024, 1:21am UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/3 "2024-04-17T01:21:01Z")

</div>

Hi @mcd 👋

Welcome to the Kinsta Community!

Regarding your concern, this could indeed be a bug. But we may have a workaround that you could try to resolve this issue.

If you’re familiar with using Terminal, the following command should fix this error:

`docker exec -it devkinsta_fpm /bin/rm /root/.ssh/known_hosts`

Please let us know how this one goes.

–

Best Regards,

Daniel O.  
Kinsta Staff

---

<div class="post-metadata">

### Author: ![mcd](https://avatars.discourse-cdn.com/v4/letter/m/ecb155/32.png) [@mcd](https://community.kinsta.com/u/mcd)
#### Post date: [April 17, 2024, 1:50pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/4 "2024-04-17T13:50:17Z")

</div>

> [@Daniel\_O](#):
>
> docker exec -it devkinsta\_fpm /bin/rm /root/.ssh/known\_hosts

That command gives me this:

/bin/rm: cannot remove ‘/root/.ssh/known\_hosts’: No such file or directory

I can confirm that it does not exist inside the docker container.

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [April 18, 2024, 12:30am UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/5 "2024-04-18T00:30:54Z")

</div>

Hi @mcd,

If you haven’t already, please close or quit both the DevKinsta and Docker apps completely. After that, relaunch DevKinsta and try the pull action again. If the issue persists, please share a copy of your DevKinsta raw **main.log** file with me via private message. To locate it, click the question mark icon at the bottom-left corner of DevKinsta, and select “ **Reveal log file in File Manager** ”. We’d like to take a closer look at why the DK0029 error is occurring.

We look forward to hearing back from you. 🙂

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [April 18, 2024, 11:59pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/8 "2024-04-18T23:59:34Z")

</div>

Hi @mcd,

Thank you for sharing your main.log file with me. I have reviewed the log and found that the site you are trying to import into Devkinsta is not a standard WordPress installation. From the file structure, it appears to be built using Bedrock. Unfortunately, the Devkinsta pull/push action works best only with standard WordPress installations. However, you can try the suggested workaround from Kevin to get the pull action to work. Here’s the link: [Import WordPress/Bedrock host on Kinsta to DevKinsta](https://community.kinsta.com/t/import-wordpress-bedrock-host-on-kinsta-to-devkinsta/1733)

I hope this information helps you.

---

<div class="post-metadata">

### Author: ![mcd](https://avatars.discourse-cdn.com/v4/letter/m/ecb155/32.png) [@mcd](https://community.kinsta.com/u/mcd)
#### Post date: [April 19, 2024, 3:51pm UTC](https://community.kinsta.com/t/cant-create-mysql-dump-dk0029/3309/9 "2024-04-19T15:51:57Z")

</div>

Doh. I forgot about this from when I first published my site a few years ago. Disappointing that Bedrock is still not supported. I think I’ll drop Devkinsta and build my own local environment instead. Thank you for for helping me out.
