# Can't startup Kinsta after interrupted upgrade

**URL:** <https://community.kinsta.com/t/cant-startup-kinsta-after-interrupted-upgrade/1760>\
**Category:** Installation\
**Created:** [September 23, 2022, 7:54am UTC](https://community.kinsta.com/t/cant-startup-kinsta-after-interrupted-upgrade/1760 "2022-09-23T07:54:48Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Johannes](https://avatars.discourse-cdn.com/v4/letter/j/7ba0ec/32.png) [@Johannes](https://community.kinsta.com/u/Johannes)\
**Post date:** [September 23, 2022, 7:54am UTC](https://community.kinsta.com/t/cant-startup-kinsta-after-interrupted-upgrade/1760/1 "2022-09-23T07:54:48Z")

</div>

Hi,  
I’m locked out of DevKinsta, after a probably failed update yesterday. Stopping all services in terminal (Mac) won’t help. I urgently need access to maria db but it fails to start up also repo is greyed out. PANIC!

Here are some logs  
2022-09-23 08:22:56+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 08:22:57+00:00 [Note] [Entrypoint]: Switching to dedicated user ‘mysql’  
2022-09-23 08:22:57+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 08:23:58+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 08:23:58+00:00 [Note] [Entrypoint]: Switching to dedicated user ‘mysql’  
2022-09-23 08:23:58+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 08:25:00+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 08:25:00+00:00 [Note] [Entrypoint]: Switching to dedicated user ‘mysql’  
2022-09-23 08:25:00+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.  
2022-09-23 8:23:59 0 [Note] InnoDB: Starting shutdown…  
2022-09-23 8:23:59 0 [ERROR] Plugin ‘InnoDB’ init function returned error.  
2022-09-23 8:23:59 0 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
2022-09-23 8:23:59 0 [Note] Plugin ‘FEEDBACK’ is disabled.  
2022-09-23 8:23:59 0 [ERROR] Unknown/unsupported storage engine: InnoDB  
2022-09-23 8:23:59 0 [ERROR] Aborting  
2022-09-23 8:25:00 0 [Note] mysqld (mysqld 10.5.5-MariaDB-1:10.5.5+maria~focal) starting as process 1 …  
2022-09-23 8:25:00 0 [Note] InnoDB: Using Linux native AIO  
2022-09-23 8:25:00 0 [Note] InnoDB: Uses event mutexes  
2022-09-23 8:25:00 0 [Note] InnoDB: Compressed tables use zlib 1.2.11  
2022-09-23 8:25:00 0 [Note] InnoDB: Number of pools: 1  
2022-09-23 8:25:00 0 [Note] InnoDB: Using SSE4.2 crc32 instructions  
2022-09-23 8:25:00 0 [Note] mysqld: O\_TMPFILE is not supported on /tmp (disabling future attempts)  
2022-09-23 8:25:00 0 [Note] InnoDB: Initializing buffer pool, total size = 134217728, chunk size = 134217728  
2022-09-23 8:25:00 0 [Note] InnoDB: Completed initialization of buffer pool  
2022-09-23 8:25:00 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().  
2022-09-23 8:25:00 0 [ERROR] InnoDB: Missing FILE\_CHECKPOINT at 587095623 between the checkpoint 587095623 and the end 587095552.  
2022-09-23 8:25:00 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error  
2022-09-23 8:25:00 0 [Note] InnoDB: Starting shutdown…  
2022-09-23 8:25:01 0 [ERROR] Plugin ‘InnoDB’ init function returned error.  
2022-09-23 8:25:01 0 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
2022-09-23 8:25:01 0 [Note] Plugin ‘FEEDBACK’ is disabled.  
2022-09-23 8:25:01 0 [ERROR] Unknown/unsupported storage engine: InnoDB  
2022-09-23 8:25:01 0 [ERROR] Aborting

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [September 23, 2022, 5:12pm UTC](https://community.kinsta.com/t/cant-startup-kinsta-after-interrupted-upgrade/1760/2 "2022-09-23T17:12:42Z")

</div>

Hi @Johannes, thanks for reaching out. Was this after a failed update of DevKinsta? Are you able to use Time Machine to [restore Docker](https://www.jappler.com/2021/12/14/how-to-restore-a-docker-container-with-time-machine-mac-os/)? I’m not sure if you have that configured in your Docker settings.

Assuming the issue is similar to this: [linux - mysqld fails to start due to InnoDB - Server Fault](https://serverfault.com/questions/1094543/mysqld-fails-to-start-due-to-innodb) then the solution listed there and [here](https://support.inductiveautomation.com/hc/en-us/articles/4415186180493-MySQL-or-MariaDB-is-faulted-due-a-startup-error) might fix the issue.

I can’t reproduce this error so all I can do is provide ideas. My best guess is that you will need to make this change in the devkinsta\_db\_data Volume. These instructions for Mac might help: [Getting path and accessing persistent volumes in Docker for Mac ⚡ | TimOnWeb](https://timonweb.com/docker/getting-path-and-accessing-persistent-volumes-in-docker-for-mac/)

On Windows, I can reach the directory with the logfiles by navigating here:  
`\\wsl$\docker-desktop-data\data\docker\volumes\devkinsta_db_data\_data`

The Mac path should be somewhat similar. The solution should be renaming or deleting the `ib_logfile` file. I recommend making a backup of it if deleting.

---

<div class="post-metadata">

**Author:** ![Johannes](https://avatars.discourse-cdn.com/v4/letter/j/7ba0ec/32.png) [@Johannes](https://community.kinsta.com/u/Johannes)\
**Post date:** [September 23, 2022, 5:17pm UTC](https://community.kinsta.com/t/cant-startup-kinsta-after-interrupted-upgrade/1760/3 "2022-09-23T17:17:03Z")

</div>

Thanks Kevin, I think I’ll start off with the database recovery (delete log) before I’ll go on and try to restore docker through time macjine. I’ll let you know where it led to.

Thank you!
