# DevKinsta Multisite Import Failure

**URL:** https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174
**Category:** Installation
**Created:** [May 6, 2026, 3:46am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174 "2026-05-06T03:46:52Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Hector\_Veiga](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hector_veiga/32/5542_2.png) [@Hector\_Veiga](https://community.kinsta.com/u/Hector_Veiga)
#### Post date: [May 6, 2026, 3:46am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/1 "2026-05-06T03:46:52Z")

</div>

### **Site Information:**

- **Live Site:** `redacteddomain.com`

- **Local Site:** `sitename.local` (DevKinsta)

- **Site Type:** Directory-based WordPress Multisite

**Problem Description:** When attempting to import the site from MyKinsta to DevKinsta, the process fails. The site is inaccessible, attempting to redirect to `http://undefined`. Additionally, the `wp-admin` area displays a database connection error. The live site on MyKinsta remains fully functional.

**Error Message Received:**

> “Error establishing a database connection. Could not find site sitename.local:[port]. Searched for table wp\_blogs in database SiteName\_redacted.”

**Troubleshooting Steps Performed (No resolution):**

- **Re-imports:** Performed multiple fresh imports (Single domain, Subdomain Multisite, and Directory Multisite configurations).

- **SSL/HTTPS:** Toggled SSL settings on and off within DevKinsta.

- **Environment Variables:** Attempted manual adjustment of environment variables.

- **Config Files:** Verified `wp-config.php` definitions for `WP_HOME` and `WP_SITEURL`.

- **Database Check:** Confirmed access to the database manager is possible, but the site remains unable to connect to the specific required tables.

**Request:** The user requires assistance resolving the import failure for this specific multisite configuration. Previous attempts at self-troubleshooting and standard re-installation have not corrected the database mapping or the redirect loop. Please investigate why the multisite import process is failing to correctly map tables for this environment.

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 6, 2026, 4:07am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/2 "2026-05-06T04:07:37Z")

</div>

Hi @Hector_Veiga 👋

Welcome to the Kinsta Community!

Based on the database connection error you shared, it appears that the Pull action was unable to correctly update the domain entry in the `wp_blogs` and/or `wp_site` database tables. This issue may arise due to the configuration of WP Multisite. So a manual database update is needed when doing Push/Pull actions. Could you please review these two tables in DevKinsta to ensure the `.local` domain is properly set?

Let us know how it goes!

---

<div class="post-metadata">

### Author: ![Hector\_Veiga](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hector_veiga/32/5542_2.png) [@Hector\_Veiga](https://community.kinsta.com/u/Hector_Veiga)
#### Post date: [May 6, 2026, 4:12am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/4 "2026-05-06T04:12:55Z")

</div>

This is a fresh installation, what do you mean a manual update?

What do i need to manually update?

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 6, 2026, 4:18am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/5 "2026-05-06T04:18:09Z")

</div>

> [@Hector\_Veiga](#):
>
> “Error establishing a database connection. Could not find site sitename.local:[port]. Searched for table wp\_blogs in database Sitename\_Redacted.”

Based on the above error, it seems that the domain entries in the `wp_blogs` and/or `wp_site` database tables in DevKinsta were not updated from: “`redacted_domain.com`” to “`sitename.local`” during the Pull site action. Please check this two database tables in DevKinta to make sure they have the correct domain entry which should be “`sitename.local`”

---

<div class="post-metadata">

### Author: ![Hector\_Veiga](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hector_veiga/32/5542_2.png) [@Hector\_Veiga](https://community.kinsta.com/u/Hector_Veiga)
#### Post date: [May 6, 2026, 4:31am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/6 "2026-05-06T04:31:08Z")

</div>

instead of getting the db error it now redirects to the main live website redactedomain[.]com

I made changes to the site, blogs, and options tables accordingly, as well as made sure the config file has the same urls as the db

---

<div class="post-metadata">

### Author: ![Hector\_Veiga](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/hector_veiga/32/5542_2.png) [@Hector\_Veiga](https://community.kinsta.com/u/Hector_Veiga)
#### Post date: [May 6, 2026, 4:35am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/7 "2026-05-06T04:35:25Z")

</div>

ok, after another reboot the local site seems to be working.  
when are you going to update the devkinsta app to fix this issue?

also please remove the thread as it contains clients information. thanks.

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 6, 2026, 4:50am UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/8 "2026-05-06T04:50:46Z")

</div>

I’m glad to hear that it’s now working. However, we don’t have a specific timeframe for when the Pull Site action will operate seamlessly for Multisite. I will pass your inquiry along as feedback to our DevKinsta engineering team. I’ve also removed all sensitive information from this thread. 🙂

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)
#### Post date: [May 8, 2026, 4:51pm UTC](https://community.kinsta.com/t/devkinsta-multisite-import-failure/6174/9 "2026-05-08T16:51:06Z")

</div>

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.
