# Devkinsta's Cancell Maintenance Stuck

**URL:** <https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444>\
**Category:** Application Support\
**Created:** [April 29, 2022, 10:48am UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444 "2022-04-29T10:48:21Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [April 29, 2022, 10:48am UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/1 "2022-04-29T10:48:21Z")

</div>

Hi I am Puspa ,

I am trying to push from local to staging it gives error dk0026 and I try to cancel then it stuck on cancelling But staging site is running with restore snapshot. How to get rid to these problem.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [April 29, 2022, 4:45pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/2 "2022-04-29T16:45:44Z")

</div>

Hi @PuspaRaj_Subedi, welcome to DevKinsta!  
Thank you for sending me your main.log file. If you are still unable to cancel the process, here are instructions on how to “reset” the process: [Stuck on Canceling maintenance, restore snapshot - #7 by Kevin](https://community.kinsta.com/t/stuck-on-canceling-maintenance-restore-snapshot/1362/7)

There are a few different errors in your main.log that could be causing the DK0026. I recommend contacting our Live Support and asking them to “reset staging” to delete everything that is currently there. After that please try to push again and share the main.log if it fails.

I recommend this because I am seeing this error in your logs: [Rsync error code 12 - How we figure it out?](https://bobcares.com/blog/rsync-error-code-12/)

Please let me know if the issue continues.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [April 29, 2022, 5:53pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/3 "2022-04-29T17:53:31Z")

</div>

Hi @Kevin have send that main log for error while uploading it stops with error code dk0026 and stuck at 800 mb

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [April 29, 2022, 9:03pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/4 "2022-04-29T21:03:28Z")

</div>

Hi @PuspaRaj_Subedi, yes the DK0026 is happening because of this error: [Rsync error code 12 - How we figure it out?](https://bobcares.com/blog/rsync-error-code-12/)

This is what is showing in your main.log:  
`rsync error: error in rsync protocol data stream (code 12) at token.c(476) [sender=3.2.3]`

That is why I recommend deleting everything from your Staging Environment before you try to Push. It might be happening because of the files on you Staging website.

Please log into Kinsta and contact our Chat Support team to help you reset your Staging environment before you try pushing the website again.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 2, 2022, 1:28am UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/5 "2022-05-02T01:28:04Z")

</div>

Hi Kevin  
I got the same error dk0026 when try to push site to new staging site. Do you have any other solution i will send my main.log with recent push error.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 2, 2022, 5:15am UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/6 "2022-05-02T05:15:08Z")

</div>

Hi kevin i got the same error while i try to push in another staging site which i have make for testing purpose it give same error dk0026 i have send you a main.log file in message.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 2, 2022, 12:57pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/7 "2022-05-02T12:57:08Z")

</div>

HI @PuspaRaj_Subedi, I only received one main.log file with this error I mentioned above. You would need to send the new mian.log again to make sure it is the same error/cause.

Have you tried deleting the files from the Staging environment before you try to Push? That is still my recommendation.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 2, 2022, 1:41pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/8 "2022-05-02T13:41:57Z")

</div>

Sorry, @PuspaRaj_Subedi I just reread your message. Can you send me the main.log for the brand new staging environment? I need to make sure it is the exact same error message in the logs.

If possible, I would recommend trying DevKinsta from a different computer with these sites to see if it’s the same error. The only other thing I can think of is maybe there is an internet connection issue happening.

Either way, please share the main.log for you test failure with me and I’ll compare the errors.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 2, 2022, 3:42pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/10 "2022-05-02T15:42:10Z")

</div>

I have send you a log on reply please help me to solve it

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 3, 2022, 4:15pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/11 "2022-05-03T16:15:54Z")

</div>

Thanks @PuspaRaj_Subedi, I was ill yesterday but will continue looking into this.

Your most recent log still shows an rsync error but different:  
`rsync error: timeout in data send/receive (code 30) at io.c(197) [sender=3.2.3]`

So to troubleshoot, can you create a new WordPress website **in DevKinsta** then try to push that to Kinsta?

Another way to push your site to Kinsta would be using a [manual migration](https://kinsta.com/blog/migrate-wordpress-site/). You could use the Duplicator plugin, or you could zip the public/sitename directory and then copy that to Kinsta.

I am still trying to narrow this down so the best test would be this:

1. Create brand new WP site on DevKinsta
2. Create blank WP site on Kinsta and add a staging environment.
3. Push the DevKinsta site to Kinsta Staging
4. If this fails, please share the main.log. It will offer better data.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 6:38am UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/12 "2022-05-04T06:38:15Z")

</div>

Hi kevin I have deleted my staging and try it gives me this error  
rsync: [sender] write error: Broken pipe (32)  
rsync error: unexplained error (code 255) at io.c(823) [sender=3.2.3]  
you can find my recent log file here  
[main.log](https://community.kinsta.com/uploads/short-url/9xTfU4CnsJ0JpT9iBY8SIq6PGde.log) (6.5 KB)

For your reference,  
I have also created new site on both kinsta and devkinsta its working fine.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 4, 2022, 4:12pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/13 "2022-05-04T16:12:59Z")

</div>

Thanks for sharing @PuspaRaj_Subedi, I’m looking at the log now. So now it sounds like your ssh connection was broken/idle. That’s what “Broken pipe” means. Please let me ask our developers what the best approach next would be.

Have you already tested Pushing this site to the NEW Blank Kinsta Staging? Just to be sure it tails the same way. Can you also send me a private message with your computer’s IP address? I want to make sure it isn’t being caused by our firewall.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 4:43pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/14 "2022-05-04T16:43:03Z")

</div>

I just tested pushing fresh site in devkinsta and push it to New Blank kinsta staging.  
how to send my ip ??

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 4, 2022, 4:47pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/15 "2022-05-04T16:47:33Z")

</div>

Thanks for sharing your IP.

Can you test Pushing the “old” DevKinsta site to the “fresh” Kinsta staging?

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 4:49pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/16 "2022-05-04T16:49:17Z")

</div>

i am trying now but its stopping with broke pipe error in 200 mb

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 4:56pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/17 "2022-05-04T16:56:16Z")

</div>

![](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/4/4909add08b8874905a732c390ee5c6051cd3d912.jpeg)

And some time it gives this error

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 4, 2022, 5:07pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/18 "2022-05-04T17:07:14Z")

</div>

Ah, okay, that error again. I saw that in a different log you gave before. Can you try following the instructions that the error is giving you? Basically this:

I’m not sure where this is on Linux, but on Windows, the DevKinsta storage directory looks like this:  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/f/f692db17881642a4d95917ed06befb1c993c0621.png)

If you go into the “.ssh” directory (it might be hidden for you), you need to open the known\_hosts file  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/2/2bd43cade262f25257c493ae4bf89a534a267ce4.png)  
That’s where you would need to delete “line 29” of that file.

Since you are on Linux, the known\_hosts file might actually just be /root/.ssh/known\_hosts

The Kinsta entries will have your site’s external IP address. Most start with “34”  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/7/714fa1df5ad33f3d7d8aeebee0103b9419566f42.png)

You just need to delete the line that the error is mentioning. We also have an explanation of this [here](https://kinsta.com/knowledgebase/warning-remote-host-identification-has-changed/)

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 5:11pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/19 "2022-05-04T17:11:53Z")

</div>

Should I have to delete all entries with 35 ??

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [May 4, 2022, 5:18pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/20 "2022-05-04T17:18:58Z")

</div>

Try only deleting the “line” mentioned in the error to see if it stops happening.  
Otherwise, yes you could delete all of the entries, you should just backup the contents of the file just in case.

---

<div class="post-metadata">

**Author:** ![PuspaRaj\_Subedi](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/pusparaj_subedi/32/1083_2.png) [@PuspaRaj\_Subedi](https://community.kinsta.com/u/PuspaRaj_Subedi)\
**Post date:** [May 4, 2022, 5:23pm UTC](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444/21 "2022-05-04T17:23:47Z")

</div>

I will look after that if i stuck on ssh error again but want to know in which line we can find the ip , i didn’t find that and whats the solution for broken pipe does this problem belongs to ssh

[Next page](https://community.kinsta.com/t/devkinstas-cancell-maintenance-stuck/1444.md?page=2)
