# DK0006 Couldn't download docker images

**URL:** https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277
**Category:** Application Support
**Created:** [May 25, 2023, 1:48am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277 "2023-05-25T01:48:48Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 25, 2023, 1:48am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/1 "2023-05-25T01:48:48Z")

</div>

I have set up my docker and it was working. Now when I returned to it I am getting this error:

DK0006 Couldn’t download docker images

My log says:

[2023-05-25 11:10:13.424] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:10:13.425] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:10:13.426] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:10:13.429] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:10:13.438] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:10:13.443] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:12.963] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:39:12.965] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:39:12.967] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:39:12.968] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:39:12.971] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:12.972] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:14.927] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:39:14.927] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:39:14.928] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:39:14.929] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:39:14.930] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:14.931] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:35.302] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:39:35.303] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:39:35.304] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:39:35.305] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:39:35.306] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:35.307] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:36.173] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:39:36.173] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:39:36.174] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:39:36.174] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:39:36.175] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:36.176] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:39:40.364] [info] [main.dev.ts] Create tray icon  
[2023-05-25 11:39:40.392] [info] [main.dev.ts] close setting: true  
[2023-05-25 11:39:40.407] [info] [main.dev.ts] Create tray icon, close window /Applications/DevKinsta.app/Contents/Resources/resources/icons/trayIconTemplate.png  
[2023-05-25 11:40:06.654] [info] [main.dev.ts] Remove tray icon, open window  
[2023-05-25 11:47:25.976] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:47:25.979] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:47:25.981] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:47:25.981] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:47:26.017] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:26.018] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:26.750] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:47:26.750] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:47:26.751] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:47:26.751] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:47:26.753] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:26.754] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:27.191] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:47:27.194] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:47:27.195] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:47:27.195] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:47:27.196] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:27.197] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:27.425] [info] [dockerUtil/getImage] Get Docker image, name: kinsta/devkinsta\_nginx:1.3.1  
[2023-05-25 11:47:27.426] [info] [dockerUtil/isImageUpToDate] Check if ‘kinsta/devkinsta\_nginx’ Docker image is up to date  
[2023-05-25 11:47:27.427] [warn] [dockerUtil/isImageUpToDate] Failed to inspect image undefined  
[2023-05-25 11:47:27.427] [info] [dockerUtil/pullImage] Pull Docker image. name: kinsta/devkinsta\_nginx, version: 1.3.1  
[2023-05-25 11:47:27.429] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)  
[2023-05-25 11:47:27.429] [error] Error: connect ENOENT /var/run/docker.sock  
at \_\_node\_internal\_captureLargerStackTrace (node:internal/errors:465:5)  
at \_\_node\_internal\_exceptionWithHostPort (node:internal/errors:643:12)  
at PipeConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)

---

<div class="post-metadata">

### Author: ![Alessandro](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/alessandro/32/2310_2.png) [@Alessandro](https://community.kinsta.com/u/Alessandro)
#### Post date: [May 25, 2023, 8:52am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/2 "2023-05-25T08:52:17Z")

</div>

Hey @Aporia, based on your previous posts I assume you are using Mac OS, can you please try to run the following command via terminal when both DevKinsta and Docker are entirely closed?

`sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock`

Once done, try to open DevKinsta as usual.

Regards,  
Alessandro

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 26, 2023, 12:11am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/3 "2023-05-26T00:11:19Z")

</div>

That worked, as in DevKinsta started up. Any way to make this change permanent.

However, the site is not open.  
The interface references: [https://cheeseclubhk.local:61967/](https://cheeseclubhk.local:61967/)  
The email references: [http://cheeseclubhk.local:59172](http://cheeseclubhk.local:59172)

But both links says:

# This site can’t be reached

**cheeseclubhk.local** refused to connect.

Try:

- Checking the connection
- Checking the proxy and the firewall

ERR\_CONNECTION\_REFUSED

---

<div class="post-metadata">

### Author: ![Alessandro](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/alessandro/32/2310_2.png) [@Alessandro](https://community.kinsta.com/u/Alessandro)
#### Post date: [May 26, 2023, 3:04pm UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/4 "2023-05-26T15:04:12Z")

</div>

> That worked, as in DevKinsta started up. Any way to make this change permanent.

That should be needed only once, do you have the same issue after closing and reopening DevKinsta?

> However, the site is not open.

Can you please check inside Docker if the containers are all running?

Regards,  
Alessandro

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 29, 2023, 1:17am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/5 "2023-05-29T01:17:32Z")

</div>

They are all running. nginx on ports 61966-61967.

Attached is my log  
main.log (918.4 KB)

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 29, 2023, 1:39am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/6 "2023-05-29T01:39:41Z")

</div>

I used terminal to look into nginx. Nginx is running, but on port 80

In DevKinsta: nginx is configured this way:

listen 59172;  
listen [::]:59172;  
listen 59173 ssl http2;  
listen [::]:59173 ssl http2;

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [May 29, 2023, 7:13am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/8 "2023-05-29T07:13:38Z")

</div>

Hi there 🙂

Can you please try to go to your DevKinsta Settings page, and there go to the “ **Port selector** ” section and un-check the “**[] Auto-detect open ports**” , then put the default port number to each field ( **HTTP** with **80** , and **HTTPS** with **443** ) then click the **confirm** button?

 ![Screenshot from 2023-05-29 14-10-59](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/c/c8ff6923c22a15e3e473372cfdbe41de96c4528c.png)

This will set your local site domain URL without that custom port (e.g.: 61967 / 59172 ) but will use those 2 default ports.

After that, please check if you will be able to access that local site URL ( [http://cheeseclubhk.local](http://cheeseclubhk.local) and/or [https://cheeseclubhk.local](https://cheeseclubhk.local) ) ? 🤞

Regards,  
Agus

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 12:53am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/9 "2023-05-30T00:53:37Z")

</div>

Alright I did that and it worked. I restored it to auto-detect open ports and now the selected ports do not work.

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 12:55am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/10 "2023-05-30T00:55:50Z")

</div>

I stopped docker and DevKinsta in between. It would appear that DevKinsta’s port change is working for the docker container, but the actual service on the nginx on the container is still running on 80 and 443.

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 12:56am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/11 "2023-05-30T00:56:33Z")

</div>

I am running devkinsta\_nginx [kinsta/devkinsta\_nginx:1.3.1]

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [May 30, 2023, 2:06am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/12 "2023-05-30T02:06:06Z")

</div>

Glad to see it worked! 👍  
I would suggest to set/keep them to the default ports (HTTP = **80** , HTTPS = **443** ) in that “_Port selector_” section (on the DevKinsta Setting page) - I myself also always use these default ports on my DevKinsta settings (in my personal opinion to make the local URL looks clean - without any additional ports):

 ![Screenshot from 2023-05-30 08-42-52](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/d/dc64318272a712c850a0e8c1b62e8d91a86b4be7.png)  
 ![Screenshot from 2023-05-30 08-42-40](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/0/0684b312031d0ececa4c5e72924d04d08f421327.png)

though when I tried with custom ports they also worked just fine:

 ![Screenshot from 2023-05-30 08-40-20](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/d/d8648dde1f056e8ffce443f97ebbd580e0052375.png)  
 ![Screenshot from 2023-05-30 08-41-07](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/e/ef548b26ee1565fb0dc3f7a8f781f360494cf4bc.png)  
 ![Screenshot from 2023-05-30 08-40-02](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/c/c6e6498346abf6fe23bea2df2443de9238db3030.png)  
 ![Screenshot from 2023-05-30 08-41-33](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/1/11559ae98a1a25ff17378d8560ffe0406860acff.png)

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 2:13am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/13 "2023-05-30T02:13:39Z")

</div>

The default ports do not work for me, because I am still using Mamp Pro. I am experimenting with switching to DevKinsta, but until it is more stable, I need to continue to use Mamp Pro.

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 2:58am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/14 "2023-05-30T02:58:44Z")

</div>

Ok, now I think nginx is running fine. I see how it runs on 80 and 443 and that docker maps from the external ports. So what would be different between 80 and 443 and other ports.

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [May 30, 2023, 5:49am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/15 "2023-05-30T05:49:47Z")

</div>

> The default ports do not work for me, because I am still using Mamp Pro. I am experimenting with switching to DevKinsta, but until it is more stable, I need to continue to use Mamp Pro.

Yeah, if there’s another web service running (Mamp pro or something like that) on your local computer (uses the same/default ports) then that would be conflicting/preventing the other web service (NGINX in this case) to run on those same default ports.

I also had Apache web service ran on my local computer before (on default ports: 80 and 443), and I had to change my DevKinsta ports to something else, so that both Apache and DevKinsta’s (NGINX) local sites would be working just fine - as shown in the following screenshots that I took:

 ![Screenshot from 2023-05-30 09-26-20](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/d/da403f71e8d70b1742bafcf88c75f01ef2ed37c8.png)  
(Apache service was not able to run before when DevKinsta/NGINX was set with the default ports 80/443, and was then working fine after I changed the DevKinsta ports to something else: 8080 and 4343).

 ![Screenshot from 2023-05-30 09-25-17](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/9/987bc2a0d851d087ffe7b230c9b0f507ee2c0677.png)

 ![Screenshot from 2023-05-30 09-25-24](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/1/179b1a98270ab0fbada12d995d527edbd4b0af60.png)  
 ![Screenshot from 2023-05-30 09-25-21](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/3/3b1b9b95a28db1125eb69feed6fb957a36868f19.png)  
 ![Screenshot from 2023-05-30 09-25-44](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/3/340188d4254ae296f5a15b87a676c0513faeac49.png)

The ports set in that “Port selector” section would be set in each of the sitename.conf file(s) located in the `~/DevKinsta/nginx_sites` sub-folder.

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 30, 2023, 6:15am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/16 "2023-05-30T06:15:15Z")

</div>

I think you misunderstand me. I definitely want and need to run devkinsta on other ports than 80 and 443. I now understand that nginx runs on port 80 and 443 but docker maps external ports to those, so no need to adjust the files in ~/DevKinsta/nginx\_sites

You can see here, it is running and working:  
39acff3002b0 kinsta/devkinsta\_nginx:1.3.1 “/docker-entrypoint.…” 5 hours ago Up 3 seconds 80/tcp, 443/tcp, 0.0.0.0:51350-51351-\>51350-51351/tcp devkinsta\_nginx

However, when I try to access that url, i get an error and I do not know what is happening

 ![Screen Shot 2023-05-30 at 4.14.34 PM](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/2/20245c139e98044bb139abd8979c637db417b6cc.png)

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [May 30, 2023, 7:56am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/17 "2023-05-30T07:56:00Z")

</div>

Yeah I understood that you would want / need to run DevKinsta on custom ports other than 80 and 443.  
It should work as I tested and showed in the previous screenshots before, that I changed the ports to 8080 and 4343.

I also just tried once again now to change the ports to: 51350 (HTTP) and 51351 (HTTPS)

 ![Screenshot from 2023-05-30 14-46-11](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/0/0959c22be7bc07e5d47a788e1bdedd3d35841552.png)

and this what I got from the docker:

> 12760f5710c5 kinsta/devkinsta\_nginx:1.3.1 “/docker-entrypoint.…” 12 seconds ago Up 11 seconds 80/tcp, 443/tcp, 0.0.0.0:51350-51351-\>51350-51351/tcp, :::51350-51351-\>51350-51351/tcp devkinsta\_nginx

and my sitename.conf file was changed with those ports automatically by DevKinsta (after I changed those ports)

```auto
agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ head -8 agustest.conf 
server {
  set $site_name agustest;
  set $php_path devkinsta_fpm:9003;

  listen 51350;
  listen [::]:51350;
  listen 51351 ssl http2;
  listen [::]:51351 ssl http2;

```

I could still access the local URL just fine with that custom port (tested to open with FireFox in incognito mode):

 ![Screenshot from 2023-05-30 14-45-23](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/a/a6b546facf7c5676d02636ca34337df797a64999.png)

also I was able to call it via cURL command line (from the terminal), here’s the example results returned from that:

```auto
agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ curl -Ik https://agustest.local:51351/
HTTP/2 200 
server: nginx
date: Tue, 30 May 2023 07:53:06 GMT
content-type: text/html; charset=UTF-8
link: <https://agustest.local:51351/index.php?rest_route=/>; rel="https://api.w.org/"

```

and

```auto
agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ curl -k https://agustest.local:51351/
<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='max-image-preview:large' />
<title>agustest</title>
<link rel="alternate" type="application/rss+xml" title="agustest &raquo; Feed" href="https://agustest.local:51351/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="agustest &raquo; Comments Feed" href="https://agustest.local:51351/?feed=comments-rss2" />

```

Have you tried to access your local URL (with custom port) with different browser(s) to compare? and may also want to test via cURL command line to see the results? as I was not able to replicate the error on my local computer.

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![Aporia](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aporia/32/2031_2.png) [@Aporia](https://community.kinsta.com/u/Aporia)
#### Post date: [May 31, 2023, 12:37am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/18 "2023-05-31T00:37:02Z")

</div>

My ~/DevKinsta/nginx\_sites/cheeseclubhk.conf is not showing the changed ports. Why wouldn’t it get updated?

I manually updated that file. I had actually tried to update this file before, but I think I did it on the image, which might get overwritten?

Anyway, it is working. I am going to continue to play with this, including doing a sync. I am hoping for it work better so I can get some colleagues using it.

Thank you

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [May 31, 2023, 2:15am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/19 "2023-05-31T02:15:13Z")

</div>

Thank you for your reply Darcy 🙂  
I’m not sure either why that .conf file ( ~/DevKinsta/nginx\_sites/cheeseclubhk.conf ) wouldn’t get updated on your local computer.  
Mine got updated automatically each time I modified and saved the new ports in DevKinsta.

Before:

```auto
agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ ll
total 56
drwxrwxrwx 2 root root 4096 Mei 30 14:43 ./
drwxrwxrwx 9 root root 4096 Feb 11 22:52 ../
-rwxrwxrwx 1 agus agus 1025 Mei 30 14:43 agustest.conf*

agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ head -8 agustest.conf 
server {
  set $site_name agustest;
  set $php_path devkinsta_fpm:9003;

  listen 51350;
  listen [::]:51350;
  listen 51351 ssl http2;
  listen [::]:51351 ssl http2;

```

After I changed the ports once again in DevKinsta’s settings/port selector (to the default ports) :

```auto
agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ ll
total 56
drwxrwxrwx 2 root root 4096 Mei 31 07:40 ./
drwxrwxrwx 9 root root 4096 Feb 11 22:52 ../
-rwxrwxrwx 1 agus agus 1015 Mei 31 07:40 agustest.conf*

agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ head -8 agustest.conf 
server {
  set $site_name agustest;
  set $php_path devkinsta_fpm:9003;

  listen 80;
  listen [::]:80;
  listen 443 ssl http2;
  listen [::]:443 ssl http2;

agus@Lenovo-IdeaPad-FLEX-15IWL:~/DevKinsta/nginx_sites$ stat agustest.conf 
  File: agustest.conf
  Size: 1015 Blocks: 8 IO Block: 4096 regular file
Device: fd01h/64769d	Inode: 15098889 Links: 1
Access: (0777/-rwxrwxrwx) Uid: ( 1000/ agus) Gid: ( 1000/ agus)
Access: 2023-05-31 07:40:36.864561314 +0700
Modify: 2023-05-31 07:40:35.284540298 +0700
Change: 2023-05-31 07:40:35.284540298 +0700
 Birth: 2023-05-31 07:40:35.284540298 +0700

```

It didn’t require me to update this .conf file manually (I’ve never done/edited it).

Glad to hear it’s working! Sounds great! please take your time and hopefully your colleagues can also using it! 🙏 and you’re always welcome sir! 😃

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)
#### Post date: [June 3, 2023, 2:15am UTC](https://community.kinsta.com/t/dk0006-couldnt-download-docker-images/2277/20 "2023-06-03T02:15:19Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
