# errors.WP\_PARSE\_CONFIG DK0081 when trying to manually import a site downloaded from My Kinsta

**URL:** <https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828>\
**Category:** Application Support\
**Created:** [October 29, 2022, 6:59pm UTC](https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828 "2022-10-29T18:59:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chevas](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/chevas/32/1384_2.png) [@Chevas](https://community.kinsta.com/u/Chevas)\
**Post date:** [October 29, 2022, 6:59pm UTC](https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828/1 "2022-10-29T18:59:37Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:** 2022-10-29 - 12:00PM MST

**Q: DevKinsta Version**  
**A:** 2.8.0

**Q: OS Version**  
**A:** Windows 10

**Q: Docker Desktop Version**  
**A:** 4.11.1

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** DK0081 - errors.WP\_PARSE\_CONFIG

Since I continue to get the “Something Bad Happened” error when trying to use DevKinsta to automatically add a site from My Kinsta (["Something Bad Happened" when website is large, probably rsync, BUT?](https://community.kinsta.com/t/something-bad-happened-when-website-is-large-probably-rsync-but/1827)), I have opted to create a backup of the website in My Kinsta, then download the zip.

This I have done. Now I am trying to import the zip with DevKinsta and I am seeing this error.

I have reviewed [DevKinsta Error Codes - Kinsta®](https://kinsta.com/knowledgebase/devkinsta/error-codes/#dk0081)

The article says that this error will appear if it

1. cannot find wp-config.php, OR
2. The DB\_NAME variable is not found in the wp-config.php file, OR
3. {dbName}.sql is not found

My zip does have wp-config.php, inside of that file there is the DB\_Name variable, and in the root of the zip is the database SQL file.

The article also states that wp-config.php needs to be in the root of the zip. Well, in the root of the zip is the folder /public and the database.sql file. Inside of the /public folder are all the wordpress files, which includes wp-config.php. This was the structure that was auto-generated when I created the database. Did My Kinsta generate the zip file in such a way to make it incompatible with DevKinsta’s import feature?

I am really stuck trying to get my website downloaded locally.

---

<div class="post-metadata">

**Author:** ![elund](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/elund/32/1355_2.png) [@elund](https://community.kinsta.com/u/elund)\
**Post date:** [January 7, 2023, 10:36pm UTC](https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828/2 "2023-01-07T22:36:08Z")

</div>

Hi Chevas,

Did you find a solution for your issue?

I am getting the same error as you when importing a zip-file.  
But I don’t have the folder /public in my zip-file, so everything is in the root of the zip-file.

Best regards, Elund

---

<div class="post-metadata">

**Author:** ![Chevas](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/chevas/32/1384_2.png) [@Chevas](https://community.kinsta.com/u/Chevas)\
**Post date:** [January 8, 2023, 3:11am UTC](https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828/3 "2023-01-08T03:11:11Z")

</div>

Chances are pretty good that you have a file within one of your websites with a super offensive filename (some character that is weird or something stupid long).

> [@"Something Bad Happened" when website is large, probably rsync, BUT?](https://community.kinsta.com/t/something-bad-happened-when-website-is-large-probably-rsync-but/1827):
>
> Q: Date/Time this occurred (Provide your time zone also) A: 2022 October 28, 2022 - All day, 7-8 attempts Q: DevKinsta Version A: 2.8.0 Q: OS Version A: Windows 10 Q: Docker Desktop Version A: 4.11.1 Q: Were any error codes or messages observed? If so, what were they? A: “Something bad happened”. Q: Detailed Description of the Problem I am importing a bunch of my sites from Kinsta after a clean uninstall and reinstall of Docker and DevKinsta. I don’t have any problems for any of my s…

I hate checking logs, but this is one of those errors where I realized “it just needs to be done.”

@Kevin is also super helpful at finding what may be causing the error if you provide him yours.

---

<div class="post-metadata">

**Author:** ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)\
**Post date:** [January 9, 2023, 5:50am UTC](https://community.kinsta.com/t/errors-wp-parse-config-dk0081-when-trying-to-manually-import-a-site-downloaded-from-my-kinsta/1828/4 "2023-01-09T05:50:51Z")

</div>

Hello @elund 👋 welcome to DevKinsta community!

You may want to check the `main.log` file as shown here:

> **[DevKinsta Error Codes](https://kinsta.com/knowledgebase/devkinsta/error-codes/#info)**
>
> Find out what error codes may be returned in DevKinsta, what each of them means and how you can fix them.

and try to search for the `DK0081` error message in there (with text editor for example). It should tell the exact error message for that error code. If you’re experiencing any issues with it, feel free to send (DM) me your main.log file.

Also, as you mentioned that you don’t have the folder /public in your zip-file (everything is in the root of the zip file), then I would suggest the following:

1. Extract that .zip file on your local computer
2. Create a new directory and name it as _public_ , and then move the extracted WP files and its sub-folders, etc. into it. But the `databasename.sql` DB file should be located outside the /public folder.
3. After that, please try to compress them again (name it with a new .zip), so in the root of the new .zip file, there will be only `public` folder and that `databasename.sql` file, and see if you can then import that new .zip backup file to DevKinsta.

Cheers,  
Agus
