# Local Site Won't Open - ERR\_EMPTY\_RESPONSE

**URL:** <https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527>\
**Category:** Application Support\
**Created:** [June 4, 2024, 5:17pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527 "2024-06-04T17:17:46Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Brant\_Court](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/brant_court/32/3542_2.png) [@Brant\_Court](https://community.kinsta.com/u/Brant_Court)\
**Post date:** [June 4, 2024, 5:17pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/1 "2024-06-04T17:17:46Z")

</div>

Everything was working great. However, the other day I closed Docker without “Turning Off” the website through Kinsta.

Today trying to access the website, Docker wouldn’t load. I closed and reopened and it worked fine. But now when clicking “Open Site” or “WP Admin” I get this error:

This page isn’t working burlington-krown.local didn’t send any data.  
ERR\_EMPTY\_RESPONSE

All containers are running on Docker.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/83e4d6c34505e7753188d31d45ead7a0b39ab383.png)

Is this a common issue with a quick fix? Everything was working great until I made the mistake of leaving the site “on” whilst closing docker.

---

<div class="post-metadata">

**Author:** ![jackirish](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jackirish/32/1361_2.png) [@jackirish](https://community.kinsta.com/u/jackirish)\
**Post date:** [June 4, 2024, 8:32pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/2 "2024-06-04T20:32:14Z")

</div>

Hi @Brant_Court ! 👋 Welcome to the Kinsta Community.

Hm. Usually that error indicates Docker is having an issue launching or maintaining a service.

Can you please send me your main.log file from the site via a DM? [Troubleshooting - Error Codes - Kinsta® Docs](https://kinsta.com/docs/devkinsta/devkinsta-troubleshooting/error-codes/#viewing-the-application-log-file)

---

<div class="post-metadata">

**Author:** ![Brant\_Court](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/brant_court/32/3542_2.png) [@Brant\_Court](https://community.kinsta.com/u/Brant_Court)\
**Post date:** [June 4, 2024, 8:36pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/3 "2024-06-04T20:36:01Z")

</div>

Hope this helps, thank you.

---

<div class="post-metadata">

**Author:** ![jackirish](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jackirish/32/1361_2.png) [@jackirish](https://community.kinsta.com/u/jackirish)\
**Post date:** [June 4, 2024, 9:04pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/5 "2024-06-04T21:04:47Z")

</div>

Thank you for providing that; I’ve removed the log files from the public post for security.

Looking over the most recent logs, the latest error is

`[2024-06-04 14:50:33.040] [error] watchDocker - Error: connect ENOENT //./pipe/docker_engine`

Which unfortunately indicates an issue within Docker itself, possibly because a container is failing to launch properly.

Attempting to start Docker as an administrator may help resolve this.

Alternatively, a full reinstall of Docker may be necessary. You can make a copy of your local site’s files that are saved under this sub-folder (to be copied to somewhere else as a backup):  
`C:\Users\<your user>\DevKinsta\public\site-name`  
(for example: `C:\Users\Brant_Court\DevKinsta\public\site-name` )  
That site’s subdirectory contains your WordPress files (and sub-folders) used for that specific site.

Then you can also need to get a backup of that site’s data (which is stored in the database) via the [Adminer database manager/tool](https://kinsta.com/knowledgebase/devkinsta/database-manager/) to export your specific site’s database (to be exported/dumped into `.sql` file), then you can save that .sql database file as your site’s DB backup.

Once you have both files and DB backed up, please remove and clean-up DevKinsta completely - remove/delete any folders and data related to it, for example, inside these folders:  
`C:\Users\<your user>\AppData\Roaming\DevKinsta`,  
and  
`C:\Users\<your user>\DevKinsta`.

And please remove all containers, images, network volumes, etc. in your Docker Desktop. Once they’re removed completely, please restart your computer, then you may want to re-install Docker Desktop first, and once done, you can re-install DevKinsta (it will re-download/setup new images/containers from scratch). Then please try to create a new local site there and see if you’re able to launch the site. If not, a new **main.log** file may be necessary.

---

<div class="post-metadata">

**Author:** ![Brant\_Court](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/brant_court/32/3542_2.png) [@Brant\_Court](https://community.kinsta.com/u/Brant_Court)\
**Post date:** [June 4, 2024, 9:30pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/6 "2024-06-04T21:30:26Z")

</div>

Okay thanks for the response. I should mention - I am able to “Add Site” in the Kinsta App and I can access the WP Dashboard on a new install. But not sure why first website stopped working.

---

<div class="post-metadata">

**Author:** ![jackirish](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jackirish/32/1361_2.png) [@jackirish](https://community.kinsta.com/u/jackirish)\
**Post date:** [June 4, 2024, 9:50pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/7 "2024-06-04T21:50:44Z")

</div>

Hm. In the DevKinsta settings, is the checkbox “Auto-detect open ports” enabled or disabled?

---

<div class="post-metadata">

**Author:** ![Brant\_Court](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/brant_court/32/3542_2.png) [@Brant\_Court](https://community.kinsta.com/u/Brant_Court)\
**Post date:** [June 4, 2024, 10:00pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/8 "2024-06-04T22:00:19Z")

</div>

The “Auto-detect open ports” is enabled.

---

<div class="post-metadata">

**Author:** ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)\
**Post date:** [June 4, 2024, 10:12pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/9 "2024-06-04T22:12:59Z")

</div>

Hi @Brant_Court 👋

Please uncheck “Auto-detect open ports” and set port 80 for HTTP and 443 for HTTPS. Then, check your site on a new private browser (E.g., Incognito in Chrome). Let me know if this helps make your site accessible again.

---

<div class="post-metadata">

**Author:** ![Brant\_Court](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/brant_court/32/3542_2.png) [@Brant\_Court](https://community.kinsta.com/u/Brant_Court)\
**Post date:** [June 4, 2024, 10:32pm UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/10 "2024-06-04T22:32:23Z")

</div>

That resolved it, thank you very much.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)\
**Post date:** [June 7, 2024, 10:33am UTC](https://community.kinsta.com/t/local-site-wont-open-err-empty-response/3527/11 "2024-06-07T10:33:16Z")

</div>

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.
