# MySQL Dump Error DK0029

**URL:** https://community.kinsta.com/t/mysql-dump-error-dk0029/287
**Category:** Bug Reports
**Created:** [January 29, 2021, 10:14pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287 "2021-01-29T22:14:57Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![todrick](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/todrick/32/220_2.png) [@todrick](https://community.kinsta.com/u/todrick)
#### Post date: [January 29, 2021, 10:14pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/1 "2021-01-29T22:14:57Z")

</div>

imported a site  
made changes  
pushed to staging  
pushed live

Then added my first additional site(It’s a multisite)

Deleted local

Tried to import again and get the DK0029 error

Tried to import a different site, works fine.

Deleted additional site i’d added

DK0029

I’m stuck here… I need to be able to edit multisite, but cant even get the site as it existed.  
I’d expected to be able to add sites to the multisite locally, then push… but when I clicked network admin it goes to the live site… so my only idea was delete local and re-import… but that doesn’t work

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [January 29, 2021, 11:50pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/2 "2021-01-29T23:50:59Z")

</div>

Hi @todrick . I’m sorry for the issues here. When it worked prior to adding your first additional site, am I understanding this correctly that only the main site existed and it wasn’t until you added a subsite that it started to cause issues?

---

<div class="post-metadata">

### Author: ![todrick](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/todrick/32/220_2.png) [@todrick](https://community.kinsta.com/u/todrick)
#### Post date: [January 31, 2021, 2:46am UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/3 "2021-01-31T02:46:36Z")

</div>

yes, @michael, that’s correct.

I had set it up as a multisite… and when I pulled it down on devkinsta i set it as a subdirectory multisite… even though it was only the primary site at that point.

then after adding the first multisite, it won’t download.

Also of note, the new multisite, does not display correctly… the site, on the kinsta live host, displays as if it has no CSS file. though the original master site works fine

---

<div class="post-metadata">

### Author: ![todrick](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/todrick/32/220_2.png) [@todrick](https://community.kinsta.com/u/todrick)
#### Post date: [January 31, 2021, 5:29am UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/4 "2021-01-31T05:29:38Z")

</div>

OK, I nuked the entire site off Kinsta and started over…

Seems to work again… But I’m right at the stage where i want to add that new site to the multisite.

Is there no “pull” to update the local site with whatever exists on the live server?

---

<div class="post-metadata">

### Author: ![todrick](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/todrick/32/220_2.png) [@todrick](https://community.kinsta.com/u/todrick)
#### Post date: [January 31, 2021, 5:57am UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/5 "2021-01-31T05:57:52Z")

</div>

AND… it broke the download again… back to where I started.

DK0029

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [February 1, 2021, 8:37pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/6 "2021-02-01T20:37:01Z")

</div>

Thanks for the info. Our developers will take a look at this further.

> [@todrick](#):
>
> Is there no “pull” to update the local site with whatever exists on the live server?

At this time DevKinsta will only pull the staging site.

---

<div class="post-metadata">

### Author: ![robert](https://avatars.discourse-cdn.com/v4/letter/r/e95f7d/32.png) [@robert](https://community.kinsta.com/u/robert)
#### Post date: [February 2, 2021, 4:50pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/7 "2021-02-02T16:50:28Z")

</div>

I’m having the same issue as Todrick outlined:

imported a site  
made changes  
pushed to staging  
pushed to live  
deleted existing local copy  
attempted to import from live (DK0029 error: Can’t create mysql dump)

In my case though, the site is not a multisite.

Update:  
imported the site from staging without error

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [February 3, 2021, 4:16pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/8 "2021-02-03T16:16:49Z")

</div>

Hi @robert . Sorry for the trouble! We’ll have more on this shortly.

---

<div class="post-metadata">

### Author: ![aidenberzins](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aidenberzins/32/260_2.png) [@aidenberzins](https://community.kinsta.com/u/aidenberzins)
#### Post date: [February 7, 2021, 9:50pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/9 "2021-02-07T21:50:38Z")

</div>

I am also experiencing the same issue of DK0029.  
Only on one of the two sites that I have pulled. One of them had no issue from the jump and still seems to be working fine but even after 24 hours of trying to pull it will not allow me to pull the staging site.

---

<div class="post-metadata">

### Author: ![ahonshaw](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/ahonshaw/32/339_2.png) [@ahonshaw](https://community.kinsta.com/u/ahonshaw)
#### Post date: [March 2, 2021, 5:10am UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/10 "2021-03-02T05:10:28Z")

</div>

I got the same issue. I have contacted Mykinsta support. This is what they said “On our end however the mysqldump issue seems to be resolve but there are still some issue that could not troubleshoot as only the DevKinsta team have access to it.”

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [March 2, 2021, 4:33pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/11 "2021-03-02T16:33:11Z")

</div>

Hi @ahonshaw . Welcome to DevKinsta. I’m sorry for the issues here. That’s correct that the two mysqldump issues are separate. We’ll work on resolving this on DevKinsta.

---

<div class="post-metadata">

### Author: ![anon90552464](https://avatars.discourse-cdn.com/v4/letter/a/b2d939/32.png) [@anon90552464](https://community.kinsta.com/u/anon90552464)
#### Post date: [January 26, 2021, 1:58pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/12 "2021-01-26T13:58:37Z")

</div>

Hi guys!  
I was trying to clone/copy a site using DevKinsta and I got a DK0029 error: Can’t create mysql dump.  
The thing is that the database it’s large (~ 2.5 gb). Is there any way I can solve this? I’ve tried to execute like 4 times, but I got DK0029.

Thanks!

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [January 26, 2021, 5:53pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/13 "2021-01-26T17:53:16Z")

</div>

Hi @anon90552464 . Thanks for reaching out and welcome to DevKinsta 🙂  
Sorry for the issues you’re experiencing there. Does this occur on all sites pulled from Kinsta? Do you happen to have more than one site you’d be able to test with?

---

<div class="post-metadata">

### Author: ![anon90552464](https://avatars.discourse-cdn.com/v4/letter/a/b2d939/32.png) [@anon90552464](https://community.kinsta.com/u/anon90552464)
#### Post date: [January 26, 2021, 7:02pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/14 "2021-01-26T19:02:22Z")

</div>

Thanks for your reply @michael. I only tested with this site. I will test with another one and will let you know. The issue is that this was the one I needed and I think it is because of the database size.

---

<div class="post-metadata">

### Author: ![aidenberzins](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aidenberzins/32/260_2.png) [@aidenberzins](https://community.kinsta.com/u/aidenberzins)
#### Post date: [February 7, 2021, 9:53pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/15 "2021-02-07T21:53:35Z")

</div>

I am having the same issue. One site pulled totally fine. The other does not want to pull at all and continues to get stuck on the mysql dump as well

---

<div class="post-metadata">

### Author: ![aidenberzins](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/aidenberzins/32/260_2.png) [@aidenberzins](https://community.kinsta.com/u/aidenberzins)
#### Post date: [February 7, 2021, 10:36pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/16 "2021-02-07T22:36:23Z")

</div>

@michael  
@anon90552464

I did manage to figure out the issue for my particular case.

if you do not have wp\_ as the only prefix it will not allow you to download the database.  
There seemed to have been wp\_ and an additional prefix duplicate in my DB and removing the duplicates resolved the issue.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [February 8, 2021, 4:25pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/17 "2021-02-08T16:25:24Z")

</div>

Great find @aidenberzins ! Thanks for reporting back your findings. We’ll research this more closely and provide an update here.

---

<div class="post-metadata">

### Author: ![aphantasianetwork](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@aphantasianetwork](https://community.kinsta.com/u/aphantasianetwork)
#### Post date: [March 14, 2021, 5:56pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/18 "2021-03-14T17:56:03Z")

</div>

hi @michael ,

I’m also having a similar issue while importing the site on DevKinsta.

Thing is we have custom views created on our database (they also have “wp\_” prefix).

But it looks like DevKinsta is unable to import database having views other than standard WP tables.

I’m able to import the site if I manually drop views first.

Can you please have a look into it?

Thanks.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [March 15, 2021, 4:44pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/19 "2021-03-15T16:44:00Z")

</div>

Welcome to DevKinsta @aphantasianetwork ! Thank you for the additional information. I’ll pass this on to the devs here.

---

<div class="post-metadata">

### Author: ![Joona\_Penttila](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/joona_penttila/32/426_2.png) [@Joona\_Penttila](https://community.kinsta.com/u/Joona_Penttila)
#### Post date: [April 14, 2021, 12:52pm UTC](https://community.kinsta.com/t/mysql-dump-error-dk0029/287/21 "2021-04-14T12:52:20Z")

</div>

Hi, I got also same issue and can’t create mysql dump, mysql size is around 600Mb

[Next page](https://community.kinsta.com/t/mysql-dump-error-dk0029/287.md?page=2)
