# Non-saying error

**URL:** <https://community.kinsta.com/t/non-saying-error/1603>\
**Category:** Application Support\
**Created:** [July 7, 2022, 9:17am UTC](https://community.kinsta.com/t/non-saying-error/1603 "2022-07-07T09:17:52Z")\
**Posts on this page:** 14\
**Page:** 2

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 11, 2022, 5:44pm UTC](https://community.kinsta.com/t/non-saying-error/1603/21 "2022-07-11T17:44:47Z")

</div>

I was able to reproduce that error by deleting my certificates. I’m not sure when/how those were deletec from your computer.  
I have asked our developers for a quickfix for this. We basically just need to manually create the ssl certificate. I will contact you once they tell me. Thank you for your patience here @jarno. We’ve never anyone run into this so it’s a brand new error.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 12, 2022, 4:28pm UTC](https://community.kinsta.com/t/non-saying-error/1603/22 "2022-07-12T16:28:33Z")

</div>

Hi @jarno, this is the process the Developers gave me to generate a new certificate so that NGINX can start:

1. `cd ~/DevKinsta/ssl`
2. `openssl genrsa 2048 > odonna-1.local.key`
3. `openssl req -new -x509 -nodes -sha256 -days 365 -key odonna-1.local.key -out odonna-1.local.crt`
4. Answer anything to the prompt questions until you are asked for the “Common Name”. For this you enter `odonna-1.local`
5. With those files created you should delete `devkinsta_nginx` again before reopening DevKinsta.

It _should_ now get past that error, if it doesn’t please share the logs. Once you get back into DevKinsta, please make sure the site still works without issues. You can also go to that specific site’s page and disable SSL  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/7/7b561f2d1ddab9ace609cdd832a219c3cdadeb16.png)

After it is disabled, you can delete the SSL certificate that you manually created. Enabling SSL and HTTPS again should allow DevKinsta to create the certificate for you.

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 12, 2022, 5:04pm UTC](https://community.kinsta.com/t/non-saying-error/1603/23 "2022-07-12T17:04:34Z")

</div>

Yes, that worked. Now, I’m encountering the next issue, related to the database. When trying to delete a site, I get a DK0051 error.

I’ve tried to install mysql with Docker:

```auto
sudo docker pull mysql/mysql-server:latest

```

I get this error when I open database manager:

```auto
Warning
: Cannot modify header information - headers already sent by (output started at /var/www/html/adminer.php:181) in
/var/www/html/adminer.php
on line
1528

Warning
: Cannot modify header information - headers already sent by (output started at /var/www/html/adminer.php:181) in
/var/www/html/adminer.php
on line
1436

```

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 12, 2022, 5:33pm UTC](https://community.kinsta.com/t/non-saying-error/1603/24 "2022-07-12T17:33:06Z")

</div>

Devkinsta uses Mariadb and not Mysql. You could try deleting the mariadb container and letting DevKinsta recreate it but you will need to send me the main.log for the DK0051 error.

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 12, 2022, 5:46pm UTC](https://community.kinsta.com/t/non-saying-error/1603/25 "2022-07-12T17:46:18Z")

</div>

[main.log|attachment]

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 12, 2022, 6:33pm UTC](https://community.kinsta.com/t/non-saying-error/1603/26 "2022-07-12T18:33:45Z")

</div>

Do you know why this is happening? Did you change anything with your computer before this started?

> Cannot select database The database server could be connected to (which means your username and password is okay) but the database could not be selected.

All of your database connections say “Unknown database.” Did you delete the kinsta database or something? Does your database manager show your databases?

Also, are you trying to delete all of your websites to start over? Or are you only deleting some of them?

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 13, 2022, 8:01am UTC](https://community.kinsta.com/t/non-saying-error/1603/27 "2022-07-13T08:01:12Z")

</div>

One of my sites got stuck on pulling from Kinsta. I tried to delete that site and start the process again, but that led to all of the issues I’m having now.

When I open my database manager, I see the error from the message I sent before the main.log.

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 14, 2022, 12:11am UTC](https://community.kinsta.com/t/non-saying-error/1603/28 "2022-07-14T00:11:51Z")

</div>

Hmm, a single site failing shouldn’t cause this but this might be something new. Can you update to DevKinsta 2.7.0?

Once done please **private message** your config.json file to me. I’ll see if the database connection information is still correct. You’re config.json will be here for Mac:

`User/Library/Application Support/DevKinsta`

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 17, 2022, 1:42pm UTC](https://community.kinsta.com/t/non-saying-error/1603/29 "2022-07-17T13:42:36Z")

</div>

I just updated to 2.7.0. The issue is in the databases. I still have a full\_backup.sql file, containing database info of all my sites. Where can I import this file, so that my databases are restored?

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 18, 2022, 5:09pm UTC](https://community.kinsta.com/t/non-saying-error/1603/30 "2022-07-18T17:09:27Z")

</div>

Okay perfect; so you can use the database manager to import the SQL  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/c/c18fe84eb8769e188be71aae480464974af9b95a.png)  
You can import to specific sites

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/0/0a345ba48d0d60f2877ede63db23fae491cabb93.png)

Or just the entire database depending on what your backup SQL contains.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/7/790fee8b0790ad4cbad12c0e21ad0d68f2960d0f.png)

Or if you have a database management application/program you can use the credentials under “Site Info \> Database” to connect to your DevKinsta database. It will work the same way as the Database Manager.

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 18, 2022, 5:23pm UTC](https://community.kinsta.com/t/non-saying-error/1603/31 "2022-07-18T17:23:43Z")

</div>

I’m getting this error when I open the database manager:

 ![CleanShot 2022-07-18 at 19.23.13@2x](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/b/b1cabdf9cc79746850e706fce32e9569421f3d8a.png)

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 18, 2022, 5:29pm UTC](https://community.kinsta.com/t/non-saying-error/1603/32 "2022-07-18T17:29:16Z")

</div>

Click on the dropdown and select the blank option. What does that do?  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/f/f87716d020c1b18527c21c192951494dee334dfa.png)

The URL will be something like this: [http://127.0.0.1:15200/?server=devkinsta\_db&username=root&import=](http://127.0.0.1:15200/?server=devkinsta_db&username=root&import=)

---

<div class="post-metadata">

**Author:** ![jarno](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jarno/32/4097_2.png) [@jarno](https://community.kinsta.com/u/jarno)\
**Post date:** [July 18, 2022, 5:42pm UTC](https://community.kinsta.com/t/non-saying-error/1603/33 "2022-07-18T17:42:33Z")

</div>

That helps! The full\_backup.sql file is too big to upload. Can I upload via CLI?

 ![CleanShot 2022-07-18 at 19.41.41@2x](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/9/9885cb770d73b33bd769e92f27c70025cd7410e5.png)

---

<div class="post-metadata">

**Author:** ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)\
**Post date:** [July 18, 2022, 6:32pm UTC](https://community.kinsta.com/t/non-saying-error/1603/34 "2022-07-18T18:32:37Z")

</div>

Yes it should be possible. I’m not on Mac but the command should be the same. Something like this:

`docker exec -i devkinsta_db bash -l -c "mysql -uroot -p{thepasswordnospace} < /path/to/backup.sql"`

There is a thread [here](https://gist.github.com/geraldvillorente/4c60e7fdb5562f443f16ad2bbe4235ce) with ideas if you run into issues.

The plain command for accessing the mysql container is `exec -it devkinsta_db bash`

[Previous page](https://community.kinsta.com/t/non-saying-error/1603.md?page=1)
