# Pulling Database getting DK0029 error code

**URL:** https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058
**Category:** Bug Reports
**Created:** [February 8, 2023, 10:18pm UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058 "2023-02-08T22:18:49Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![monofrio](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/monofrio/32/2577_2.png) [@monofrio](https://community.kinsta.com/u/monofrio)
#### Post date: [February 8, 2023, 10:18pm UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/1 "2023-02-08T22:18:49Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A: Feb 8 2023**

**Q: DevKinsta Version**  
\*\*A: Version 2.9.0 (2.9.0.6039) \*\*

**Q: OS Version**  
**A: 12.6**

**Q: Docker Desktop Version**  
\*\*A: 3.6.0 (3.6.0.5487) \*\*

**Q: Were any error codes or messages observed? If so, what were they?**  
**A: when just trying to pull database from live server**

**Q: Detailed Description of the Problem**  
\*\*A: pulling the database constantly give me this error  
 ![Screen Shot 2023-02-08 at 5.18.24 PM](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/a/ac179a16518fa04a231232c978d76c2f7e9dd258.png)  
\*\*

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [February 9, 2023, 12:41am UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/2 "2023-02-09T00:41:50Z")

</div>

Hello @monofrio 👋 Welcome to DevKinsta community!

Thank you for reaching us out!

That [DK0029](https://kinsta.com/knowledgebase/devkinsta/error-codes/#dk0029) error (during that process - pull/import site from MyKinsta) means DevKinsta is unable to create a MySQL dump on the remote / host server.

To check it further, please kindly check the `main.log` file on your computer (open it with your local text editor) and locate/search for “DK0029” .You can [check here](https://kinsta.com/knowledgebase/devkinsta/error-codes/#viewing-the-application-log-file) to see how to see/get that main.log file.

Similar to [this case discussed here](https://community.kinsta.com/t/can-t-create-mysql-dump-dk0029/2037/3), if it’s showing something like this:

```auto
[error] Error - DK0029: MYSQL_DUMP_COMMON: Error (3): {mysqldump: Error 2020: Got packet bigger than 'max_allowed_packet' when dumping table `any_wp_table` at row: XXX

```

then you can then reach out to our support ( via chat from [my.kinsta.com](http://my.kinsta.com/)) and please ask them to **temporarily** increase the " `max_allowed_packet` " value (let’s say to 64M) for the `[mysqldump]` section of your site in question (hosted on our Kinsta server).

In case you’re experiencing any issues to read the `main.log` , please send that main.log file to me (via DM/PM), so I can check and review that `DK0029` error in there.

After that, you may want to give it a try to pull / import that site in question, and see if it’s no longer throwing [DK0029](https://kinsta.com/knowledgebase/devkinsta/error-codes/#dk0029) error message.

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![monofrio](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/monofrio/32/2577_2.png) [@monofrio](https://community.kinsta.com/u/monofrio)
#### Post date: [February 9, 2023, 7:55pm UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/3 "2023-02-09T19:55:45Z")

</div>

I did have the original error in my log, and had support increase but I’m I’m now coming up with this error code when pulling from live: Error DK0066

Error - DK0066: IMPORT\_DB\_DUMP: Error (1): VERROR 1153 (08S01) at line 1150: Got a packet bigger than ‘max\_allowed\_packet’ bytes

---

<div class="post-metadata">

### Author: ![monofrio](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/monofrio/32/2577_2.png) [@monofrio](https://community.kinsta.com/u/monofrio)
#### Post date: [February 9, 2023, 11:12pm UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/4 "2023-02-09T23:12:03Z")

</div>

I resolved this by updating my.cnf file within the docker devkinsta\_db database container. Added max\_allowed\_packet=64M and was able to pull the database down.

You will also need to install nano text editor into the local docker container to update the file.  
example found here: [How to Edit post\_max\_size in PHP Configuration - #3 by AlexM](https://community.kinsta.com/t/how-to-edit-post-max-size-in-php-configuration/266/3)

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [February 10, 2023, 3:25am UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/5 "2023-02-10T03:25:40Z")

</div>

Heya @monofrio ,

Thank you for your reply and update!  
Yeah, I just checked and could see that you reached out to our support team and asked them to increase the `max_allowed_packet` to 64M on your r3 site (but you then got another [error code `DK0066`](https://kinsta.com/knowledgebase/devkinsta/error-codes/#dk0066)).

The support engineer also provided you the link to our doc of that error code and confirmed that the Database of your site on the server side is running fine. So there was likely an issue on the DevKinsta side - and in this case, as you’ve already found out the issue (as also mentioned in the error message you shared, about `IMPORT_DB_DUMP` and `max_allowed_packet`), that you solved it by adding the `max_allowed_packet=64M` line to the `/etc/mysql/my.cnf` file within the `devkinsta_db` docker’s DB container on you local computer! 👏 👍 😄

Thank you for sharing your solution here for this case, and this should help other users in the future (in case they’re experiencing similar case).

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)
#### Post date: [February 13, 2023, 3:39am UTC](https://community.kinsta.com/t/pulling-database-getting-dk0029-error-code/2058/7 "2023-02-13T03:39:22Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
