# Renaming site, DK0073

**URL:** https://community.kinsta.com/t/renaming-site-dk0073/5231
**Category:** Bug Reports
**Created:** [June 30, 2025, 7:18pm UTC](https://community.kinsta.com/t/renaming-site-dk0073/5231 "2025-06-30T19:18:11Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![krisl](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/krisl/32/4860_2.png) [@krisl](https://community.kinsta.com/u/krisl)
#### Post date: [June 30, 2025, 7:18pm UTC](https://community.kinsta.com/t/renaming-site-dk0073/5231/1 "2025-06-30T19:18:11Z")

</div>

I cannot successfully rename a site. I can reproduce this issue.  
Site is named “[kitchensbycountryside.com](http://kitchensbycountryside.com)”. Root path is /www/kinsta/public/kitchensbycountrysidecom;

When i trigger a rename (to “[OLDkitchensbycountryside.com](http://OLDkitchensbycountryside.com)”.), it immediately fails with a DK0073 - Could not restart nginx error.

If I manually try to restart the nginx server (in Docker), it fails to restart and fails with the following error:

nginx: [emerg] cannot load certificate “/www/kinsta/ssl/oldoldkitchensbycountrysidecom.local.crt”: BIO\_new\_file() failed (SSL: error:80000002:system library::No such file or directory:calling fopen(/www/kinsta/ssl/oldoldkitchensbycountrysidecom.local.crt, r) error:10000080:BIO routines::no such file)

What looks like what is happening, is the function is adding an additional “old” to the path.

Finally, it works if I rename the site “oldkitchensbycountrysidecom”.

**Q: DevKinsta Version**  
\*\*A: 2.13.4

**Q: OS Version**  
\*\*A: Mac OS 15.5

**Q: Docker Desktop Version**  
\*\*A: 4.42.1

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [July 1, 2025, 5:04am UTC](https://community.kinsta.com/t/renaming-site-dk0073/5231/2 "2025-07-01T05:04:15Z")

</div>

Hi @krisl,

Welcome to the Kinsta Community!

I can confirm that I have replicated this issue on both Windows and Mac. When renaming the site by adding characters to the beginning of the name (for example, **anythinghere** currentsitename), DevKinsta displays DK0073. However, it works correctly if the characters are added to the end or if the name is changed entirely. I will forward this report to our Development team. Thank you for bringing this to our attention.
