# Seeing 404 Error for NGINX on loading local sites

**URL:** https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930
**Category:** Application Support
**Created:** [December 6, 2022, 7:46pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930 "2022-12-06T19:46:15Z")
**Posts on this page:** 14
**Page:** 1

<div class="post-metadata">

### Author: ![steckinsights](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/steckinsights/32/1476_2.png) [@steckinsights](https://community.kinsta.com/u/steckinsights)
#### Post date: [December 6, 2022, 7:46pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/1 "2022-12-06T19:46:15Z")

</div>

Dev Kinsta has worked for me in the past. Not sure if this is a result of the recent Mac OS X upgrade (Ventura - 13.0.1) conflicting with Dev Kinsta (version 2.9.0).

But when I launch the site or wp-admin, I get an NGINX 404 Not Found error.

Any thoughts on what could be causing this?

---

<div class="post-metadata">

### Author: ![Bozabit](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/bozabit/32/1687_2.png) [@Bozabit](https://community.kinsta.com/u/Bozabit)
#### Post date: [December 6, 2022, 11:53pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/2 "2022-12-06T23:53:23Z")

</div>

I having the same issue and it’s driving me nuts. I’ve tried with ssl and without it. Tried to change nginx configuration but nothings seems to work. It goes stratight to 404 on any site and any address.

It must be related to 2.9.0 in ventura yes…

---

<div class="post-metadata">

### Author: ![Joe\_Young](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/joe_young/32/1689_2.png) [@Joe\_Young](https://community.kinsta.com/u/Joe_Young)
#### Post date: [December 7, 2022, 12:11am UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/3 "2022-12-07T00:11:19Z")

</div>

Same here… Looking for a solution and can’t seem to track one down.

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [December 7, 2022, 2:32am UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/4 "2022-12-07T02:32:31Z")

</div>

Hello everyone 👋  
@steckinsights (Brian Steck), @Bozabit (Daniel Alvarez Echenagucia), and @Joe_Young  
welcome to DevKinsta community!

Thank you for reporting this issue.  
I’m not able to reproduce this issue on my end, cause I don’t have Mac machine here, and only have Linux laptop (based on _Bionic/Ubuntu 18.04.5_) - and I’ve just replaced/upgraded the DevKinsta from 2.8.0 to 2.9.0 version.

So far the previous sites I created (as well as new site I created just now) are all working/loading just fine (I don’t get NGINX 404 Not found error) with the current DevKinsta 2.9.0 on my Linux laptop.

I will report and ask my colleague and internal dev team to test this DevKinsta 2.9.0 on Mac OS Ventura, and see if they can replicate the same issue with it.  
We will update you all again here as soon as we have more information/update from them.

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [December 7, 2022, 7:32am UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/5 "2022-12-07T07:32:44Z")

</div>

Hello again: @steckinsights (Brian Steck), @Bozabit (Daniel Alvarez Echenagucia), and @Joe_Young 😃

1 of our DevKinsta devs has just tested to reproduce this reported issue on his **Mac OS Ventura** (and **DevKinsta 2.9.0** ), and he was able to create a new site with it without any issues (didn’t get NGINX 404 error when he accessed that site), and this doesn’t look like an OS related issue as per his test.

To check and investigate this further, could you please provide (copy-paste) the contents of your:

1. `/etc/hosts` file  
( at least for the DevKinsta section, between “_#### START DEVKINSTA entries_” and “_#### END DEVKINSTA entries_” )

2. nginx config file for the particular site in question (in the `~/DevKinsta/nginx_sites/the-site-name.conf` file)

Also, could you please clarify if this 404 error not found happening only on your pre-existing sites (created before DevKinsta 2.9.0), or if it’s also happening to the new created sites as well?

Cheers,  
Agus

---

<div class="post-metadata">

### Author: ![Joe\_Young](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/joe_young/32/1689_2.png) [@Joe\_Young](https://community.kinsta.com/u/Joe_Young)
#### Post date: [December 7, 2022, 3:39pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/6 "2022-12-07T15:39:22Z")

</div>

I can verify that the issue seems to be exclusive to existing sites before the upgrade. New sites seem to work fine. Meaning I can create a new site and everything works as expected.

I will look into the files you are suggesting and post my findings

---

<div class="post-metadata">

### Author: ![Bozabit](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/bozabit/32/1687_2.png) [@Bozabit](https://community.kinsta.com/u/Bozabit)
#### Post date: [December 7, 2022, 3:40pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/7 "2022-12-07T15:40:29Z")

</div>

New sites and pre-existing sites for me…

 ![Screenshot 2022-12-07 at 9.35.58](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/5/5434e7f8741e678be4513d39c5fa02c27fc259a9.png)

It happens with all sites… an sending just one ngix config as they are all the same

---

<div class="post-metadata">

### Author: ![Bozabit](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/bozabit/32/1687_2.png) [@Bozabit](https://community.kinsta.com/u/Bozabit)
#### Post date: [December 7, 2022, 3:41pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/8 "2022-12-07T15:41:11Z")

</div>

Here is the ngix config…

 ![Screenshot 2022-12-07 at 9.41.00](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/2/20b3f2fb5dc48837d5dcc9025ead431e517195e6.png)

---

<div class="post-metadata">

### Author: ![Alessandro](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/alessandro/32/2310_2.png) [@Alessandro](https://community.kinsta.com/u/Alessandro)
#### Post date: [December 7, 2022, 3:46pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/9 "2022-12-07T15:46:39Z")

</div>

Thank you both for your replies. @Bozabit , that Nginx configuration would explain why the site is returning 404. Can you please make a safe copy of the current Nginx conf file and then replace the original with the following:

```auto
server {
  set $site_name tubrica-81-version;
  set $php_path devkinsta_fpm:9004;

  listen 80;
  listen [::]:80;
  listen 443 ssl http2;
  listen [::]:443 ssl http2;

  

  ssl_certificate /www/kinsta/ssl/tubrica-81-version.net.crt;
  ssl_certificate_key /www/kinsta/ssl/tubrica-81-version.net.key;

  server_name tubrica-81-version.net *.tubrica-81-version.net;
  access_log /www/kinsta/logs/tubrica-81-version_access.log main;
  error_log /www/kinsta/logs/tubrica-81-version_error.log;

  root /www/kinsta/public/tubrica-81-version;
  index index.php index.html;

  include multisite_subdir.conf;

  location / {
      try_files $uri $uri/ /index.php?$args;
  }

  location ~ \.php$ {
      fastcgi_split_path_info ^(.+?\.php)(/.*)$;
      if (!-f $document_root$fastcgi_script_name) {
        return 404;
      }
      include fastcgi_params;
      fastcgi_param PHP_ADMIN_VALUE "sendmail_from=devkinsta@tubrica-81-version.net";
      fastcgi_intercept_errors on;
      fastcgi_pass $php_path;
      fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  }
}

```

I’ll report back to our devs to investigate why the Nginx config has been edited in the first place.

---

<div class="post-metadata">

### Author: ![Bozabit](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/bozabit/32/1687_2.png) [@Bozabit](https://community.kinsta.com/u/Bozabit)
#### Post date: [December 7, 2022, 4:12pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/10 "2022-12-07T16:12:53Z")

</div>

It worked… Yes I saw tht 404 as well but I know litle to nothing about nginx and all the other were exactly the same.

---

<div class="post-metadata">

### Author: ![Alessandro](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/alessandro/32/2310_2.png) [@Alessandro](https://community.kinsta.com/u/Alessandro)
#### Post date: [December 7, 2022, 4:15pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/11 "2022-12-07T16:15:12Z")

</div>

That is good news @Bozabit, thank you for sharing. Closing DevKinsta, removing the Nginx config file, and then starting DevKinsta again should also regenerate the file properly.

Regards,

Alessandro

---

<div class="post-metadata">

### Author: ![Joe\_Young](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/joe_young/32/1689_2.png) [@Joe\_Young](https://community.kinsta.com/u/Joe_Young)
#### Post date: [December 7, 2022, 11:11pm UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/12 "2022-12-07T23:11:36Z")

</div>

I can verify that by simply deleting the nginx\_sites/site-name.conf file and restarting devKinsta fixed my issue.

Thanks for the help! 👊🏼✌🏼

---

<div class="post-metadata">

### Author: ![Agus](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/agus/32/1515_2.png) [@Agus](https://community.kinsta.com/u/Agus)
#### Post date: [December 8, 2022, 12:19am UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/13 "2022-12-08T00:19:50Z")

</div>

Great to hear that workaround helps to fix the issue @Joe_Young ! 👏  
so I think that’s the solution for this issue that we can follow right now 👍

We’ve also reported this case to our internal devs to check/investigate further and to see if we can find the root cause for it (why the NGINX site config file has been modified/edited in the first place).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)
#### Post date: [December 11, 2022, 12:20am UTC](https://community.kinsta.com/t/seeing-404-error-for-nginx-on-loading-local-sites/1930/14 "2022-12-11T00:20:39Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
