# Something bad happened again

**URL:** https://community.kinsta.com/t/something-bad-happened-again/6314
**Category:** Bug Reports
**Created:** [May 26, 2026, 2:59pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314 "2026-05-26T14:59:12Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 26, 2026, 2:59pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/1 "2026-05-26T14:59:12Z")

</div>

Hi All,

I’m looking for some help, please. I am new to Kinsta and very new to DevKinsta. In fact, I’ve only just installed it along with Docker. The first time I tried to import a site from my Kinsta account, I get the following error.

 ![Screenshot 2026-05-26 at 12.41.08](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/7/7a0b7cdf8cf8c6618f1daf697ab9615e4b7d1d78.png)

After Google searching and using AI to try to diagnose, I have tried deleting containers, volumes, config files, deleting both apps and reinstalling. I even tried a few terminal commands offered from Gemini. Nothing seems to work.

I’m simply trying to import my first staging site from Kinsta.

Does anybody have a sure-fire way to get Kinsta to actually download a site and make it work please?

I am on Mac for reference

Thanks for any help.

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 26, 2026, 11:27pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/2 "2026-05-26T23:27:22Z")

</div>

Hi @Phease69,

Welcome to the Kinsta Community!

I’m sorry to hear that you’re experiencing issues with our DevKinsta app. To help us investigate the problem further, could you please send me a private message with the DevKinsta main.log file?

For Mac users, you can typically find the log file at the following location:  
`/Users/<yourusername>/Library/Logs/DevKinsta/main.log`.

Thank you!

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 27, 2026, 11:48am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/3 "2026-05-27T11:48:53Z")

</div>

@Phease69

My shift has ended. Feel free to share the DevKinsta main.log to @VladimirM or @jackirish instead once you’re able.

Thanks!

---

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 27, 2026, 2:07pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/5 "2026-05-27T14:07:02Z")

</div>

How do I send private messages?

---

<div class="post-metadata">

### Author: ![Adrian\_L](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/adrian_l/32/2810_2.png) [@Adrian\_L](https://community.kinsta.com/u/Adrian_L)
#### Post date: [May 27, 2026, 10:13pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/6 "2026-05-27T22:13:46Z")

</div>

To send a private message, click the username of the person and then select the Message button.

Example:

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/0/05ab4329815f653005b4754b52f32f05e00a36fc.png)  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/8225e94bd0d462bf680dac68cd897dcc91788022.png)  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/a/aea59d6822716a5ca8a45d428b071977755c2f66.png)

---

<div class="post-metadata">

### Author: ![VladimirM](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vladimirm/32/2786_2.png) [@VladimirM](https://community.kinsta.com/u/VladimirM)
#### Post date: [May 28, 2026, 6:14am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/7 "2026-05-28T06:14:27Z")

</div>

Hello @Phease69 👋

Vladimir here.

We have had this type of cases and I have devised a solution and posted here:

> [@Error: Something bad happened - when trying to import site from myKinsta](https://community.kinsta.com/t/error-something-bad-happened-when-trying-to-import-site-from-mykinsta/5661/15):
>
> Hello @wpcreative-jwwaving_hand As discussed in our chat, I’m posting a complete step by step instructions, if needed in the future. @Seyed My colleague and I gave you the steps in the other threads, but I wanted to tag you here as well. Note: This applies to fixing the issues with site creation that are caused by database access error (in DevKinsta main.log, it’s → ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES) ). Part ONE - RESETING ‘root’ USER PASSW…

Please arm yourself with patience and be sure to understand and execute each step as written. I myself had to do it over a couple of times when I had the issue, but I hope you’ll have a better luck 🤞

Let me know if this helps.

---

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 28, 2026, 10:08am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/8 "2026-05-28T10:08:45Z")

</div>

Thanks for the reply Vladimir. But a brand-new software install on a standard Mac shouldn’t require this much troubleshooting just to do its basic job. I will follow these steps and see what happens. I know its not your fault, so no blame or criticism of you personally intended, its just really disappointing that this software is so poor.

---

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 28, 2026, 10:22am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/9 "2026-05-28T10:22:20Z")

</div>

OK, so I followed all steps perfectly. After completing all steps in part one, I still have the issue. So I moved on to steps covered in section 2 like advised, and I got this:

root@127f281ca05b:/# mysql -u root -p

Enter password:

**Welcome to the MariaDB monitor. Commands end with ; or \g.**

**Your MariaDB connection id is 6**

**Server version: 10.5.17-MariaDB-1:10.5.17+maria~ubu2004 [mariadb.org](http://mariadb.org) binary distribution**

**Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.**

**Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.**

MariaDB [(none)]\> GRANT ALL PRIVILEGES ON \*.\* TO ‘root’@‘%’ IDENTIFIED BY ‘root’ WITH GRANT OPTION;

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Then I went into config.json and changed the password manually in there.

I still have the error on importing and creating sites.

☹

---

<div class="post-metadata">

### Author: ![VladimirM](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vladimirm/32/2786_2.png) [@VladimirM](https://community.kinsta.com/u/VladimirM)
#### Post date: [May 28, 2026, 2:05pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/10 "2026-05-28T14:05:50Z")

</div>

Did you remove the additional devkinsta\_db container from the Docker after resetting the root password? That’s this from the first part:

The above steps are resetting the passwrod for ‘root’ user.

1. Switch back to Terminal. Delete the temporary Docker container by running the following in Terminal: `docker rm devkinsta_reset_mariadb_root -f`

2. Start the original devkinsta\_db container in Docker

---

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 29, 2026, 11:47am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/11 "2026-05-29T11:47:46Z")

</div>

Yes I did. I just reastarted my machine and followed all steps again. I got to this…

GRANT ALL PRIVILEGES ON \*.\* TO ‘root’@‘%’ IDENTIFIED BY ‘root’ WITH GRANT OPTION;

ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

the config.json file has the correct password in it (the one I have created)

---

<div class="post-metadata">

### Author: ![VladimirM](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vladimirm/32/2786_2.png) [@VladimirM](https://community.kinsta.com/u/VladimirM)
#### Post date: [May 29, 2026, 12:18pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/12 "2026-05-29T12:18:13Z")

</div>

> [@Error: Something bad happened - when trying to import site from myKinsta](https://community.kinsta.com/t/error-something-bad-happened-when-trying-to-import-site-from-mykinsta/5661/15):
>
> GRANT ALL PRIVILEGES ON _._ TO ‘root’@‘%’ IDENTIFIED BY ‘the password you created’ WITH GRANT OPTION;

I think that the issue is the line you are running, it might have wrong quotes and you use ‘root’ for password again. But it should be:

GRANT ALL PRIVILEGES ON \*.\* TO ‘root’@‘%’ IDENTIFIED BY ‘xxxxxxx’ WITH GRANT OPTION;

Where ‘xxxxxxx’ is actually the password you have set in the previous steps.

Can you try that?

---

<div class="post-metadata">

### Author: ![Phease69](https://avatars.discourse-cdn.com/v4/letter/p/5f9b8f/32.png) [@Phease69](https://community.kinsta.com/u/Phease69)
#### Post date: [May 29, 2026, 1:21pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/13 "2026-05-29T13:21:51Z")

</div>

yes, I have set the password to be ‘root’ that is why I put root in it.

 ![Screenshot 2026-05-29 at 14.21.32](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/84919bcf99642764c8fe1d9c7cecb73566ae5a69.png)

---

<div class="post-metadata">

### Author: ![VladimirM](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/vladimirm/32/2786_2.png) [@VladimirM](https://community.kinsta.com/u/VladimirM)
#### Post date: [May 29, 2026, 2:24pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/14 "2026-05-29T14:24:04Z")

</div>

Hey @Phease69 👋

I’m sorry for the back and forth. The only thing left I can think of is that wrong quotes are copied because forum is changing them.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/7/796eac13d886898b0cc64a368416968ddc9e414d.png)  
See if you can spot the difference, please copy the line to a text editor tool and make sure that quotes are replaced with proper quotes.  
Wrong:  
`GRANT ALL PRIVILEGES ON `_`.`_` TO ‘root’@‘%’ IDENTIFIED BY ‘xxxxxxx’ WITH GRANT OPTION;`

Correct:

```auto
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'xxxxxxx' WITH GRANT OPTION;

```

---

<div class="post-metadata">

### Author: ![edharris](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/edharris/32/5603_2.png) [@edharris](https://community.kinsta.com/u/edharris)
#### Post date: [June 4, 2026, 11:41pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/15 "2026-06-04T23:41:20Z")

</div>

Hi - I’m having the same problem as others on this thread. I’ve tried following the detailed instructions provided by @VladimirM including the final third step of modifying DevKinsta’s config.json file, but am still getting the same “Something bad happened” error on trying to import a site from my Kinsta account. Would love some help resolving this.

---

<div class="post-metadata">

### Author: ![merineth](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/merineth/32/3022_2.png) [@merineth](https://community.kinsta.com/u/merineth)
#### Post date: [June 5, 2026, 12:31am UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/16 "2026-06-05T00:31:26Z")

</div>

Hi @edharris Welcome to the Community.

I’m sorry to hear that you’re experiencing issues.

Could you please provide the **main.log** file from DevKinsta and send it here? This will help us investigate further.

You can refer to this guide for instructions on locating the log file:  
[Troubleshooting - Error Codes - Kinsta® Docs](https://kinsta.com/docs/devkinsta/devkinsta-troubleshooting/error-codes/#viewing-the-application-log-file)

We will wait for your update. Thank you.

---

<div class="post-metadata">

### Author: ![edharris](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/edharris/32/5603_2.png) [@edharris](https://community.kinsta.com/u/edharris)
#### Post date: [June 5, 2026, 1:07pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/17 "2026-06-05T13:07:59Z")

</div>

Thanks - just messaged you with the main.log file!

---

<div class="post-metadata">

### Author: ![Andrew](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/andrew/32/2792_2.png) [@Andrew](https://community.kinsta.com/u/Andrew)
#### Post date: [June 6, 2026, 6:54pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/19 "2026-06-06T18:54:14Z")

</div>

Hi @edharris,

We appreciate you sharing the log file with our team! After reviewing the main.log file it appears the issue is that the connection to the database is still failing with an access denied error. This can be seen in the snippet below:

[`2026-06-04 16:39:18.920] [error] Error - DK0051: DELETE_SITE_DATABASE: Error (1): UERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)`

This is indicating that the root password for the MariaDB container/service is still out of sync.

To determine if the password still differs from what is in the config.json file please try running the following command in a Terminal window:

`docker inspect devkinsta_db --format ‘{{range .Mounts}}{{.Name}} → {{.Destination}}{{println}}{{end}}’`  
`docker exec -it devkinsta_db mysql -u root -e “SHOW DATABASES; SELECT User,Host,plugin FROM mysql.user WHERE User=‘root’;”`  
`grep -i password ~/Library/Application\ Support/DevKinsta/config.json`

If this shows database information than this indicates that the data-dir password may differ from what is set in config.json.

To correct this you may run the following commands:

`docker exec -it devkinsta_db mysql -u root`

At the MariaDB prompt, with `PASS` replaced by the exact value from `config.json`. This password value should have been output at the end of the `docker` command above. These commands should be run individually with each one ending with the semicolon:

`ALTER USER ‘root’@‘localhost’ IDENTIFIED VIA mysql_native_password USING PASSWORD(‘PASS’);`  
`GRANT ALL PRIVILEGES ON `_`.`_` TO ‘root’@‘%’ IDENTIFIED BY ‘PASS’ WITH GRANT OPTION;`  
`FLUSH PRIVILEGES;`  
`exit`

After this has been completed please try importing your site again into DevKinsta to see if it can now be imported successfully.

If you do continue to experience any issue or have questions please don’t hesitate to let us know. We are standing by and happy to help!

---

<div class="post-metadata">

### Author: ![edharris](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/edharris/32/5603_2.png) [@edharris](https://community.kinsta.com/u/edharris)
#### Post date: [June 6, 2026, 7:18pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/20 "2026-06-06T19:18:55Z")

</div>

Hi @Andrew - on running the first command I got an access denied error message from the database.

The next command you provided:  
`docker exec -it devkinsta_db mysql -u root`  
also returns the following error message:  
`Access denied for user 'root'@'localhost' (using password: NO)`

---

<div class="post-metadata">

### Author: ![Andrew](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/andrew/32/2792_2.png) [@Andrew](https://community.kinsta.com/u/Andrew)
#### Post date: [June 6, 2026, 8:34pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/21 "2026-06-06T20:34:01Z")

</div>

Hi @edharris,

Thank you for your reply! I’m sorry to hear that you ran into the access denied error when trying to run these commands as well.

In that case please try modifying the `docker exec -it devkinsta_db mysql -u root`so that it is `docker exec -it devkinsta_db mysql -u root -p`. This should then result in you being prompted for a password. Please try copying/pasting the password from the `~/Library/Application\ Support/DevKinsta/config.json` file into that prompt. Then, confirm if it allows you to connect to the database and if you see the MariaDB prompt.

If you continue to see an access denied error using that password that does confirm the password in the config.json file is out of sync with the database service. In that case we may need to recreate the MariaDB container and volume, or possibly the entire DevKinsta stack in Docker.

Please let us know however if using the password in the config.json file works first to confirm if the issue is indeed the passwords being out of sync there or not.

We look forward to hearing back from you!

---

<div class="post-metadata">

### Author: ![edharris](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/edharris/32/5603_2.png) [@edharris](https://community.kinsta.com/u/edharris)
#### Post date: [June 7, 2026, 5:35pm UTC](https://community.kinsta.com/t/something-bad-happened-again/6314/22 "2026-06-07T17:35:17Z")

</div>

I ran `docker exec -it devkinsta_db mysql -u root -p` and then entered the password from the config.json file and it did allow me to connect with the database (no access denied error message). What’s the next step?

[Next page](https://community.kinsta.com/t/something-bad-happened-again/6314.md?page=2)
