# Subdomain Multisite Download from Kinsta Throwing Redirect Errors

**URL:** https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263
**Category:** Bug Reports
**Created:** [February 1, 2022, 4:13pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263 "2022-02-01T16:13:28Z")
**Posts on this page:** 12
**Page:** 1

<div class="post-metadata">

### Author: ![ekline](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/ekline/32/376_2.png) [@ekline](https://community.kinsta.com/u/ekline)
#### Post date: [February 1, 2022, 4:13pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/1 "2022-02-01T16:13:28Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:**

**Q: DevKinsta Version**  
\*\*A:\*\*2.3

**Q: OS Version**  
\*\*A:\*\*12.2

**Q: Docker Desktop Version**  
\*\*A:\*\*4.4.2

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** redirected too many times

**Q: Detailed Description of the Problem**  
**A:** When downloading a Kinsta subdomain multisite from staging or live I am unable to open the main site and get a redirect error in the browser. I have tried this many times with several different multisite setups living within Kinsta.

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [February 1, 2022, 9:20pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/2 "2022-02-01T21:20:50Z")

</div>

Hi @ekline, thanks for reaching out!  
I’m able to reproduce this and can confirm that it’s due to a known issue with the Search and Replace. You would need to use the database manager to edit the wp\_blogs and and wp\_posts entries. Those will need to use kinsta.local domain names.

The good news is that we are releasing a new version of DevKinsta very soon that should resolve this issue. I’m going to run some tests with the new release and make sure that this is fixed.

Please let me know if you have any questions!

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 9:23pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/3 "2022-05-11T21:23:43Z")

</div>

I just did this and am still running into the issue. Is this not resolved?

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [May 11, 2022, 9:26pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/4 "2022-05-11T21:26:17Z")

</div>

Hi @mwalcott; this specific issue was resolved with a previous update.  
Can you provide more info about your issue? What OS are you using?

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 9:29pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/5 "2022-05-11T21:29:13Z")

</div>

I just installed everything today so the most up to date versions. I then created a multisite on Kingsta and tried to pull it down to my windows machine. Then once completed I got the too many redirects error.

Is there any additional info you need?

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [May 11, 2022, 9:58pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/6 "2022-05-11T21:58:28Z")

</div>

Can you check the wp-confing.php file on your local machine? Is it still referring to the staging site?

Also in the database, are wp\_blogs and wp\_site not being updated to the .local domain?

There is a different database-related issue happening with the current Windows version that could cause this. The good news is that the next DevKinsta release with the appropriate fix will be coming out either this week or next week.

I can let you know once the new version has been released so that you can try again.

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 10:06pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/7 "2022-05-11T22:06:14Z")

</div>

```auto
<?php
/**
 * The base configuration for WordPress
 *
 * The wp-config.php creation script uses this file during the installation.
 * You don't have to use the web site, you can copy this file to "wp-config.php"
 * and fill in the values.
 *
 * This file contains the following configurations:
 *
 * * Database settings
 * * Secret keys
 * * Database table prefix
 * * Localized language
 * * ABSPATH
 *
 * @link https://wordpress.org/support/article/editing-wp-config-php/
 *
 * @package WordPress
 */

// **Database settings - You can get this info from your web host** //
/** The name of the database for WordPress */
define( 'DB_NAME', 'summitgeeks' );

/** Database username */
define( 'DB_USER', 'root' );

/** Database password */
define( 'DB_PASSWORD', '' );

/** Database hostname */
define( 'DB_HOST', 'devkinsta_db' );

/** Database charset to use in creating database tables. */
define( 'DB_CHARSET', 'utf8' );

/** The database collate type. Don't change this if in doubt. */
define( 'DB_COLLATE', '' );

/**#@+
 * Authentication unique keys and salts.
 *
 * Change these to different unique phrases! You can generate these using
 * the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}.
 *
 * You can change these at any point in time to invalidate all existing cookies.
 * This will force all users to have to log in again.
 *
 * @since 2.6.0
 */
define( 'AUTH_KEY', ' 
define( 'SECURE_AUTH_KEY', '
define( 'LOGGED_IN_KEY', '
define( 'NONCE_KEY', '
define( 'AUTH_SALT',         
define( 'SECURE_AUTH_SALT', '
define( 'LOGGED_IN_SALT', '
define( 'NONCE_SALT',        
define( 'WP_CACHE_KEY_SALT', '

/**#@-*/

/**
 * WordPress database table prefix.
 *
 * You can have multiple installations in one database if you give each
 * a unique prefix. Only numbers, letters, and underscores please!
 */
$table_prefix = 'wp_';

/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 *
 * For information on other constants that can be used for debugging,
 * visit the documentation.
 *
 * @link https://wordpress.org/support/article/debugging-in-wordpress/
 */
define( 'WP_DEBUG', false );

/* Add any custom values between this line and the "stop editing" line. */

define( 'WP_ALLOW_MULTISITE', true );
define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', true );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', 'summitgeeks.local' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

/* That's all, stop editing! Happy publishing. */

/** Absolute path to the WordPress directory. */
if ( ! defined( 'ABSPATH' ) ) {
	define( 'ABSPATH', __DIR__. '/' );
}

/** Sets up WordPress vars and included files. */
require_once ABSPATH . 'wp-settings.php';

```

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 10:08pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/8 "2022-05-11T22:08:56Z")

</div>

I clicked on Database manager from the DevKinsta dashboard and see this.

 ![DevKinsta](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/815b329475284483326d5a387a88bb539e56ea17.png)

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [May 11, 2022, 10:28pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/9 "2022-05-11T22:28:06Z")

</div>

Yes, sorry, it looks like it didn’t export the database, which is the current issue with Windows/DevKinsta.

You can wait until the new version is released or you can manually export the database from Kinsta/phpMyAdmin then import it into DevKinsta/Database manager. You would just have to manually update the table values.

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 10:31pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/10 "2022-05-11T22:31:12Z")

</div>

I did find that if I create the site locally and deploy then everything works

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [May 11, 2022, 10:48pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/11 "2022-05-11T22:48:02Z")

</div>

Yes, I’ve only seen the issue with Kinsta → DevKinsta on Windows. I don’t think there are any issues going in the other direction.

This has been fixed and tested on the new version, though. We are just waiting for quality testing to be completed before the update is ready.

---

<div class="post-metadata">

### Author: ![mwalcott](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/mwalcott/32/2882_2.png) [@mwalcott](https://community.kinsta.com/u/mwalcott)
#### Post date: [May 11, 2022, 10:56pm UTC](https://community.kinsta.com/t/subdomain-multisite-download-from-kinsta-throwing-redirect-errors/1263/12 "2022-05-11T22:56:02Z")

</div>

Ok thank you for the quick response. I appreciate it.
