# Unable to enable SSL on new site

**URL:** https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639
**Category:** Bug Reports
**Created:** [July 21, 2022, 5:45pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639 "2022-07-21T17:45:26Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![alanj](https://avatars.discourse-cdn.com/v4/letter/a/97f17d/32.png) [@alanj](https://community.kinsta.com/u/alanj)
#### Post date: [July 21, 2022, 5:45pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/1 "2022-07-21T17:45:26Z")

</div>

**Q: Date/Time this occurred (Provide your time zone also)**  
**A:** Now. Uk time

**Q: DevKinsta Version**  
**A:** How do you tell? But latest with site stop/start

**Q: OS Version**  
**A:** Linux Mint 20.3 cinnamon

**Q: Docker Desktop Version**  
**A:** no idea - whatever DevKinsta installs

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** Just the “SSL update failed” on the Dev Kinsta Enable SSL and Https

**Q: Detailed Description of the Problem**  
**A:** Just created a new site.  
Changed PHP to 8 ( why does it default to 7.4 ? )  
Tried to enable SSL and HTTPS but get the SSL update failed message.

Went to the admin page ( http ) and changed Wordpress to use https. Now the Site does not work at all and I am unable to get back to the admin. The DevKinsta SSL and HTTPS button still gives the failure to update error.

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 21, 2022, 9:08pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/2 "2022-07-21T21:08:21Z")

</div>

Hi @alanj, thanks for reaching out!  
Can you please private message your [main.log file](https://kinsta.com/knowledgebase/devkinsta/error-codes/#info) to me?

---

<div class="post-metadata">

### Author: ![alanj](https://avatars.discourse-cdn.com/v4/letter/a/97f17d/32.png) [@alanj](https://community.kinsta.com/u/alanj)
#### Post date: [July 21, 2022, 11:29pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/3 "2022-07-21T23:29:43Z")

</div>

Sure, attached.  
[main.old.log]  
Looks like a permission problem with the config file … but why as DevKinsta only just created it?

Error from log.  
[2022-07-21 18:47:34.744] [error] [setSsl] Error while setting ssl to true {  
e: “Error: EACCES: permission denied, open ‘/home/ssoa/DevKinsta/public/bdtest1/wp-config.php’\n” +  
’ at Object.openSync (node:fs:585:3)\n’ +  
’ at Object.func [as openSync] (node:electron/js2c/asar\_bundle:5:1800)\n’ +  
’ at Object.writeFileSync (node:fs:2153:35)\n’ +  
’ at /opt/DevKinsta/resources/app.asar/main.prod.js:2:958897\n’ +  
’ at tryCatch (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180690)\n’ +  
’ at Generator.\_invoke (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180313)\n’ +  
’ at Generator.next (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2181465)\n’ +  
’ at asyncGeneratorStep (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1003)\n’ +  
’ at \_next (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1302)\n’ +  
’ at /opt/DevKinsta/resources/app.asar/main.prod.js:2:1452\n’ +  
’ at new Promise ()\n’ +  
’ at /opt/DevKinsta/resources/app.asar/main.prod.js:2:1214\n’ +  
’ at /opt/DevKinsta/resources/app.asar/main.prod.js:2:959017\n’ +  
’ at Array.map ()\n’ +  
’ at /opt/DevKinsta/resources/app.asar/main.prod.js:2:958422\n’ +  
’ at tryCatch (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180690)’  
}  
[2022-07-21 18:47:34.746] [error] Error: EACCES: permission denied, open ‘/home/ssoa/DevKinsta/public/bdtest1/wp-config.php’  
at Object.openSync (node:fs:585:3)  
at Object.func [as openSync] (node:electron/js2c/asar\_bundle:5:1800)  
at Object.writeFileSync (node:fs:2153:35)  
at /opt/DevKinsta/resources/app.asar/main.prod.js:2:958897  
at tryCatch (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180690)  
at Generator.\_invoke (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180313)  
at Generator.next (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2181465)  
at asyncGeneratorStep (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1003)  
at \_next (/opt/DevKinsta/resources/app.asar/main.prod.js:2:1302)  
at /opt/DevKinsta/resources/app.asar/main.prod.js:2:1452  
at new Promise ()  
at /opt/DevKinsta/resources/app.asar/main.prod.js:2:1214  
at /opt/DevKinsta/resources/app.asar/main.prod.js:2:959017  
at Array.map ()  
at /opt/DevKinsta/resources/app.asar/main.prod.js:2:958422  
at tryCatch (/opt/DevKinsta/resources/app.asar/main.prod.js:8:2180690)

Cheers  
Alan

> **Summary**
>
> This text will be hidden

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 21, 2022, 11:40pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/4 "2022-07-21T23:40:42Z")

</div>

I don’t see why either. Can you run `stat` on your wp-config.php file? Like `stat /path/to/wp-config.php`  
What does that return?

I’m going to ask our Developers what could cause this as I’m not on Linux. I’ll also ask them how to fix the permissions .

Do you get the same error on any new site that you create? I’ve never seen this error before so maybe it’s being caused by the new update.

---

<div class="post-metadata">

### Author: ![alanj](https://avatars.discourse-cdn.com/v4/letter/a/97f17d/32.png) [@alanj](https://community.kinsta.com/u/alanj)
#### Post date: [July 22, 2022, 8:51am UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/5 "2022-07-22T08:51:09Z")

</div>

Hi Kevin,  
So a Stat gives ==\> :~/DevKinsta/public/bdtest1$ stat wp-config.php  
File: wp-config.php  
Size: 3393 Blocks: 8 IO Block: 4096 regular file  
Device: 811h/2065d Inode: 21516512 Links: 1  
Access: (0777/-rwxrwxrwx) Uid: ( 1000/ alan) Gid: ( 1000/ alan)  
Access: 2022-07-22 00:16:16.866365989 +0100  
Modify: 2022-07-21 18:35:20.911337393 +0100  
Change: 2022-07-22 00:16:15.474317669 +0100  
Birth: -

Looking at the permissions I see they are created with a different user being the owner. This may be the cause. They are 777 though.

I originally installed DevKinsta under my main userid which had admin ( root) permissions.  
I then created a second userid just for my website work. This gave some problems as the new userid did not have root. So I reinstalled DevKinsta under this second userid, and gave that userid su ability.  
Things then worked ok.

However since the 2.6 release of DK it has started asking for the root password every time I start DK. Not a big deal but a change in behaviour.

The HTTPS/SSL issue happens on any new site I create now. I have only noticed this since the latest upgrade to DK 2.7. Previous sites could have SSL/HTTPS enabled without issue.

LOL after writing the above I tried again to set the HTTPS/SSL value on 2 brand new sites … guess what? Today both worked!  
So maybe this is just a timing thing and it needs time to sort itself out before you can set SSL/Https?

BUT I still can’t actually access the sites. Both report …

> This site can’t provide a secure connection
> 
> **bdtest1.local** sent an invalid response.
> 
> ERR\_SSL\_PROTOCOL\_ERROR

So I am unable to access the dashboard. The sites do show the home page using plain http.

Looking in the main.log I see the SSL certs created for both sites ok. But I also see a few errors relating to SSL. Not sure if they are related at all.

> [2022-07-22 09:39:17.226] [error] create thumbnail error: Error: write EPROTO 46471546942600:error:100000f7:SSL routines:OPENSSL\_internal:WRONG\_VERSION\_NUMBER:…/…/third\_party/boringssl/src/ssl/tls\_record.cc:242:

OpenSSL is OpenSSL\> version  
OpenSSL 1.1.1f 31 Mar 2020

Confused yet? I am.

Cheers  
Alan

---

<div class="post-metadata">

### Author: ![alanj](https://avatars.discourse-cdn.com/v4/letter/a/97f17d/32.png) [@alanj](https://community.kinsta.com/u/alanj)
#### Post date: [July 22, 2022, 3:55pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/6 "2022-07-22T15:55:23Z")

</div>

More news:

After a few more stop/starts … but no changes. My second test site is now working and using https.  
The first test site still refuses to use https so unable to access wp-admin. But I’ll delete it and start again.

Maybe I just need more patience. But think this can be closed now.  
Sorry for the confusion.

Cheers  
Alan

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [July 22, 2022, 4:37pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/7 "2022-07-22T16:37:56Z")

</div>

Thanks for the update @alanj. I’m glad it started working on new sites. Very odd issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/2X/8/80f8c4e56fecc02327a0964e6bf63a716483529f.png) [@system](https://community.kinsta.com/u/system)
#### Post date: [July 25, 2022, 4:38pm UTC](https://community.kinsta.com/t/unable-to-enable-ssl-on-new-site/1639/8 "2022-07-25T16:38:14Z")

</div>

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.
