# Windows 10: DK0033 error while creating a site

**URL:** https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155
**Category:** Bug Reports
**Created:** [January 20, 2021, 2:07pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155 "2021-01-20T14:07:55Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![slaFFik](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/slaffik/32/110_2.png) [@slaFFik](https://community.kinsta.com/u/slaFFik)
#### Post date: [January 20, 2021, 2:07pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/1 "2021-01-20T14:07:55Z")

</div>

**Q: DevKinsta Version**  
**A:** 1.0.1

**Q: OS Version**  
**A:** Windows 10 Pro 20H2

**Q: Docker Desktop Version**  
**A:** 3.1.0

**Q: Were any error codes or messages observed? If so, what were they?**  
**A:** DK0033

**Q: Detailed Description of the Problem**  
**A:** While trying to create my first `kinsta.local` domain I got this error message:

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/94dc58ee61c3687812d2e2e877d2b8463b0681a4.png)

The error is linked to this page: [DevKinsta Error Codes - Kinsta](https://kinsta.com/knowledgebase/devkinsta/error-codes/#dk0033)  
But there is no such error code on that page.

There are no other MySQL instances running at this time.

---

<div class="post-metadata">

### Author: ![slaFFik](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/slaffik/32/110_2.png) [@slaFFik](https://community.kinsta.com/u/slaFFik)
#### Post date: [January 20, 2021, 2:16pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/2 "2021-01-20T14:16:09Z")

</div>

I checked the docker `devkinsta-db` image logs and found this error:

```auto
2021-01-20 10:57:29 0 [Note] mysqld: ready for connections.

Version: '10.5.5-MariaDB-1:10.5.5+maria~focal' socket: '/run/mysqld/mysqld.sock' port: 3306 mariadb.org binary distribution

2021-01-20 11:02:16 3 [Warning] Access denied for user 'root'@'localhost' (using password: YES)

```

Also, DK tries dozens of times (30+) those incorrect username/password credentials, because I see that many such “Access defined” errors.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [January 20, 2021, 4:25pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/3 "2021-01-20T16:25:43Z")

</div>

Thanks for reporting @slaFFik. We’ll take a look at this.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [January 20, 2021, 8:26pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/4 "2021-01-20T20:26:44Z")

</div>

We’re working on a fix for this. Here’s a workaround to resolve this for the time being:

1. Stop DevKinsta
2. Delete devkinsta\_db container: `docker rm devkinsta_db`
3. Delete db volume: `docker volume rm devkinsta_db_data`
4. Restart DevKinsta

Let us know if this helps

---

<div class="post-metadata">

### Author: ![slaFFik](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/slaffik/32/110_2.png) [@slaFFik](https://community.kinsta.com/u/slaFFik)
#### Post date: [January 20, 2021, 9:11pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/5 "2021-01-20T21:11:33Z")

</div>

Removing the db container and volume helped to fix this issue. Thanks.

I guess the error codes page on your site should be updated as well to include this DK0033.

---

<div class="post-metadata">

### Author: ![michael](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/michael/32/31_2.png) [@michael](https://community.kinsta.com/u/michael)
#### Post date: [November 10, 2021, 2:35pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/6 "2021-11-10T14:35:06Z")

</div>

Hey @slaFFik . Have you experienced any further issues on this in the last 10 months? Let us know if you’ve encountered this again. Try [DevKinsta 2.3.0 as well.](https://devkinsta.com)

---

<div class="post-metadata">

### Author: ![berger292](https://avatars.discourse-cdn.com/v4/letter/b/ec9cab/32.png) [@berger292](https://community.kinsta.com/u/berger292)
#### Post date: [February 17, 2022, 9:12am UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/7 "2022-02-17T09:12:13Z")

</div>

Hi there,

I ran into this problem today running DevKinsta 2.4.1. When I typed in the command above, I got back the following:

Error response from daemon: You cannot remove a running container 671ca85b30580aed7e1d1df1533dff43d28291e1f8981a0a898eb80b11b50e0b. Stop the container before attempting removal or force remove

What do I do? Any help would be greatly appreciated. Thanks!

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [February 21, 2022, 9:52pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/8 "2022-02-21T21:52:01Z")

</div>

Hi @berger292, sorry for the late response here.  
You can actually do all of this from within Docker.  
You first need to stop the container you are trying to remove:

 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/16b11f11c4f73ddcac5348d1988028705e981534.png)  
`docker stop devkinsta_db` would be how you do this from the command line.  
And then you’ll be able to delete it:  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/a127ed08b8a5a42712bc9818e260169df322e12a.png)  
Which is the same as `docker rm devkinsta_db`

Please let us know if that doesn’t work!

---

<div class="post-metadata">

### Author: ![jackdoe](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/jackdoe/32/1059_2.png) [@jackdoe](https://community.kinsta.com/u/jackdoe)
#### Post date: [February 24, 2022, 8:06am UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/9 "2022-02-24T08:06:52Z")

</div>

Hey @slaFFik ,  
Export your site’s database with Adminer then close DevKinsta.  
Run this command in terminal  
“docker container rm devkinsta\_db && docker volume rm devkinsta\_db\_data”  
Now Start DevKinsta and Import Database with Adminer.

---

<div class="post-metadata">

### Author: ![powem](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/powem/32/976_2.png) [@powem](https://community.kinsta.com/u/powem)
#### Post date: [March 15, 2022, 3:31pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/10 "2022-03-15T15:31:53Z")

</div>

Same issue here, current version of DevKinsta, 2.4.1.

I have MariaDB and MySQL installed. MySQL is on port 3307 and MariaDB is on port 3308.

Per instructions, I exited the app, stopped the db container and removed the db & db\_data containers. Upon restart, same issue.

Some net resources indicate that this error is caused by usage of the `auth_plugin` for authentication, which (apparently) does not allow root logins.

Via Docker Desktop, log messages, followed by login error:

```auto
2022-03-15 15:10:00+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.
2022-03-15 15:10:00+00:00 [Note] [Entrypoint]: Switching to dedicated user 'mysql'
2022-03-15 15:10:00+00:00 [Note] [Entrypoint]: Entrypoint script for MySQL Server 1:10.5.5+maria~focal started.
2022-03-15 15:10:00 0 [Note] mysqld (mysqld 10.5.5-MariaDB-1:10.5.5+maria~focal) starting as process 1 ...
2022-03-15 15:10:00 0 [Note] InnoDB: Using Linux native AIO
2022-03-15 15:10:00 0 [Note] InnoDB: Uses event mutexes
2022-03-15 15:10:00 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2022-03-15 15:10:00 0 [Note] InnoDB: Number of pools: 1
2022-03-15 15:10:00 0 [Note] InnoDB: Using SSE4.2 crc32 instructions
2022-03-15 15:10:00 0 [Note] mysqld: O_TMPFILE is not supported on /tmp (disabling future attempts)
2022-03-15 15:10:00 0 [Note] InnoDB: Initializing buffer pool, total size = 134217728, chunk size = 134217728
2022-03-15 15:10:00 0 [Note] InnoDB: Completed initialization of buffer pool
2022-03-15 15:10:00 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2022-03-15 15:10:01 0 [Note] InnoDB: 128 rollback segments are active.
2022-03-15 15:10:01 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2022-03-15 15:10:01 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2022-03-15 15:10:01 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2022-03-15 15:10:01 0 [Note] InnoDB: 10.5.5 started; log sequence number 45289; transaction id 21
2022-03-15 15:10:01 0 [Note] Plugin 'FEEDBACK' is disabled.
2022-03-15 15:10:01 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2022-03-15 15:10:01 0 [Note] InnoDB: Buffer pool(s) load completed at 220315 15:10:01
2022-03-15 15:10:01 0 [Note] Server socket created on IP: '::'.
2022-03-15 15:10:01 0 [Warning] 'user' entry 'root@f0f30fbecb5f' ignored in --skip-name-resolve mode.
2022-03-15 15:10:01 0 [Warning] 'user' entry '@f0f30fbecb5f' ignored in --skip-name-resolve mode.
2022-03-15 15:10:01 0 [Warning] 'proxies_priv' entry '@% root@f0f30fbecb5f' ignored in --skip-name-resolve mode.
2022-03-15 15:10:01 0 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_transition_type' doesn't exist trying to live without them
2022-03-15 15:10:01 0 [Note] Reading of all Master_info entries succeeded
2022-03-15 15:10:01 0 [Note] Added new Master_info '' to hash table
2022-03-15 15:10:01 0 [Note] mysqld: ready for connections.
Version: '10.5.5-MariaDB-1:10.5.5+maria~focal' socket: '/run/mysqld/mysqld.sock' port: 3306 mariadb.org binary distribution
2022-03-15 15:10:27 3 [Warning] Access denied for user 'root'@'localhost' (using password: YES)
2022-03-15 15:10:30 4 [Warning] Access denied for user 'root'@'localhost' (using password: YES)
[...]

```

---

<div class="post-metadata">

### Author: ![Kevin](https://sea2.discourse-cdn.com/flex020/user_avatar/community.kinsta.com/kevin/32/808_2.png) [@Kevin](https://community.kinsta.com/u/Kevin)
#### Post date: [March 15, 2022, 11:58pm UTC](https://community.kinsta.com/t/windows-10-dk0033-error-while-creating-a-site/155/11 "2022-03-15T23:58:58Z")

</div>

Hi @powem, welcome to DevKinsta.  
What container’s do you have running in Docker?  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/kinsta/original/1X/c2526789838029eb08386c7258dff85c1160e4b1.png)

Does Adminer load for you? For example, in my setup it would be here: [http://127.0.0.1:15200/](http://127.0.0.1:15200/)

I also want to point out this solution that may also be relevant for you: [Can't connect to database - #4 by jromero\_arro](https://community.kinsta.com/t/cant-connect-to-database/1061/4)
