Blocked at updating host file 75%

Hi @rafu . Could you confirm that you are indeed running these with administrator rights? Perhaps your current user doesn’t have the proper permissions? User Account Control (UAC) may be worth taking a look at as well.

Hello everyone, especialy Mr. michael from Kinsta Staff.
I have the same problem. No new site can be created. Site installation stops at 75%.
I tried EVERYTHING that is recommended above in this thread.
And the rights to edit the host file, and runs as administrator, and UAC is generally disabled (like Windows Defender) from the first day of installing Windows. The most recent versions of EVERYTHING on the computer. WSL 2 installed and updated files. And the virtualization in BIOS is on. AND EVERYTHING, EVERYTHING … I can’t understand what could be the reason. Neither a new site nor a WordPress site is created, not from scratch, the installation does not continue later …

Just to say,

Using Kaspersky and had the same issue. Never a problem with WAMP.

But I paused KIS and, VOILA! DK wrote to the hosts file.

Thanks for your observations.
I am using TotalAV Pro. I turned it off, turned off everything connected with it from the task manager. Nothing changes. On changing the host file - infinity.
This is generally a strange bug. Isolated cases, as I understand it. But it exists, and I really want to fix it. I really need help from DevKinsta.

For others with the same problem, this might be a workaround, until kinsta publishes a fixed version:

  1. Clone a wordpress site from kinsta or create a new one inside the DevKinsta tool.
  2. Wait for it to get stuck at updating the hosts file.
  3. Exit DevKinsta.
  4. Edit the hosts file manually. For this, add entries for your local domain at the end of the file like so (supposing, you used the DevKinsta default domain with .local):
#### START DEVKINSTA entries <wordpress-site-slug>.local www.<wordpress-site-slug>.local  
::1 <wordpress-site-slug>.local  
::1 www.<wordpress-site-slug>.local  
#### END DEVKINSTA entries
  1. Open the Devkinsta config-file (for default Windows installation this is in %APPDATA%\Roaming\DevKinsta\config.json) and under sites find your freshly created site. Replace the "status"-value with "running":
"sites": [
			"id": "<some-unique-id>",
			"status": "running",
			"name": "<wordpress-site-slug>",
  1. Under the same site, there is another entry with key hostFile with "status": "error" and some error message. Remove the error message and replace "error" with "running":
"hostFile": {
    "status": "running"
  1. Now you should be able to start DevKinsta again with no errors and the site up and running!

Hope this helps. Don’t now, why they didn’t want us to know, how we could achieve this step manually…? ¯\_(ツ)_/¯


Hope they solve it soon, in the meantime I will stick with Local by Flywheel until they fix this problem, I would love to use DevKinsta without having to manually update the hosts file.

Hi @claumigue ! Welcome to DevKinsta. I’m sorry for the trouble. You’re right that you shouldn’t have to manually edit the host file and by default it does not. I understand every system is different though and we’re looking at all possibilities to solve this from occurring.

I’ve created 8 sites successfully on local, but the last 2 sites (total of sites is now 10) both seemed to suffer from this problem. @rafu 's fix however quickly sets me on my way again, works great.

Thanks for taking the time to explain the fix.

@rafu workaround works for me for creating new websites. I however noticed that removing sites also wasn’t working for me (not related to workaround). I noticed that the batch file that executes had a lot of garbage dns entries so I looked into my hosts file, which is located in c:\windows\system32\drivers\etc.

It had multiple (3 in total) entries that looked like this:

# Added by Docker Desktop                  host.docker.internal gateway.docker.internal  
# To allow the same kube context to work on the host and the container:                  kubernetes.docker.internal  
# End of section 

I removed 2 of them and made sure that the IP actually matched the one from my network card. I was now able to succesfully remove the websites that I didn’t need anymore, and create a new website without having to go through the workaround.

1 Like

With the release of DevKinsta 2.0, could you tell us if you’re still having this issue? You can download DevKinsta 2.0+ here. Thank you and apologies for the trouble here.

Thank you very much, Michael, for your answer. Since then, as I could not find a solution to the problem with installing a new site on DevKinsta, I no longer used this program. After your new answer, I downloaded the new version and installed it. And I was pleasantly surprised that the new site was installed without any problems from the first try! Thank you for your work and the work of the support service! At a high level!

1 Like

Q: Date/Time this occurred (Provide your time zone also)
A: 7/21/21 10:06AM PST

Q: DevKinsta Version

Q: OS Version
A: Windows 10Pro 19043.1110

Q: Docker Desktop Version
A: 3.5.2

Q: Were any error codes or messages observed? If so, what were they?
A: DK0022 - Host file update failed

Q: Detailed Description of the Problem
A: When I create a new site it stops at 75% with a DK0022 error code saying “Host file update failed” When I try to delete the site it says " you didn’t grant permission for site deletion" I am running as administrator.

Hey @LindsayB . This may be another case of permissions as the host file may be locked. Have anything that might be blocking this operation from completing?

Hi @michael . I suppose it could be antivirus protection, how would I access the correct file to disable this? I have tried to google it but can’t find anything that I could follow. Thanks!

@LindsayB The issue is that there’s a protection enabled somewhere against this file. DevKinsta needs to be able to edit the host file. As an example, here’s how to edit the host file manually although DevKinsta itself still needs to be able to gain access to edit the file. If you’re able to disable the antivirus to test that, that might be a good first step.

@michael I disabled antivirus and firewall but still got the same error. I followed the steps in editing the host file manually but when opening the file etc it is empty.

@LindsayB We’ll take a look at making this step easier. At the moment there’s something on your machine that’s blocking DevKinsta from being able to write to the host file :disappointed:

With the release of DevKinsta 2.2.0, this should now be resolved. Please let us know if you still experience this issue by creating a new bug report. Thanks again for using DevKinsta!