Copied plugins not showing up

Q: DevKinsta Version
A: 1.0.1

Q: OS Version
A: MacOS Big Sur 11.1

Q: Docker Desktop Version
A: 3.1.0

Q: Were any error codes or messages observed? If so, what were they?
A: No

Q: Detailed Description of the Problem
A: Copying plugins doesn’t work immediately.
If I create a new site, and copy plugins over from a directory, none of them appear in the Installed plugins list.
If I go to Add new page, search for the copied plugin, the button for it will be Activate but when I press it, I get an error.

The plugin does not have a valid header.

If I install any plugin from Add new or update an existing one, all the previously copied plugins appear and I can activate them.

My coworker was unable to replicate this on his computer.

Plugins appeared immediately in the listing so this is oddity on my setup it seems.

Hi there. I haven’t been able to reproduce this either. Is there a specific set of plugins perhaps? Do you have any custom configurations with your site or is this a brand new site?

It was when creating a brand new site. Any plugin did it.

I tried uninstalling Docker and even resetting it.
I tried renaming the Application Support/devKinsta folder.
I tried reinstalling DevKinsta but none of those helped.

Then I just removed the /Users/jarno/devKinsta folder and that fixed it completely.

Something from when I tried the Alpha conflicted with that folder itself.
Now it is working just as it should.

1 Like