DevKinsta Super slow

Hello. We have installed DevKinsta on a Windows 11 Home with an I7 processor.
We chose to install with docker.
We have a production website that we want to install locally.
The database is quite big and the website also.
We only have the the basic wordpress installation installed and pages are taking more than 20 seconds to load.
We have augmented the PHP memory in wp-config to 512mb and no change.
We have enabled >>> BIOS-level hardware virtualization support must be enabled in the BIOS settings.
When we check if we have >>> Enable the WSL 2 feature on Windows >>> it shows us the help text
Docker seems to have installed its own version of linux ??? Are we supposed to install another version on top ? We are confused with the instructions provided…

1 Like

Hi, @kebecweb, welcome to DevKinsta!
Do you have any alternate Windows machines that you can test with to see if they are just as slow?

So on a brand new Windows 10 Pro machine I had to install the following:
Docker Desktop

If you are able to open the local site that means you have everything correctly installed. I’m not sure why page loading would take 20 seconds, though unless there is some limitation with your machine.

The DevKinsta system requirements are just based on the Docker requirements here

If you monitor your computer’s performance in Task Manager, when navigating between pages does your CPU usage spike by a large amount? For me in Windows 10, “Vmmem” spikes about 5% when I navigate the frontend of a basic WordPress site. The process is using 3GB of RAM.

I can imagine there being slowness if your processor is being overloaded/taking a while or if you are low on RAM.

Hello. Here are the docker stats via terminal.

Thank you; what happens to those stats why you are waiting for pages to load? Is CPU usage higher?

Before we proceed, I really want to make sure if we have the right WSL2 components installed.

Is the code below ok ?

Microsoft Windows [Version 10.0.22000.556]
(c) Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>wsl --install
Copyright (c) Microsoft Corporation. All rights reserved.

Usage: wsl.exe [Argument] [Options…] [CommandLine]

Arguments for running Linux binaries:

If no command line is provided, wsl.exe launches the default shell.

--exec, -e <CommandLine>
    Execute the specified command without using the default Linux shell.

    Pass the remaining command line as is.

Sets the specified directory as the current working directory.
If ~ is used the Linux user’s home path will be used. If the path begins
with a / character, it will be interpreted as an absolute Linux path.
Otherwise, the value must be an absolute Windows path.

--distribution, -d <Distro>
    Run the specified distribution.

--user, -u <UserName>
    Run as the specified user.

    Launches a shell for the system distribution.

Arguments for managing Windows Subsystem for Linux:

    Display usage information.

--install [Options]
    Install additional Windows Subsystem for Linux distributions.
    For a list of valid distributions, use 'wsl --list --online'.

        --distribution, -d [Argument]
            Downloads and installs a distribution by name.

                A valid distribution name (not case sensitive).

                wsl --install -d Ubuntu
                wsl --install --distribution Debian

--set-default-version <Version>
    Changes the default install version for new distributions.

    Immediately terminates all running distributions and the WSL 2
    lightweight utility virtual machine.

    Show the status of Windows Subsystem for Linux.

--update [Options]
    If no options are specified, the WSL 2 kernel will be updated
    to the latest version.

            Revert to the previous version of the WSL 2 kernel.

Arguments for managing distributions in Windows Subsystem for Linux:

--export <Distro> <FileName>
    Exports the distribution to a tar file.
    The filename can be - for standard output.

--import <Distro> <InstallLocation> <FileName> [Options]
    Imports the specified tar file as a new distribution.
    The filename can be - for standard input.

        --version <Version>
            Specifies the version to use for the new distribution.

--list, -l [Options]
    Lists distributions.

            List all distributions, including distributions that are
            currently being installed or uninstalled.

            List only distributions that are currently running.

        --quiet, -q
            Only show distribution names.

        --verbose, -v
            Show detailed information about all distributions.

        --online, -o
            Displays a list of available distributions for install with 'wsl --install'.

--set-default, -s <Distro>
    Sets the distribution as the default.

--set-version <Distro> <Version>
    Changes the version of the specified distribution.

--terminate, -t <Distro>
    Terminates the specified distribution.

--unregister <Distro>
    Unregisters the distribution and deletes the root filesystem.

--mount <Disk>
    Attaches and mounts a physical disk in all WSL2 distributions.

            Attach the disk to WSL2, but don't mount it.

        --type <Type>
            Filesystem to use when mounting a disk, if not specified defaults to ext4.

        --options <Options>
            Additional mount options.

        --partition <Index>
            Index of the partition to mount, if not specified defaults to the whole disk.

--unmount [Disk]
    Unmounts and detaches a disk from all WSL2 distributions.
    Unmounts and detaches all disks if called without argument.


Hi there.

I tested with a fresh Windows 10 Home install, and simply having the Windows Subsystem for Linux service available was enough for functionality.
No specific components or distro within WSL were installed, which looks like from your wsl --install output you do have available.

Unfortunately, I don’t have Win11 Home for testing, but the fact that DevKinsta does install and the site is accessible points away from a compatibility issue in my opinion.

As Kevin mentioned, CPU or memory limits being reached while DevKinsta/Docker is running could be an issue and is worth checking on for sure.
The Docker stats you shared don’t seem concerning on the container side, though the host machine itself could be peaking.

I am facing the exact same issues.
I have 64 GB of Ram, AMD Ryzen with 8 cores and the page takes 30 seconds to run.

Here’s what I have tried so far (with no success)
Delete docker and downgrade (currently on 4.10)
Check for permissions (every new install seemed to have database connectivity issues until I realized it was that certain strings in the database weren’t being replaced in terms of changing the site address.)
Change WSL to Hyper-V
Change .wslconfig settings.

It takes longer to load a local development single page than it did connecting to a content heavy site a 14.4 modem in the 90s.

I am beyond exasperated and there is no good information on the internet or in any DevKinsta forum about how to address this.

Any ideas?

Hello @Dan_W :wave: Welcome to DevKinsta community!

Really nice computer specs you have there! :heart_eyes: and that should more than enough to run DevKinsta, and the site page load should not that slow (30 seconds to run)!

Could you please also tell, what Windows O/S version you’re running on your computer?

I have another spare computer (intel core i7 Gen-3 with 16GB RAM) runs on Windows 10 Pro version, and I installed DevKinsta and Docker (but I didn’t enable WSL 2 engine there, and only use Hyper-V). I installed fresh WP site locally there, and its site pages loaded almost instantly.

If you’re on Windows 10 Pro, then maybe try to disable/un-check WSL2 on your docker desktop (General) settings as suggested here .


Hi Agus. I am using windows 11 Pro.
I already tried to do exactly what that thread suggested with no success.

I actually tried it 3 times without success and the website takes about 4 hours to download (about 30GB of pictures/files)

Hello @Dan_W ,
It seems you have already tried all the options that are currently available as workaround for this issue.
I would try adding again more resources to Docker by changing .wslconfig settings.
Our devs are aware of the performance issues that DevKinsta might have on Windows and are currently working on a fix. Unfortunately, we don’t have a specific ETA for its release just yet, but in the first few tests we have done internally the page interactivity is much faster.