DK003 Couldn't install docker on Kubuntu Linux


I’m on Linux, running Kubuntu 20.10, trying to setup DevKinsta on my computer.

I can install the .deb file just fine, however, when I open the app the installation process stops when trying to install Docker and I get the error code mentioned in the title.

Hi @dexter ! Welcome to DevKinsta!

Officially, DevKinsta currently only supports Ubuntu. We haven’t tested with Kubuntu.

Try installing Docker via their official site manually and see if that helps.

Hello @michael!

The way Ubuntu and Kubuntu handles packages are practically the same so installing Docker from their website was no problem!

Unfortunately, when i run the DevKinsta installer after downloading Docker, the installer gets stuck on “Starting Docker…” for a while. After a few minutes it tells me to try running Docker manually, but when I do, it gets stuck on the same “Starting Docker…” again.

@dexter Unfortunately, we don’t have a instance of Kubuntu here to test this to determine whether the issue is unique to Kubuntu.

Are the containers being installed at all in Docker? There should be five containers related to Kinsta there.

Hi again,

It seems I’ve fixed the issue.

What i did was input sudo adduser (username) and then the docker group in terminal and it worked.

I ran into another issue though which I’ve faced before when running lamp stack where when trying to update plugins on wordpress it asks for FTP connection. To fix this, i started by looking at what permissions are needed with ps aux then look for DevKinsta, in my case it was user.

Next i navigated to where the website is located /home/DevKinsta/public/(websitename) and then i changed the permissions to user with sudo chown -R (user) (websitename)/ and now it is working fine.

Hope this can be of use to anyone who has the same problems as me!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.