Error DK0031: Port 80 and 443 is used

Hi Michael,

I have several apps running according to the list, including Spotify, my Stream Deck, Dropbox and more.

I hope this doesn’t come off as combative, but can you tell me the purpose for requesting that information?

Are there known conflicts with other Docker-based apps like Local by Flywheel?

Hi Joe,

No problem at all. The purpose was so we can better understand what’s conflicting with DevKinsta. It may conflict if you have other web services running with port 80 or 443. In my own testing, it does not appear to conflict with Local.

Thanks Michael,

Understood! Attached are the results of the command.

In the mean time, is there a way to define a different port?

Thanks for the screenshot. I don’t see 80 or 443 being used there. I’m checking with the development team on this as well and will get back to you shortly. I’m afraid at this time it’s not possible to define a different port. It’d make for a great first feature request though!

1 Like

Hi Joe. Although we’re unable to determine the cause of the issue you’re having, we’ll be releasing a fix that includes additional checks regarding ports in the next version. Sorry for the trouble and thanks again for trying out DevKinsta!

Hey Joe. Sorry for the double reply. Could you try one more thing? Try restarting the customer with no other applications running. Then try opening DevKinsta again and let us know if that helps.


Watching the Memory processes in Activity Monitor, what’s using Port 80 switches as processes switch. Some are system level and as expected, restarting did not work.


Hi Joe,
Could you try the latest version of DevKinsta and let me know if that helps?

That didn’t work, nor did uninstalling Docker and starting from scratch.

I was able to get it working on my BigSur laptop. I’m not really sure what the conflict is on my iMac Pro. The main difference is I’m running Catalina on this and I have several live streaming tools.

Thanks for testing that out. Our developers will look into this and I’ll provide an update when we have more information.

We also have a feature request submitted for changing port numbers if you want to add to that :slight_smile:

1 Like

Hi @michael,

I thought it worthwhile to +1 this as I am having the exact same issue. I am on macOS v11.1 and also have Local by Flywheel installed.


Thank you

Update: Hi @michael and @jcasabona I managed to complete the installation by killing all processes on port 80, however, I have no idea if this is a long-term fix (presumably not).


# find & kill processes which are using port 80
sudo lsof -i tcp:80 | grep LISTEN | awk '{print $2}' | xargs kill -9


# find processes which are using port 80
netstat -ano | findstr :80

# kill process by PID. replace "<PID>" with result from the above command.
taskkill /PID <PID> /F

Support: DevKinsta Error Codes - Kinsta


1 Like

Thanks for the workaround, @ElliottMangham. We’ll have more information on this soon too.

Hi @ElliottMangham I tried to use your command but I get this error:

kill: 78: Operation not permitted

Do you have the solution for this?

Hey, I am afraid I only followed Kinsta’s own support page: DevKinsta Error Codes - Kinsta

I’m not sure if this is helpful, but checking the actual Docker app, it seems devkinsta has had some resources created there despite the installation failing.

Hey party people. I found this thread and the solution here worked for me: macOS Catalina (10.15.5) has port conflict with httpd · Issue #1364 · docksal/docksal · GitHub

Seems at least in macOS Catalina, for me, httpd got all agro. Running this command worked:

sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist

Nothing seemed to break on my machine, but use at your own peril.

1 Like

Good news everyone! We’ve released DevKinsta 2.3.0 which introduces a port selector! It’ll automatically detect open ports, but you can also select your own ports if you wish. I’ll be marking this bug as resolved but if you encounter any issues with this new feature, please do create a new thread here. Thanks so much everyone who has contributed to this thread here! Here’s more information on this update: DevKinsta Releases (Minor) - #7 by michael