Error establishing a database connection

i updated devKinsta and Docker now when i try to open one of the sites i get the error “Error establishing a database connection”.
It happens with all sites, if I try to open the database here too there are errors.
I am attaching screenshots.

Thank you

Hi @WoodyP . It sounds like you may be experiencing the issue highlighted here. Could you tell me if the solution posted there works for you?

Nothing does not work, it was already 59gb, I took it to the maximum Disk image size: 73.5 GB (5.2 GB used), but the problem remains, the database does not connect.
I hope I haven’t lost everything…

@WoodyP Are all containers running on Docker?

yes all containers are running…

I see. DevKinsta may need to be re-installed. Would you be able to do that and let me know if that helps?

but do I lose all my jobs?
I have a Mac, do I need to download and overwrite the application?

You will not lose the data as that information will stay within Docker and local folders. Before you do that, could you paste a screenshot of the following within Terminal?

docker exec -it devkinsta_db bash
mysql -p
#here copy your db password
show databases;


do i have to send your code to the computer terminal?

That’s correct. Try each line one by one.

Here is the screenshot of the terminal.
thank you


I reinstalled the devkinsta application, the problem is not solved.

It looks like the database password that was entered here did not work. Here’s a guide on where to find the password for the database. Let me know if that works for you.

it does not actually allow me to enter the password, every time it asks me to enter it, the cursor does not write.
I tried to access by re-entering the line “mysql -p” but the password does not make it enter …

Within Docker, could you try deleting devkinsta_db and the devkinsta_db_data volume as well? Re-open DevKinsta and it should download those again. We believe something may have gone wrong during the update on your machine.

will I not lose my works by deleting the DB container?

Among other things, Docker is missing one of the containers that you reported the “devkinsta_db_data”

sorry yes i found devkinsta_db_data is a volume not a container like devkinsta_db.
So do I have to delete them? won’t i lose my jobs?

Thank you

To backup the database, you’ll need to be able to login with mysql -p but I understand it’s giving you issues. Keep in mind that when entering the password, it’s hidden by default. Perhaps it’s entering but as it’s hidden, it’s not showing? Try pasting the password anyway and see if it lets you in.

you were right, pasting you do not see anything, but confirming, it goes on. Tell me what to do now before I delete the containers.

Unfortunately based on that screenshot, it appears the database is missing. That would explain why it’s been appearing as “Error establishing a database connection”. Do you recall how DevKinsta and Docker was updated? Did you by chance uninstall it?