Sites > Force Thumbnail Generation?

I have a specific Site that won’t generate a thumbnail and I’m not sure how to resolve.

I’ve tried deleting and reinstalling the WP install, re-importing, renaming. I even tried reinstalling DevKinsta (and Docker) at one point, to know avail. I don’t have any issues with the site otherwise (that I know of) nor do I have an issue with any other Sites (all display a thumbnail as expected).

Is there a way to force generate a new Site thumbnail?

Hey there, mattrock :wave:

Thanks for posting to the Community Forum!

I’m sorry to hear you’re having some issues. We should be able to help you out! Can you elaborate a bit on what thumbnail you’re referring to?

Are we looking at the preview image for the site located just to the left of the Site Name? Or are you talking about another image, e.g. the Favicon of the site?

If you have any screenshots of what you’re referencing that would be great!


Hi Jake!

You’re correct, it’s the preview image for the site located just to the left of the Site Name. See attached.

The Site in question was a Custom site initially (I’m in the process of re-adding my sites after wiping them out with a reinstall), though I reinstalled as a default installation to see if maybe that’s where the hiccup was. No dice, unfortunately.

I appreciate your insight and help!

Hi @mattrock :wave:

I was able to replicate and fix the issue by ensuring that the homepage of my website was visible and giving an HTTP 200 Ok response for non-logged-in users. Restarting DevKinsta and Docker also seems to have done the trick. It’s possible that the issue was related to the accessibility of the site’s homepage. I hope this helps!

Hi Adrian,

I’m getting HTTP 200 OK responses, and restarting DevKinsta and Docker did not resolve (I had went so far as to uninstall, manually remove related files as per another troubleshooting post, etc).

I’ve since spotted the following: There is an error creating the thumbnail due to a certificate error.

[2023-12-18 11:22:19.614] [info]  [createThumbnail] Trying to create thumbnail, tries left: 1
[2023-12-18 11:22:23.663] [error] create thumbnail error: Error: ERR_CERT_AUTHORITY_INVALID (-202) loading 'https://snowopsmag.local/?skip_cache=1'
[2023-12-18 11:22:23.663] [error] [createThumbnail] Failed to create thumbnail on /Users/moreilly/Library/Application Support/DevKinsta/static/img/sites/fbf50339-4464-4414-9d5e-98451691d4a6.png, no more tries
[2023-12-18 11:22:23.683] [info]  [action/setThumbnail]  {"path":"/Users/moreilly/Library/Application Support/DevKinsta/static/img/sites/fbf50339-4464-4414-9d5e-98451691d4a6.png","siteId":"fbf50339-4464-4414-9d5e-98451691d4a6"}
[2023-12-18 11:22:23.722] [info]  [dockerUtil/getContainer] Get 'devkinsta_fpm' Docker container
[2023-12-18 11:22:23.723] [info]  [isWpSite] Checking if snowopsmag is a Wordpress site
[2023-12-18 11:22:23.723] [info]  [ViewSite] checking site unread emails
[2023-12-18 11:22:23.724] [info]  [getSiteMailbox] Update site mailbox with API query: search?kind=containing&query=snowopsmag.local
[2023-12-18 11:22:23.726] [info]  Response: 200 OK
[2023-12-18 11:22:23.726] [info]  Response headers: {
  'content-type': 'application/json',
  date: 'Mon, 18 Dec 2023 17:22:23 GMT',
  'content-length': '42',
  connection: 'close'

It references https though the site is http (ref; screencap). I enabled https at one point, so perhaps it’s a stubborn remnant of this?

I temporarily changed the top-level domain (.test) and back (.local) to see if that might clear some sort of cache hiccup, with no luck. Any ideas?

Much appreciated,

It maybe related to the SSL indeed. But you could try creating the image file manually to the same location where [createThumbnail] Failed action failed.

ty[2023-12-18 11:22:23.663] [error] [createThumbnail] Failed to create thumbnail on /Users/moreilly/Library/Application Support/DevKinsta/static/img/sites/fbf50339-4464-4414-9d5e-98451691d4a6.png, no more triespe or paste code here

I tried it on my test site too and I am able to manually change the thumbnail by just updating the .jpg image on its location.

I hope it helps!

Right. I knew replacing the thumbnail (.png image :slight_smile:) was a quick fix, but I believe fresh thumbnails are generated (when the page is updated, the site is launched via the dashboard, or at some sort of interval, I’m not sure) so getting to the root of the issue is my goal. I do appreciate you helping me try to get there though!

You are always welcome. :slightly_smiling_face:

It seems that when the HTTPS is enabled or disabled, a [wpSearchAndReplace] action is run in the site’s database. However, there could still be some hard-coded HTTPS entries or Uninitialized Classes that our script couldn’t capture.

You can try stopping and starting the site in Devkinsta to trigger the [createThumbnail] action. If the issue persists, you might want to check the site’s wp-config.php file for any custom scripts that could be forcing HTTPS, or you could temporarily disable any plugins that force requests to HTTPS. :+1: