Something Bad Happened: Creating New Site

Q: Date/Time this occurred (Provide your time zone also)
**A:**August 27, 2022 EST, 10am

Q: DevKinsta Version

Q: OS Version
**A:**Windows 10 PRO

Q: Docker Desktop Version
**A:**Docker Desktop 4.11.1 (84025)

Q: Were any error codes or messages observed? If so, what were they?
**A:**During First new site install after the NGINX install DevKinsta reports “Something Bad Happened”.
Within Docker’s MariaDB log file is see the following:
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Q: Detailed Description of the Problem
**A:**During First new site install after the NGINX install DevKinsta reports “Something Bad Happened”.
Within Docker’s MariaDB log file is see the following:
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

DockerDesktop, Containers, Images and Devkinsta all seem to be installed properly as per documented instructions.

Hi @bmunir, thanks for reaching out. Are you running Docker under WSL2 or are you using Hyper-V? Can you try again then share your main.log file with me privately? On windows it will be somewhere like: C:\Users\USERNAME\AppData\Roaming\DevKinsta\logs

Hi Kevin,
The first time I used WSL2. Then after failure I uninstalled everything and did a fresh reinstall using Hyper-V. In both cases, I am running into this same issue, where the install craps-out after the NGINX install.
It appears that DevKinsta cannot successfully create a new database (due to root permissions)?

Attaching main.log
[main - Copy.log]


1 Like

Hi @bmunir, replied to you privately as well. It seems as if the root password that DevKinsta is trying to use isn’t the same as what is set in MySQL. That’s my best current guess. It’s interesting that the error remains the same even if you switch between WSL and Hyper-V.

Are you installing DevKinsta for a non-root/admin user on your PC?

Same Error…

I am using DevKinsta first time, Worst Experience…

Hi there @dgaroorkee :wave: welcome to our community!

Could you please provide more information/details of the following:

  • The DevKinsta Version you’re using?
  • The Operating System Version (e.g.: if it’s Windows 10 Pro or Home?)
  • The Docker Desktop Version you’re using?
  • And are you running Docker using WSL or Hyper-V ?

Please also send the main.log file of your DevKinsta (via DM) to me, so we can check further - if there’s such information which could tell what happened for that error (“Something bad happened” thing). You can check here on how to get that main.log file.


ok, Thanks for your response.
The required information are here:
DevKinsta Version 2.11.0
Windows 10-Home
Docker Version 4.22.0
main.log file attached with it too.
main.log (845.4 KB)

Thank you for the information/details as well as that main.log file.

Since you’re using Windows 10 Home O/S, it’s always recommended to use WSL instead of Hyper-V as per our documentation here: Installing DevKinsta - Kinsta®.

I also checked the main.log file you sent, and noticed the following error in that file, when you tried to create that new local site “Proj_DKD_001” (but got “Something bad happened” on the second step - that was when DevKinsta trying to create a database for that site in question) :

[2023-08-14 01:45:37.771] [info] [containerExec] Command ‘mysql -u root -p****** -e “create database Proj_DKD_001;”’ on devkinsta_db finished with exit code 1

[2023-08-14 01:45:37.799] [error] [ipcMainStep] Error in operation SITE_CREATION, step database: Error: Error (1): UERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

The issue here seems to be related to that MySQL root password (access denied) issue on your local docker’s container.

Now I assume there’s no other sites data yet, as you just tried it for the first time and there’s no important data in it, right? If that so, then my suggestion would be as follow:

  1. Exit and shutdown completely for both DevKinsta and Docker Dekstop

  2. Then try to remove and clean-up DevKinsta completely (remove any folders/data related to it) as well as to remove all containers, images, network volumes, etc. in Docker Desktop.
    Also you will need to remove/delete anything inside these folders on your computer
    (e.g.: C:\Users\DGA\AppData\Roaming\DevKinsta , and C:\Users\DGA\DevKinsta ) .

  3. Once they have been removed completely, please try to restart your computer, and after that you may want to re-install the Docker Desktop first, and followed by to re-install DevKinsta (it will re-download/setup new images/containers from scratch).

I suggested the same steps in the previous old thread which was confirmed to be working fine by the other user (they used Windows 11 Home).


First, Thanks for your response to solve this issue…

I have done everystep and thing which you describe here, But the result is same…

So, I am returning my Laragon (Local Server)…Thanks again!

Thank you for your reply and update!
Yeah I’m not sure what happened as I couldn’t replicate on my end and the same steps I suggested in the other / old thread was confirmed to be working fine by that other user.
Alright then, if you have any questions, you can always post / create a new post in this community forum!



For just now, I want to save my precious time only…