Something bad happened

Q: Date/Time this occurred (Provide your time zone also)
**A: 3/30/22 11:00 EDT

Q: DevKinsta Version
**A: 2.5.0

Q: OS Version
**A: Windows 10

Q: Docker Desktop Version
**A: 4.6.1

Q: Were any error codes or messages observed? If so, what were they?
**A: “Something bad happened”

Q: Detailed Description of the Problem
**A: This is the second time I’ve tried to use Dev Kinsta. On my first machine I could never get it to create a database so I gave up. Now I’m trying on a different system. When I try to create a site at some point I get an error saying “Something bad happened” and no other error code

When attempting to pull down an existing site (a staging site if that matters) I got to 40% before hitting the error. (Last completed step “Creating mysql database”

When attempting to just create a fresh wordpress site (no importing) I got to 75% (last completed step was “Installing WordPress 5.9.2”)

Looking at the log file I see "This does not seem to be a wordpress installation --path=path/to/wordpress which looks to be coming from

Any suggestions? I love the idea of dev kinsta but this is my second attempt at using it on two different machines and I’ve yet to get it to create a site.

Hi @pasmith, welcome to Devkinsta!
It sounds like something could be going wrong with file permissions but I can’t be sure without the full log files.

Can you please private message your main.log file with me and I’ll see if anything sticks out with all of these errors: DevKinsta Error Codes - Kinsta®

Also, are you using WSL2? And are you running DevKinsta as the main/root user on the computer?

I’ve actually had the same issue on two machines.

Machine #1: WSL2, Windows 10, Dev Kinsta installed only for the current user.
Machine #2: No WSL2, Windows 10, Dev Kinsta installed for all users.

I looked at the log further and I’m seeing some rsync errors. I’ll PM the logs from Machine #2

Thanks for sending that over @pasmith; I’m going to look this over with our devs.

So there are some issues that occur when you run DevKinsta as a non root user but that doesn’t explain machine #1s issue. I would have to see that main.log as well to see if it’s the same issue.

Machine #2 doesn’t seem to be connecting to the Staging container. I’m not even seeing the failure attempts reaching the server on Kinsta. Can you use Command Prompt or Powershell to SSH from that machine to the staging container? I just want to make sure it isn’t purely a network issue.

I’m also going to ask about the significance of this error:
Error: ENOENT: no such file or directory, open '..i\DevKinsta\kinsta\sites.ini'

Hey Kevin,
So this is interesting. While I can sftp to the server, when I try to SSH into it I’m getting a Permission Denied when I enter the password. Same credentials of course, taken direct from my.kinsta.

So that might be a problem for a different department but it would explain my issues with Dev Kinsta!

1 Like

So in talking to Kinsta support and trying different things, I can’t SSH in through Windows Powershell, but I CAN SSH in if I spin up Ubuntu on WSL and try it from in there.

I’m not sure what, if anything, that tells us with regards to Dev Kinsta…

1 Like

Thanks for the update @pasmith .

As you work with our Support team, try running the ssh command with -vvv appended to it. That should give you a lot more useful information. I’ve seen this before when there are issues with the machine’s SSH keys.

Hi Kevin,
So I installed putty and set up SSH keys and can now SSH via putty.

I tried Dev Kinsta again and was watching it. Before I get “Something Bad Happens” a cmd window pops up…but nothing happens in it. Then it closes and I get the error. I’m guessing that’s where/when the connection should be happening?

OK now I’ve set up Powershell’s SSH to use a key, and I can log in via powershell too. Just for giggles I confirmed it words from cmd.exe as well.

Dev Kinsta still isn’t happy, though.

Yes, that might be where it’s happening. Can you try Force closing DevKinsta then running it as Administrator?

It might also help to log out of DevKinsta and log back into your MyKinsta account.

Is the error still exactly the same in main.log?

Hi Kevin,
I quit DevKinsta, restarted it as Admin, logged out, quit again, started as Admin again, and finally logged back into My Kinsta.

No change, I’m afraid.

In the log I see the SSH key is OK:

[2022-03-30 18:15:06.752] [info] [renewSshKey] SSH key is valid

But then trouble starts:

[2022-03-30 18:15:06.754] [info] [createMySqlDump] Create mysql dump
[2022-03-30 18:15:06.755] [info] [dockerUtil/getContainer] Get ‘devkinsta_fpm’ Docker container
[2022-03-30 18:15:28.011] [warn] [dumpSiteDatabase] Some warnings from mysql: Essh: connect to host [IP REDACTED] port 12897: Connection refused

And then rsync fails too

[2022-03-30 18:15:49.293] [info] [downloadSite] Download files
[2022-03-30 18:16:14.120] [warn] [terminalExec] Error: ssh: connect to host [REDACTED IP] port 12897: Connection refused

[2022-03-30 18:16:14.121] [warn] [terminalExec] Error: rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
rsync error: unexplained error (code 255) at io.c(228) [Receiver=3.2.3]

But the redacted IP address is not the IP address that shows when i visit the site in my.kinsta
Is that normal? I’ll PM you the IP addresses

Ah, thanks for that, Peter.

The IP that you redacted is valid; that’s how DevKinsta connects using the IP address for external connections so yes, I I’m assuming that’s where the issue is occurring.

I’m going to share this with our devs to see if they can shed any light on why this could be happening to you. I’ve never seen this exact issue occur before so I’m at a loss right now.

Just to cover more bases, I would recommend trying to Pull any other site from MyKinsta to DevKinsta. If the error is always consistent regardless of the site IPs/Ports, then something is probably wrong with your DevKinsta installation and we can concentrate on troubleshooting there. Right now there could also be an issue on the MyKinsta side.

Actually, I just had a though @pasmith, that IP address is actually the IP address for external connections. You should be able to connect to that IP address/your staging port without issue, but it seems as if something is blocking it. I’m able to connect to that IP address/your Live port without issue. It seems as if this could be an issue within MyKinsta/this specific site.

Can you please reach out to our Support then have them verify this:
Create an SSH connection on Live using the IP address for External Connections, then try the same for Staging. The staging port seems to be timing out/blocking the connection.

I’ll still mention this with the DevKinsta devs but hopefully our Support team can help you out sooner/look into this with our Sysops team.

Hi Kevin,
I’ll talk to support. But I have just confirmed I can SSH to the “External Connections” IP on the Live Port, but not on stage.

On my my.kinsta pages the External Connections IP is not displayed for staging servers; I’m not sure if that is relevant or not.

All that said, I just tried to import the live site and had no better luck. This time I saw a new error in the log file though:

Permissions 0755 for ‘/root/.ssh/id_rsa’ are too open.It is required that your private key files are NOT accessible by others.This private key will be ignored.Load key “/root/.ssh/id_rsa”: bad permissions

My private key is not in /root/.ssh/id_rsa (remember I’m on Windows) so I’m not sure what this is referring to, unless Dev Kinsta is copying my key into a container and not setting the permissions correctly?

Anyway I appreciate all your help but I think I need to go back to doing my dev work the old-fashioned way and just spin up a docker container and download a backup of the site and put stuff together by hand. I’ve got a deadline for this project and can’t really spend much more time trying to get Dev Kinsta to work right now. I’ll give it another go at some point when I have more time to play around with things.

1 Like

Thanks @pasmith for working with us and yes please feel free to pick this up again in the future when you have time.