Staging Site Password Protection displayed on Live site

Our Staging Site Password protection was being displayed on our Live site front end.
The only thing I did yesterday and can’t see this being the culprit is found and replaced.

48 results replaced from “” to “

I disabled the Password protection on staging to fix it but afraid to add it back.


Hello @monofrio :wave:

As I can see at the moment, your Live/production site is no longer showing that “Password protection (HTAuth)” pop-up, while as I can also see the Staging site is prompting for that password auth pop-up.

Looks like you have re-enabled that Password protection on the Staging site, and at the moment it’s no longer showing on your Live site.

As you mentioned before that when you performed that Search and Replace, several old staging URLs were found and replaced by the Live site URL in the database, and that most likely solved the issue in question. So yeah, when Password Protection is enabled on the Staging environment and if there’s a link/request on the Live site to call that Staging URL, then the HTAuth pop-up would appear on the Live site’s too.

I think this has now resolved already then? :smile:
anyway if you’re still experiencing issue (like the case mentioned above) with your WordPress sites hosted on our server (Live site or Staging site), I would suggest to open a support chat instead, and our support team will be happy to help and assist you right away!

Best regards,

The issue was due to bring over one asset by accident from staging that caused the sign-in box to display. After running another search and replacement, it did fix the issue. Thanks for helping and checking into this.

Hi @monofrio!

We’re glad to hear that this issue has been resolved. If you do have any questions in the future please don’t hesitate to reach out to our Support team, or post a new thread on our community forum!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.