Unable to resolve error DK0005 after switching to Hyper-V

Hello all. Very noob and “learning as I go” kinda user here.

I installed DevKinsta using WSL 2 on Win 10 Pro to create a local WordPress development environment. I was having the painfully slow lag time with every page update experience so many have experienced. I found this link on here and followed it:

[Why my local site is so slow? - Bug Reports - DevKinsta Community]

First I enabled Hyper-V and enabled an external virtual switch per the first instructions to the letter. No problems.

Rebooted my computer.

Then I backed up and deleted my one and only website, per instructions.

Then I restarted DevKinsta. Three images kept getting fed into Docker. I clicked them all and hit the “run” button. It seemed to work but the second after they loaded, they seemed to exit and I was stuck in a loop of continually having to check them to run and hit run but then the loop would start over without any tangible progress. It would result in the “DK0005” error.

I followed the instructions on the website: Manually restart Docker Desktop and then restart DevKinsta. I did. Nothing changed.

As I write this, I opened Hyper-V manager for the first time to make sure it was still working. It shows a VM machine “DockerDesktopVM”. I then tried to restart the Docker desktop with the Hyper-V manager and now all of a sudden Docker fails to start. I double checked to make sure the WSL2 option isn’t selected in Docker. Same error.

I uninstalled Docker and reinstalled. Rebooted computer. WSL 2 option still not checked.
Started up DevKinsta. Still same error.

I’m really REALLY at a loss. The only thing left would be for me to uninstall DevKinsta and reinstall. But I literally just spent the last 48 hours installing, updating etc etc all themes, plugins, etc for WordPress. I would HATE to lose all that time.

Anyone have any ideas? I would be so grateful. Again, I’m a noob and learning as I go tutorial by tutorial so I apologize if I’m not doing something obvious.

Thank you so much!

Update: Trying to give all the helpful info I can. I was playing around with Docker Desktop. I was able to start up 6 images (all relating to DevKinsta). My hope was that if they were all running, then mayit DevKinsta would start up if I booted it up AFTER the six images. However, the loop continues. It is three specific images. See the added screenshot. The three images that aren’t running are the ones that keep cycling after eack DK0005 error. Yes, each time the error cycles and I hit “retry” they seem to boot up for about a second but then instantly stop.

Hello @HomeHeart and welcome to DevKinsta Community!

If you click on the three dots menu on the line of the devkinsta_db container and then click on View Details, does it show any helpful log?

If you want you can send me via DM the content of that terminal so we can review it.