Website Interactivity is Slow

@Joe_G Not yet I’m afraid. Are you still experiencing issues with the latest version released this week?

Upgraded to latest version today and can confirm the major slowness issue persists.

It’s been 3 months and still no solution from the KINSTA development team about the slowness that prevents from using this solution in a professional way. Honestly, you should be a little more active…

@ErikDeNice I’m very sorry for the trouble here. We’ll continue looking into this issue.

Same issue here. Could this be related to WSL 2? Every time I run DevKinsta I get the following warning from Docker Desktop:

Docker Desktop - Filesharing
Docker Desktop has detected that
you shared a Windows file into a
WSL 2 container, which may perform
poorly. Click here for more details.

Hi everyone. Thank you for reporting on this issue. We’d love to obtain additional information from those affected by this. We’d really appreciate it!

If possible, please let us know the following information:

  1. A screenshot from browser Inspect network activity that shows the network information from the affected site.
  2. The content of the hosts file. You can use cat /etc/hosts on your Terminal.
  3. The following curl output curl -s -w "@curl-format.txt" -o /dev/null https://siteName.local. Note: This curl command requires putting this file to the path where we execute the curl.
  4. Providing us with the HAR file from your browser

Thank you again and apologies for the issues here!

Thanks for the response @michael!

What method would you recommend for sharing the info with ya’ll but not the public? Email address, reference via chat, …?

@mattd Good question. You may DM it to me here, through chat, or email If you do use chat or email, please reference this thread here so it reaches me.

1 Like

I’ve been working with multisite over the past few weeks testing how it works. I’m now creating a brand new instance that I will push to my Kinsta account, but as I’m setting up the subdomain the site is running very slow. No content, no images and everything is correct in the hosts file, it is just super slow. Have there been any reports of this in the latest update?

Hi @Eileen. I’m very sorry for the trouble there. I’ve merged your topic with a reported bug here that others are experiencing. We’re still looking into this.

Hi. I have exactly the same problem. Win10, i7, 12gb RAM. Thanks.

A post was split to a new topic: Slow/Performance Issues with DevKinsta

Hi @michael, is there any update on this? As others have mentioned, it has been a long time since this performance issue was raised. On my end, I’m hardly seeing improvement (if any at all) in page load times on the local environment, also not after updating DevKinsta to the latest version.

Hi @GoldyOnline! We don’t have any update at this time, though I’ll certainly let the dev team know this is still an ongoing matter. Is it possible to receive the details from your install as outlined by Michael in the previous post? I’m not sure if it may have been shared yet outside of the community forum or privately via DM to Michael directly so apologies if that has already been done.

We’ll update here once we’ve received additional word from the developtment team, we appreciate the continued feedback!

Sorry for the slow reply but I wanted to find some time to properly site down and collect the data, however, when I did yesterday I ended up spending the time on trying to figure out a solution instead. And I actually did find an alternative solution that resolves the issue completely for my system:
I upgraded my Windows 10 Home to Windows 10 Pro, and then switched to using Hyper-V instead of WSL 2, as also suggested by others earlier in this topic, this completely resolved the issue for me, the local environment is lightning fast now!
This might not be a solution for everyone but I’ll share what I did below, perhaps it will help at least some people with similar issues.

What I did is:

First I tried to resolve the issue in the existing Windows 10 Home + WSL 2 environment.

  • I (once again) updated Docker to the latest version that just came out but this didn’t help at all.
  • Experimented a bit with different resource allocations using “.wslconfig” but again this didn’t help at all.
  • I then enabled the feature “Hypervisor Platform” in Windows 10. I’m not sure if it makes much sense from a technical point of view (I don’t know enough about it) but it did seem to improve the situation somewhat. That’s relatively speaking though as page load times were still between 5 an 10 seconds most of the time, and sometimes even more than 10 seconds.

Working in the Wordpress backend was equally slow, dramatic one should say better. Also, CPU usage and Power usage (checked in Task Manager) were very high while loading pages or working in the WP backend. A process called “COM Surrogate” usually would shoot up dramatically in CPU and Power usage and my laptop would get super hot and the fan was blowing like there is no tomorrow. I have no clue why as I was doing almost nothing in the test environment other than opening a few pages. I guess it’s somehow related to the combination of Windows 10 Home, Docker and WSL 2 and perhaps the way the files are shared between Windows and Docker in the DevKinsta setup as per the warning “Docker Desktop has detected that you shared a Windows file into a WSL 2 container, which may perform poorly.” that was mentioned previously in this topic already.

Then I switched to Hyper-V and it makes all the difference! The steps for that were/are:

  1. If you are on Windows 10 Home, upgrade to Windows 10 Pro. At least, I believe this is required as Windows 10 Home is not showing the “Hyper-V” and “Container” options in “Turn Windows features on or off”. I did the upgrade to Windows 10 Pro via de Microsoft store and the process is surprisingly simple and quick. It did cost 145 Euro… but for me that was better than wasting more time on a slow environment. The upgrade did initially say it failed, and the license was not activated, however, then I manually rebooted, and Windows then automatically finished the upgrade process anyway and after the reboot I was on Pro with the purchased Pro license active.
  2. After the upgrade I tested if the combination Windows 10 Pro + Docker + WSL 2 was any better but it wasn’t, the issue remained the same.
  3. After the above, it’s better to first export the mysql database(s) of the local development site(s). (I did it later but it’s easier to do it first to avoid having to switch back to WSL 2 later to get it)
  4. Then I enabled the “Hyper-V” and “Container” options in “Turn Windows features on or off”.
  5. Then in Docker in Settings > General, I disabled the “Use the WSL 2 based engine” option. And then clicked Apply & Restart.
  6. After that I started DevKinsta which will then attempt to create and update containers for the Hyper-V environment. I ran into an error during this process but the solution described here resolved that: Windows 10 Pro: DK0005 error (adding the path mentioned there as described)
  7. Once DevKinsta is up and running, import the mysql database(s) in the new environment.

After this my local environment is working very fast and is now a proper environment for development. The funny thing is that in Docker settings it says “WSL 2 provides better performance than the legacy Hyper-V backend.”, which I suppose is normally true but not in this case that is for sure!

All of the above is of course a workaround, it doesn’t solve the issue with WSL 2, but simply avoiding using it at all is good enough for me.:smiley:


I just tried this solution and now instead of waiting a minute or more for a page to load, I’m getting almost normal loading times.

1 Like

Thank you for sharing your info!

I tried another approach, i managed to enable Hypver-V for windows home following this:


But the problem is Docker still knows i am on windows home, so the option “Use the WSL 2 based engine” in step 5 is not possible for me.

Anybody has a solution for this?

I believe that apart from “Hyper-V”, Docker als requires the “Containers” option enabled in “Turn Windows features on or off”. Maybe that is the issue?

@GoldyOnline Wow! Thanks so much for digging into this! I’ve sent this over to the devs to review:pray:

1 Like

Just switched to Hyper-V (ie, unchecked using WSL 2 in Docker) and WOW, what a difference!! Load times went from mid 20s to mid 2s :astonished:

Thanks for the details, and note on backing up your databases before switching @GoldyOnline