Website Interactivity is Slow

Thanks for the response @michael!

What method would you recommend for sharing the info with ya’ll but not the public? Email address, reference via chat, …?

@mattd Good question. You may DM it to me here, through chat, or email support@kinsta.com. If you do use chat or email, please reference this thread here so it reaches me.

1 Like

I’ve been working with multisite over the past few weeks testing how it works. I’m now creating a brand new instance that I will push to my Kinsta account, but as I’m setting up the subdomain the site is running very slow. No content, no images and everything is correct in the hosts file, it is just super slow. Have there been any reports of this in the latest update?

Hi @Eileen. I’m very sorry for the trouble there. I’ve merged your topic with a reported bug here that others are experiencing. We’re still looking into this.

Hi. I have exactly the same problem. Win10, i7, 12gb RAM. Thanks.

A post was split to a new topic: Slow/Performance Issues with DevKinsta

Hi @michael, is there any update on this? As others have mentioned, it has been a long time since this performance issue was raised. On my end, I’m hardly seeing improvement (if any at all) in page load times on the local environment, also not after updating DevKinsta to the latest version.

Hi @GoldyOnline! We don’t have any update at this time, though I’ll certainly let the dev team know this is still an ongoing matter. Is it possible to receive the details from your install as outlined by Michael in the previous post? I’m not sure if it may have been shared yet outside of the community forum or privately via DM to Michael directly so apologies if that has already been done.

We’ll update here once we’ve received additional word from the developtment team, we appreciate the continued feedback!

Sorry for the slow reply but I wanted to find some time to properly site down and collect the data, however, when I did yesterday I ended up spending the time on trying to figure out a solution instead. And I actually did find an alternative solution that resolves the issue completely for my system:
I upgraded my Windows 10 Home to Windows 10 Pro, and then switched to using Hyper-V instead of WSL 2, as also suggested by others earlier in this topic, this completely resolved the issue for me, the local environment is lightning fast now!
This might not be a solution for everyone but I’ll share what I did below, perhaps it will help at least some people with similar issues.

What I did is:

First I tried to resolve the issue in the existing Windows 10 Home + WSL 2 environment.

  • I (once again) updated Docker to the latest version that just came out but this didn’t help at all.
  • Experimented a bit with different resource allocations using “.wslconfig” but again this didn’t help at all.
  • I then enabled the feature “Hypervisor Platform” in Windows 10. I’m not sure if it makes much sense from a technical point of view (I don’t know enough about it) but it did seem to improve the situation somewhat. That’s relatively speaking though as page load times were still between 5 an 10 seconds most of the time, and sometimes even more than 10 seconds.

Working in the Wordpress backend was equally slow, dramatic one should say better. Also, CPU usage and Power usage (checked in Task Manager) were very high while loading pages or working in the WP backend. A process called “COM Surrogate” usually would shoot up dramatically in CPU and Power usage and my laptop would get super hot and the fan was blowing like there is no tomorrow. I have no clue why as I was doing almost nothing in the test environment other than opening a few pages. I guess it’s somehow related to the combination of Windows 10 Home, Docker and WSL 2 and perhaps the way the files are shared between Windows and Docker in the DevKinsta setup as per the warning “Docker Desktop has detected that you shared a Windows file into a WSL 2 container, which may perform poorly.” that was mentioned previously in this topic already.

Then I switched to Hyper-V and it makes all the difference! The steps for that were/are:

  1. If you are on Windows 10 Home, upgrade to Windows 10 Pro. At least, I believe this is required as Windows 10 Home is not showing the “Hyper-V” and “Container” options in “Turn Windows features on or off”. I did the upgrade to Windows 10 Pro via de Microsoft store and the process is surprisingly simple and quick. It did cost 145 Euro… but for me that was better than wasting more time on a slow environment. The upgrade did initially say it failed, and the license was not activated, however, then I manually rebooted, and Windows then automatically finished the upgrade process anyway and after the reboot I was on Pro with the purchased Pro license active.
  2. After the upgrade I tested if the combination Windows 10 Pro + Docker + WSL 2 was any better but it wasn’t, the issue remained the same.
  3. After the above, it’s better to first export the mysql database(s) of the local development site(s). (I did it later but it’s easier to do it first to avoid having to switch back to WSL 2 later to get it)
  4. Then I enabled the “Hyper-V” and “Container” options in “Turn Windows features on or off”.
  5. Then in Docker in Settings > General, I disabled the “Use the WSL 2 based engine” option. And then clicked Apply & Restart.
  6. After that I started DevKinsta which will then attempt to create and update containers for the Hyper-V environment. I ran into an error during this process but the solution described here resolved that: Windows 10 Pro: DK0005 error (adding the path mentioned there as described)
  7. Once DevKinsta is up and running, import the mysql database(s) in the new environment.

After this my local environment is working very fast and is now a proper environment for development. The funny thing is that in Docker settings it says “WSL 2 provides better performance than the legacy Hyper-V backend.”, which I suppose is normally true but not in this case that is for sure!

All of the above is of course a workaround, it doesn’t solve the issue with WSL 2, but simply avoiding using it at all is good enough for me.:smiley:

3 Likes

I just tried this solution and now instead of waiting a minute or more for a page to load, I’m getting almost normal loading times.

1 Like

Thank you for sharing your info!

I tried another approach, i managed to enable Hypver-V for windows home following this: https://www.itechtics.com/enable-hyper-v-windows-10-home/

hypver-v-windows-home

But the problem is Docker still knows i am on windows home, so the option “Use the WSL 2 based engine” in step 5 is not possible for me.

Anybody has a solution for this?

I believe that apart from “Hyper-V”, Docker als requires the “Containers” option enabled in “Turn Windows features on or off”. Maybe that is the issue?

@GoldyOnline Wow! Thanks so much for digging into this! I’ve sent this over to the devs to review:pray:

1 Like

Just switched to Hyper-V (ie, unchecked using WSL 2 in Docker) and WOW, what a difference!! Load times went from mid 20s to mid 2s :astonished:

Thanks for the details, and note on backing up your databases before switching @GoldyOnline

2 Likes

This works for me too. Finally normal loading times :wink:
Thanks for sharing this!

2 Likes

Amazing! Thank you so much! Speed went up 10-fold!

1 Like

You’re an absolute lifesaver :partying_face:. I have multiple dev sites that thankfully do not rely on the database content. But after an update to WSL2 the databases were lost, and performance dropped significantly. I’ve been trying to remedy since and was afraid to turn of WSL2 base engine. But that did the trick for me, everything else was already as you described.
Load times are about 10 times faster. Now of to rebuild my workspaces…

1 Like

@ GoldyOnline Upgrading to Windows 10 Pro indeed fixed the problem, thank you for figuring this out.

@ melissa Altough the actuel fix should come from DevKinsta, our entire team works on Windows Home. So that would mean to be able to make DevKinsta work you need to upgrade to Windows Pro. That isnt a real solution :wink: Any news on this?

1 Like

Not yet I’m afraid, though upgrading to Windows Pro is not necessary in all cases. We do have several users that have Windows Home that are not experiencing this issue which adds to the confusion for us. It appears an issue with Docker and Windows but we’re working on possible solutions and writing an official guide for users experiencing this issue.

I also notice some dramatic performance issues since switching to DevKinsta. I’m on a MacBook Pro (BigSur 11.5.2 / 32GB RAM / 2.9GHz 6-core)

Here’s what I observe:

  1. The more websites I add, the slower it gets
  2. The performance gets better, when I quit PhpStorm and only have DevKisnta + Browser open
  3. Performance degrades when a download is running (regardless of plugin update or just downloading a random file from a different website)
  4. When using Dockers option “Use new Virtualization Framework” performance goes really bad. Like 90 seconds for each click (hyperkit is faster!).
  5. Performance improved, once I moved most websites from “~/DevKinsta/public” to the new folder “~/DevKinsta/archive” (I left the DB, only moved the files)
  6. Performance is bad right after starting up DevKinsta and improves after 5-10 minutes
  7. Enabling Xdebug makes each request about 0.5 seconds slower

Here are some numbers (I tested each case 5-8 times, here is the mean value):

Websites Files / Size IDE Download Load-Time
1 488.000 / 4GB - - 1.2 sec
1 488.000 / 4GB - yes 2.4 sec
1 488.000 / 4GB running - 1.4 sec
1 488.000 / 4GB running yes 6.0 sec
2 529.000 / 8GB - - 1.6 sec
2 529.000 / 8GB - yes 2.7 sec
2 529.000 / 8GB running - 1.6 sec
2 529.000 / 8GB running yes 6.1 sec
4 1.030.000 / 14GB - - 2.3 sec
4 1.030.000 / 14GB - yes 5.4 sec
4 1.030.000 / 14GB running - 2.2 sec
4 1.030.000 / 14GB running yes 11.6 sec

Notes:

  • Websites: Number of Websites in DevKinsta
  • Files: Total number of files in the ~/DevKinsta/public folder
  • IDE: Is PhpStorm running with a DevKinsta project loaded, or quit?
  • Download: Is a download in progress? (I downloaded the Ubuntu ISO)
  • Load-Time: Average load time of website.local/wp-admin

I’ve also had load-times of 60+ seconds, and it seems to be directly related to file system activity - e.g. when having other apps open, like an FTP and DB client. My previous server was very consistent, regardless of file system activity. It’s possibly related to Dockers integration with the Apple APFS.

My solution/recommendation:

  • Do NOT enable the new virtualization framework on Big Sur!
  • Keep the public folder slim → move the wp-contents folder of inactive sites somewhere outside the public folder, but keep the rest, as DevKinsta will delete the website otherwise
  • Close unused apps to minimize file system access
  • Do not download files in the background
  • Start DevKinsta, get a coffee and start working after all containers and indices were initialized