Windows 10: updating themes/plugins requires FTP creds

A post was split to a new topic: Enabling cron job

Is what i found this morning as I attempted to update plugins.

I’m running MacOs 11.23, DevKinsta 1.1.5 (1559), Desktop Docker 3.3.0 (62916).

This is the first time " Connection Information

To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host."

has shown up.

Please advise…

P.S. I’m a non-programer so please be explicit with any coding request. Thanks.

Hi @kadso . I’m sorry to hear you’re having trouble! I’ve merged your topic into another thread as it’s related to the same bug/issue others are experiencing. There are a few solutions posted above. The easiest being adding the following into your wp-config.php file

define(‘FS_METHOD’,‘direct’);

Try that first and let us know if it works.

I have tried adding this but to no luck. I am having the same issue, it’s not afresh install but a pretty raw install. It’s our starter theme. Copied the site on Kinsta host, downloaded on dev kinsta. Then I got that same FTP request for credentials to do any updates at all. Then when I tried to upload an image it wouldn’t let me do that either.

Gave the following error message:
square.jpg
The uploaded file could not be moved to wp-content/uploads/2021/05.

Additionally when I tried the define('FS… I got a bunch of errors in my log.

2021/05/08 05:32:26 [error] 26#26: *584 FastCGI sent in stderr: “PHP message: PHP Warning: Use of undefined constant ‘FS_METHOD’ - assumed ‘‘FS_METHOD’’ (this will throw an Error in a future version of PHP) in /www/kinsta/public/websiteurl/wp-config.php on line 67PHP message: PHP Warning: Use of undefined constant ‘direct’ - assumed ‘‘direct’’ (this will throw an Error in a future version of PHP) in /www/kinsta/public/websiteurl/wp-config.php on line 67” while reading response header from upstream, client: 1.1.1.1, server: websiteurl.local, request: “POST /wp-admin/admin-ajax.php HTTP/2.0”, upstream: “fastcgi://1.1.0.1:9002”, host: “websiteurl.local”, referrer: “https://websiteurl.local/wp-admin/customize.php?return=%2Fwp-admin%2Fupdate-core.php”

EDIT: All of my websites are doing this. Nothing will let me upload or update plugins. It’s like my whole wp-content folder is just editable.

You can’t even delete plugins.

EDIT: 30m later -

This fixed it. I ran this, it took a bit to execute. Though when it did I was able to update, upload, and good to go. Opened up command console, copy, paste, good to go

1 Like

As a follow up to this I have had to do this multiple times now. A new website installed didn’t want to work either and ran this and I was fine again.

@Andrew_Fair Appreciate the update! Did you have to do this with each new install, or has it be a reoccurring issue on the same site?

Thank you - that did the trick for me too!

I just tested this and yes, looks like every time I have downloaded a new website from Kinsta it doesn’t give me permission to do so. Funny enough, I’m back on this post today because I needed that again to run so I could make updates to an existing client.

Hey Michael,

This does appear to be an ongoing issue. I have to run this everytime I pull a site from Kinsta and my employees are having to do it too. Is there a better resolution in sight?

We simply run

each time but I feel it’s an unneeded step.

Looking forward to continued improvements of DevKinsta!

@Andrew_Fair I’m sorry for the trouble. I understand that’s not convenient at all. I’ll provide an update here as soon as I have more to share.

Sounds good, Thank you Michael, overall I am happy with DevKinsta but certainly excited to see more features/updates :slight_smile:

With the release of DevKinsta 2.0, this issue should now be solved. You can download DevKinsta 2.0+ here. Let us know if you continue to see this issue!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.