Windows 10: updating themes/plugins requires FTP creds

Q: DevKinsta Version
A: 1.0.1

Q: OS Version
A: Windows 10 Pro 20H2

Q: Docker Desktop Version
A: 3.1.0

Q: Detailed Description of the Problem
A: After site creation I saw that some default themes and plugins needs to be updated (new versions available). When I click the Update button I’m greeted with this popup:

I don’t know what should I enter there to be able to update that.
I guess permissions should be tweaked or constant added to the wp-config.php file during the WP installation process.


Does this occur on a brand new site or one that you’ve pulled?

On a brand new site created using DevKinsta interface (I’m not a Kinsta customer - yet? - so can’t pull anything).

Thanks @slaFFik . We’ll continue researching this. We haven’t been able to reproduce the issue yet on Windows but we’ll keep looking.

How aboout MacOs? I am experiencing the same issue as slaFFik on MacOS.
I can’t use devKinsta until this is solved since no new plugins can be added or updated.

Same here.
Brand new (multi)site, SSL enabled on Windows 10 pro.

First interaction after logging in was to install a plugin from the WP Repo and was also greeted with entering credentials (as image above).

To fix you can add this line to wp-config.php, which solved my problem.

/** Sets up ‘direct’ method for wordpress, auto update without ftp */


Great idea @Didou_Schol . Thanks for the tip. We’ll continue looking into this as well in the meantime.

I can confirm this is happening for me on an imported site from MyKinsta. macOS, M1 with Docker preview.

However, it doesn’t happen on fresh installs.

Not to complicate it at all for you. :smile:

Has Kinsta come-up with a solution yet?

I’m using a site that was pulled down from my Kinsta server. I don’t have a clue what the Hostname, FTP Username, or FTP Password are. I’ve never used or needed them before.

As far as I can tell, Kinsta is the only resource for finding a fix.

I pulled the same site down and used Laragon to work on it. I had zero problems updating anything.

Hi @nametags4u . Try adding define(‘FS_METHOD’,‘direct’); inside your wp-config.php file. That should remove the issue until a patch is available for resolve this.

No luck… Back to Laragon until this is fixed.

Hi @nametags4u , sorry for the difficulties here and that the above adjustments didn’t help :pensive: Rest assured this is on our radar and we will update the thread as soon as we have something more to offer!

Hi all :wave: While we haven’t been able to duplicate this at the moment so far we feel this may be permission related, if anyone continues to see that prompt beyond the wp-config.php edit (perhaps @nametags4u ) may we please have you try running the following command?

docker exec devkinsta_fpm chown -R www-data:www-data /www/kinsta/public/

If the issue persists beyond that may we have the output of the following:

On DevKinsta (Docker):
docker exec devkinsta_fpm ls -al /www/kinsta/public/
docker exec devkinsta_fpm ls -al /www/kinsta/public/SITE_NAME/

On Windows (Command Prompt):
icacls C:\Users\USER\DevKinsta\public
icacls C:\Users\USER\DevKinsta\SITE_NAME

Thank you! Hopefully this helps pinpoint what might being on there for anyone still having difficulties!

Thanks Melissa,

I’m getting ready to try your suggestions… In the meantime, it didn’t dawn on me before, but I get Security Warnings every time I launch a site from DevKinsta. I always accept the risk. That may be why I can’t run updates.

This is the specific warning I get. Note that I do not get this warning when using Desktop Server, Laragon, or Local by Flywheel.

Warning: Potential Security Risk Ahead
Firefox detected a potential security threat and did not continue to blanksite-1.local. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.
Learn more…

You’re welcome! I don’t believe that would cause it, as that should only relate to how your browser is validating the SSL with the local domain :thinking: Are you able to share what version of Firefox you’re using? Is the same warning triggered on other browsers? I’ll check with our team about this as well as I haven’t been able to find much on this myself, I’ll keep you updated!

Thanks again, Melissa.

I deleted the local site and downloaded a fresh copy via DevKinsta. There are a couple dynamics in play. We have a new IT provider that locked me down so tight I couldn’t research military or law enforcement. That’s 90% of our business. So they opened up the firewall, I downloaded a fresh copy of the website, and ran the docker exec devkinsta_fpm chown -R www-data:www-data /www/kinsta/public/ code you sent. One or all of those combined seem to have fixed the problem.

Now all Kinsta has to do is make the thing lightning fast. I’m using SSDs, but it’s still slower than working online. This will be a great time saver once it’s optimized.



Hi @melissa

I am new to Devkinsta & Docker, can you please explain where & how to execute this docker command?

I tried it in devkinsta_fpm CLI, but ended up like this. Can you please help me on this?

Note: On Windows side the permission is all ok. I have pasted the response below.

C:\WINDOWS\system32>icacls C:\Users\saravanakumar.s\DevKinsta\public
C:\Users\saravanakumar.s\DevKinsta\public Everyone:(OI)(CI)(F)

Successfully processed 1 files; Failed processing 0 files

Hi @Saravana_Kumar ! Welcome to DevKinsta :slight_smile: . Do you have Docker installed? The docker commands are run inside your shell/Terminal of choice.

Thanks @michael Yes, docker installed in my machine. I have used the Windows Command Prompt, and execute those ownership changes command.

Its working now.