Cannot push to Remote Origin; Environments not showing

I’m trying to push my local to Remote. The list of Sites in my Kinsta account shows, but the environments don’t show up (Live, Staging, etc.). It’s asking to create a new environment, but they already exist. I’ve updated Docker and logged out/logged in to my Kinsta account. I restarted everything, and it’s still not loading. This happens to all the sites in my account, not just the new one I’ve created.

**DevKinsta Version: Version 2.13.1 (2.13.1.8585)
**OS Version: Mac M1 13.5.2
**Docker Desktop Version: 4.28.0

Hello @ghsangoma :wave: and welcome to our Community forum!

Thank you for reaching us out here!

First of all, please allow me to inform you that when pushing the local site to Kinsta , the Live environments won’t be shown there (in the “Select target site” list in DevKinsta) - so only the Staging environment(s) will be shown there - if available, either the Standard and/or Premium one - and you can only push the site from local to Staging environment only, as also mentioned here

I’ve also just checked into your MyKinsta control panel for that Sangoma US site for example - and could see that you’ve already created a Staging environment for that site (just today? so that’s why it was not shown in that target site list in DevKinsta previously)

So now when you check on your DevKinsta again, if you try to push the local site to your Kinsta site, you should now be able to see the Staging environment of that “Sangoma US” site . Then you can just click that Sangoma US * Staging name from the list, then on the next screen/modal window, you can push the local site to that staging site in question.

Another example would be for that APIdaze.io * Staging , if you click on that staging site name from the list :


on the next screen/modal window, you will be able to see the “Confirm changes” modal - before you can click the “Push site” button (to push the local site to that staging site on your hosting server).

Please give it a try and do let us know again if something is still not working properly as expected (and provide more screenshots about the issue in details, etc.) - We will be happy to help and assist you!

Best regards
Agus Utomo