DevKinsta Says I Need To Install Docker But It's Installed

I have a 2021 M1 Pro MacBook Pro, and when trying to run DevKinsta, I am stuck on the “Install Docker” screen. I have made sure to download the correct version of Docker and DevKinsta, but I am getting this message. I have also uninstalled and downloaded both DevKinsta and Docker multiple times. I have tried signing up for a Docker account and signing in, force quitting both apps, reopening them, etc. Any ideas on how to fix this?

Thanks for your help!

Hello there @tmm :wave: and welcome to Kinsta Community!

First of all, I don’t have/use Mac here (only use Linux Ubuntu and Windows O/S on my computers), but I’ve seen that someone suggested the following to Mac users for that such case in question.

Can you please try to run the following command via your Mac’s terminal when both DevKinsta and Docker are entirely closed (not running in the background at all)?

sudo ln -s "$HOME/.docker/run/docker.sock" /var/run/docker.sock

after that you may want to open DevKinsta again as usual, and see if it’s now running properly or if it’s still showing the same prompt (to download and install docker) ?


Just tried it, didn’t work. Any other ideas?

What if you open your Docker Desktop, and go to Settings → Advanced , see if the checkbox is enabled for the “Allow the default Docker socket to be used (requires password)” ?

If it is not, please close DevKinsta completely, then enable that checkbox mentioned above, and close Docker completely and try to open DevKinsta again , see if that helps?


Hey Agus,

Thanks, this fixed the issue!

1 Like

You’re most welcome!
Glad to hear that fixed the issue! :clap: :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.