Devkinsta's Cancell Maintenance Stuck

Hi I am Puspa ,

I am trying to push from local to staging it gives error dk0026 and I try to cancel then it stuck on cancelling But staging site is running with restore snapshot. How to get rid to these problem.

Hi @PuspaRaj_Subedi, welcome to DevKinsta!
Thank you for sending me your main.log file. If you are still unable to cancel the process, here are instructions on how to “reset” the process: Stuck on Canceling maintenance, restore snapshot - #7 by Kevin

There are a few different errors in your main.log that could be causing the DK0026. I recommend contacting our Live Support and asking them to “reset staging” to delete everything that is currently there. After that please try to push again and share the main.log if it fails.

I recommend this because I am seeing this error in your logs: Rsync error code 12 - How we figure it out?

Please let me know if the issue continues.

Hi @Kevin have send that main log for error while uploading it stops with error code dk0026 and stuck at 800 mb

Hi @PuspaRaj_Subedi, yes the DK0026 is happening because of this error: Rsync error code 12 - How we figure it out?

This is what is showing in your main.log:
rsync error: error in rsync protocol data stream (code 12) at token.c(476) [sender=3.2.3]

That is why I recommend deleting everything from your Staging Environment before you try to Push. It might be happening because of the files on you Staging website.

Please log into Kinsta and contact our Chat Support team to help you reset your Staging environment before you try pushing the website again.

Hi Kevin
I got the same error dk0026 when try to push site to new staging site. Do you have any other solution i will send my main.log with recent push error.

Hi kevin i got the same error while i try to push in another staging site which i have make for testing purpose it give same error dk0026 i have send you a main.log file in message.

HI @PuspaRaj_Subedi, I only received one main.log file with this error I mentioned above. You would need to send the new mian.log again to make sure it is the same error/cause.

Have you tried deleting the files from the Staging environment before you try to Push? That is still my recommendation.

Sorry, @PuspaRaj_Subedi I just reread your message. Can you send me the main.log for the brand new staging environment? I need to make sure it is the exact same error message in the logs.

If possible, I would recommend trying DevKinsta from a different computer with these sites to see if it’s the same error. The only other thing I can think of is maybe there is an internet connection issue happening.

Either way, please share the main.log for you test failure with me and I’ll compare the errors.

I have send you a log on reply please help me to solve it

Thanks @PuspaRaj_Subedi, I was ill yesterday but will continue looking into this.

Your most recent log still shows an rsync error but different:
rsync error: timeout in data send/receive (code 30) at io.c(197) [sender=3.2.3]

So to troubleshoot, can you create a new WordPress website in DevKinsta then try to push that to Kinsta?

Another way to push your site to Kinsta would be using a manual migration. You could use the Duplicator plugin, or you could zip the public/sitename directory and then copy that to Kinsta.

I am still trying to narrow this down so the best test would be this:

  1. Create brand new WP site on DevKinsta
  2. Create blank WP site on Kinsta and add a staging environment.
  3. Push the DevKinsta site to Kinsta Staging
  4. If this fails, please share the main.log. It will offer better data.

Hi kevin I have deleted my staging and try it gives me this error
rsync: [sender] write error: Broken pipe (32)
rsync error: unexplained error (code 255) at io.c(823) [sender=3.2.3]
you can find my recent log file here
main.log (6.5 KB)

For your reference,
I have also created new site on both kinsta and devkinsta its working fine.

Thanks for sharing @PuspaRaj_Subedi, I’m looking at the log now. So now it sounds like your ssh connection was broken/idle. That’s what “Broken pipe” means. Please let me ask our developers what the best approach next would be.

Have you already tested Pushing this site to the NEW Blank Kinsta Staging? Just to be sure it tails the same way. Can you also send me a private message with your computer’s IP address? I want to make sure it isn’t being caused by our firewall.

I just tested pushing fresh site in devkinsta and push it to New Blank kinsta staging.
how to send my ip ??

Thanks for sharing your IP.

Can you test Pushing the “old” DevKinsta site to the “fresh” Kinsta staging?

i am trying now but its stopping with broke pipe error in 200 mb

And some time it gives this error

Ah, okay, that error again. I saw that in a different log you gave before. Can you try following the instructions that the error is giving you? Basically this:

I’m not sure where this is on Linux, but on Windows, the DevKinsta storage directory looks like this:

If you go into the “.ssh” directory (it might be hidden for you), you need to open the known_hosts file
That’s where you would need to delete “line 29” of that file.

Since you are on Linux, the known_hosts file might actually just be /root/.ssh/known_hosts

The Kinsta entries will have your site’s external IP address. Most start with “34”

You just need to delete the line that the error is mentioning. We also have an explanation of this here

Should I have to delete all entries with 35 ??

Try only deleting the “line” mentioned in the error to see if it stops happening.
Otherwise, yes you could delete all of the entries, you should just backup the contents of the file just in case.

I will look after that if i stuck on ssh error again but want to know in which line we can find the ip , i didn’t find that and whats the solution for broken pipe does this problem belongs to ssh