DK0029 Error - Unprotected private key file

In your main.log, is it saying the id_rsa permissions are 644? Or is it still saying they are 755?

Just tried importing again, it says 755:

[2022-02-16 10:24:46.352] [error] Error - DK0029: MYSQL_DUMP_COMMON: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ WARNING: UNPROTECTED PRIVATE KEY FILE! @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@Permissions 0755 for '/root/.ssh/id_rsa' are too open.It is required that your private key files are NOT accessible by others.This private key will be ignored.Load key "/root/.ssh/id_rsa": bad permissions

So /root/.ssh maps to C:/Users/user/DevKinsta/.ssh, or is the error referring to a different location?

So I was looking at this based on a site Push; that’s where the id_rsa is in that case. Looking at your original error it’s probably due to the id_rsa on Kinsta since you’re doing a Site Pull. I’m working on this right now/trying to reproduce the error exactly as it’s showing for you.

I’ll see if any permissions on Kinsta need to be changed. Do you mind if I only look into your Staging site? Don’t want to do anything that affects the Live site.

By the way @mattd, version 2.4.1 was just released. I really doubt any of the bugfixes will affect this but it’s worth updating/trying just in case.

Hey @Kevin, unfortunately the new version didn’t fix it, but unsurprising if the issue is server-side.

But sure, you can check out our staging. I’ll DM you with the account.


1 Like

Thanks @mattd;
So I’ve finally been able to reproduce the exact error you are having and I think my original conclusion is correct. For some reason the permissions for .ssh/id_rsa are not being set correctly. Are you logged in as the root/admin user? Looking back at your stat id_rsa, I notice that your Access/ Uid and Gid don’t match what I get as the root/main user on my computer:

Access: (0600/-rw-------) Uid: ( 0/ root) Gid: ( 0/ root)


Access: (0644/-rw-r–r–) Uid: (197609/ Matt) Gid: (197609/ UNKNOWN)

Maybe you need to delete the .ssh directory again and make sure you’re running DevKinsta as the administrator when you log into your Kinsta account? Also if you have another PC that you can use to test, that would help, too.

The mysqldump command uses the SSH credentials on your computer to connect to the Kinsta site. I’ve spent a couple of hours trying to figure out how to manually set the file permissions from within Windows but for whatever reason nothing as simple as “chmod” and “chown” exists for Windows. It is interesting that your permissions aren’t being set the same way as mine on my computers, though.

I think if you install DevKinsta on the main/admin Windows account you can get past this. I’ll keep trying to reproduce this but admin privileges/permissions seems like the best thing to look into.

I did mention this to our devs and they may look into ignoring this permissions notice so that it doesn’t cause import/export to fail.

Hi @Kevin, I tried logging out of DevKinsta, exiting the app, deleted the .ssh directory, opened DevKinsta with admin privileges, and logged back in… and no dice :frowning:

The .ssh directory was re-created, but stat id_rsa is still showing my UID, not root.

I tried importing a site again anyways and still the same error.

FYI, I’m running Docker Desktop with the Hyper-V backend (vs WSL 2) as discussed here if that matters.

Thanks for trying @mattd; I’m still not sure what’s causing this for certain Windows users but the permissions on that file are definitely the issue. I’ve used this week’s troubleshooting to bring this up with the Devs. I’ll be sure to update you if they can think of a workaround or solution.

Thanks again for working with me on this one. It’s a very odd issue.

1 Like

Hey @mattd, I’ve been discussing ways to resolve this in future versions with our devs but I’ve been looking into quick fixes. Using Hyper-V might be causing the difference in permissions when the file is created but I haven’t been able to reproduce your setup yet.

Can you see if running this in the DevKinsta/.ssh directory helps with the folder permissions? If you can stat the file again after that would be helpful:

sudo cat id_rsa > id_rsa2 && chmod 600 id_rsa2 && rm id_rsa && mv id_rsa2 id_rsa

If the user/group still look weird, you might have to chown yourusername:yourusername id_rsa

Hi @Kevin, working from the office today (first time since the issue) and crazy enough, I’m getting the same exact error on my work machine. Totally different computer, network, etc. Similarities are that it’s Windows 10 Pro and Hyper-V backend for Docker Desktop.

I tried running the command(s) you suggested but still no luck. (I think the 2nd command was supposed to be chown not chmod?)

Not sure if I mentioned this before, but both my work and home PCs ran DevKinsta just fine until recently when this error popped up. Honestly not sure if it was after a specific update though…

Thanks @mattd,
Yes, chown, sorry! Yes there have been a lot of updates lately but I’m not sure what would cause this. There’s a small handful of people having the same issue but I don’t think everyone is using a Hyper-V backend setup.

I guess I’ll just try to emulate your setup sometime. By the way, did manually creating a new id_rsa still leave you with 644 permissions on that file?

Hi @Kevin, got it working! Well kinda, haha…

I switched Docker Desktop to WSL2, deleted the .ssh files, let DevKinsta rebuild the containers and logged back in, and I can now download sites again!

Problem is I’m back to having horribly slow load times on the sites, which is the reason I had switched to Hyper-V last summer :confused:

I guess it’s better than not being able to load the sites at all. Hopefully ya’ll can figure out one or both of the issues haha.

1 Like

Ah, thanks for the update @mattd; I’ll definitely do some more DevKinsta developing and try your Hyper-V approach in the future. Will let you know if I ever find a workaround/if our devs make any changes there.

1 Like

Try it again later. If It still doesn’t help, please reach out to us on our support forum.
From source divkinsta

Hi @jackdoe, if you are receiving the same error, can you please private message your main.log file to me? I would also need info on what OS and DevKinsta version you are using.
Thank you!

I’m having the same issue and have tried everything suggested in this thread. I also switched from WSL2 to Hyper-V because of performance issues.

Hi @Adam_Conde, so you run into the exact same issues when using Hyper-V but WSL2 works/is slow, correct?

We’re still not sure what would cause this to stop working but I’ll update in this thread if we find a fix/workaround.

That’s correct. The overall experience using websites in DevKinsta with WSL2 was very slow page loads. So, I switched to Hyper-V and the performance is now so much better. When I initially made the switch, I was able to import a site into DevKinsta, so I can’t say that switching was the cause of the problem I’m having now. But it is interesting because it’s something the original poster also mentioned

Yes @Kevin, I was faced this issue But now I don’t have that file

Hi @mattd and @Adam_Conde, we have released a new version of DevKinsta which resolves this issue. Please let us know if it is still occurring and thank you for all the feedback: DevKinsta Releases (Minor) - #12 by Kevin