There is no secure connection. SSL is enabled in the DevKinsta site settings, HTTPS is also specified in the WordPress site settings. OS - Windows 10, browser - Chrome.
Can you please tell me how to solve the problem?

Hi @nikvkon ! Welcome to DevKinsta! I’m happy to help. While SSL may be enabled on DevKinsta, and HTTPS is defined, it’s still possible there could be mixed HTTP/HTTPS content within the site. Does the browsers console detect mixed content by chance? If so, try a plugin like Better Search Replace to resolve those. If however that’s not the issue and doesn’t resolve it, let us know.

The problem exists when creating a new site in DevKinsta

Search and replace in the database gave no results

@nikvkon Would you be able to provide a screenshot of your Console tab on Chrome? Here’s where to find that

Yes of course. Here it is

What exactly occurs when you navigate to the site when you reach https://? Any errors?

Failed to confirm that this is server tests.local. The computer’s operating system does not trust its security certificate. The server may be configured incorrectly or someone is trying to intercept your data. Chrome notifies about untrusted certificate issuer.
I am getting the following error when going to the test site. Actually the problem appeared some time ago. I used to use Local by Flywheel and everything was fine. Then the same problem appeared. I tried it on different browsers - the error is the same. I think this is a Windows problem, but I can’t find a solution on the internet.

There is no trust in this root CA certificate. To enable trust, install this certificate in the CAs trusted root certificate store.
I liked DevKinsta, as it seemed to me, it works faster than Local, but the problem with HTTPS is present in both

This a perfectly normal error and it’s due to the SSL certificate being a self-signed certificate on the computer. You can proceed safely by clicking on Advanced then Continue. More on that here

Thanks for the answer, but:
there is an HTTPS switch in the Local control panel, but since about the beginning of spring, when you enable it, the connection does not become secure, although everything previously worked and HTTPS was on the local site, until about early spring.
Your DevKinsta dashboard also has an HTTPS switch, but enabling it does not give a secure connection to the local site. Why is this switch needed then?
Your last link was studied by me earlier, but it does not solve the problem. I would like to enable the HTTPS switch in DevKinsta to automatically create a secure connection to the local site. Now this is not happening and I cannot solve this problem.
Have a nice day!

Hi @nikvkon . I understand and apologize for the confusion. The error however is one provided by Chrome (and other browsers) and not one we can control or avoid. The site does indeed load with HTTPS, but due to being a self-signed SSL certificate, Chrome and others may provide an error that the self-signed certificate cannot be validated for the public web. This is normal and expected.

The SSL certificate will not be used publicly when you push to Live on Kinsta. Self-signed certificates are still encrypted to use locally.

Here are additional resources to read up on this:

We haven’t heard back from you on this topic in a while. However, if you do need further assistance you can simply start a new conversation. Thank you again for using DevKinsta. Let us know if you need further assistance! :wave: