Error: Could not connect to debugging client

I cannot get my website to pull to my local machine. I have tried pulling from both local and staging.

Typically when I pull from the staging website, a modal appears asking for my user credentials (a native Apple modal).

Now when I pull, that modal does not appear, and eventually, it will just say ‘something bad happened’.

When I check the xdebug file, it notes:

[381] [Step Debug] ERR: Could not connect to debugging client. Tried: host.docker.internal:9000 (through xdebug.client_host/xdebug.client_port) :-(

Can you kindly assist?

Hi @natasha_nightshift :wave:

I’m sorry to hear that you’re having trouble with our local deployment tool, Devkinsta.

If you haven’t already, please close(quit) both the DevKinsta and Docker apps completely. And click on the “Re-apply configuratoin” if this warning comes up after re-launching the Docker Desktop app.

Then, reopen DevKinsta and try the ‘pull’ action again. If the issue persists, please send me a copy of your DevKinsta raw ‘main.log’ file via private message. To locate it, click the question mark icon at the bottom-left corner of DevKinsta and select the option “Reveal log file in File Manager”. We would like to take a closer look at why the Pull action is throwing such an error.

Hi Adrian,

  1. I quit DevKinsta and Docker
  2. My Docker did not show me that error message.

Hi @natasha_nightshift

Can you also send me a copy of your DevKinsta raw ‘main.log’ file via private message? We like to investigate further the cause of the error thrown by the Pull action.

Sent to you privately!

1 Like

Hi @natasha_nightshift

Thanks for sharing the main.log file. I reviewed the log, and I noticed several of these errors in the log file from different sites. It doesn’t look like the issue is specific to any one site.

It’s possible that something went out of sync between Devkinsta and Docker. To fix this, I recommend that you first close the Devkinsta app and then delete all the Devkinsta containers in your Docker Desktop. Once you’ve done this, relaunch Devkinsta to re-generate those containers. Please note that deleting and recreating the containers should not result in the loss of your local site data, as it is stored in the Docker Volumes.

However, if you don’t have any existing working local site running, it might be easier to just uninstall both Devkinsta and Docker and reinstall the apps to start fresh.

I hope this information is helpful. Let us know how it goes.

Hi Adrian,

I deleted Kinsta, and Docker. I re-installed. Errors continue. The frustrating thing, is that I keep trying, alternating from pulling from staging and live and I just keep getting different errors.

I resent you the log file and screenshots of the various errors.

Error DK0072 is particularly annoying because there are no samename.conf files as shown in the screenshot. DK0029 just tells me to try again later and to report here…

To clarify, the site in question is AND I also tried on another computer entirely and same problem is occurring.

Could this be a weird permission problem on the server? I typically get a modal that reads: "DevKinsta wants to add domain to hosts file", in which I enter my password and the pull completes. This happens on every other site I pull, except for the nightshiftstudio project.

Hi @natasha_nightshift!

Thank you for your reply! After further reviewing the main.log file you shared it does appear for your site there is a permissions related issue occurring during the rsync process. We would be happy to help ensure that all of the file/folder permissions are correct on your site so you may attempt to perform the import again. We would need you to open a support request with our team via a live chat in MyKinsta or by emailing so we can perform this action in a verified support session.

Once our team has helped with ensuring the file/folder permissions are correct you may try importing the site again into DevKinsta to see if that has helped resolve the problem.

We look forward to hearing from you!

Best regards

I am confirming that it is now working. And that was indeed the problem. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.