Errors with push to Kinsta

First time DevKinsta user. I am trying to push my site to a Kinsta staging environment. I first received a “Failed to upload local sites” DK0065 error. I read some posts here about that and deleted some old backup files and tried again. I now receive “Remote server received wrong data” DK0013 error. I’ve attached the log files.

main.log (redacted)
main.old.log (redacted)

Hi @criswaller :wave:

I have reviewed the two log files you shared and noticed a couple of entries that seem to be causing the Push to fail:

[2024-01-15 15:47:55.508] [error] [enableSiteMaintenanceMode] Error from Kinsta API: MissingResource: ‘environment’
[2024-01-15 15:47:55.509] [error] [ipcMainStep] Error in operation SITE_PUSH, step enableMaintenanceMode: Error: ApiResponseError - DK0013: API_RESPONSE_ERROR_BAD_REQUEST

These errors suggest that the destination server (Kinsta Staging) is not being identified properly, which is unusual. I recommend restarting both Docker and Devkinsta and trying again. If you still encounter the same error, please provide the following details so that we can better assist you:

DevKinsta Version:
OS Version:
Docker Desktop Version:

I look forward to hearing from you soon.

Best regards.

I tried again after restarting as suggested and we are back to error DK0065. Log attached.
main.log (redacted)

DevKinsta Version:- 2.12.0
OS Version: Windows 11 Home 22621.3007
Docker Desktop Version: 4.26.1

It appears that some files were transferred successfully but then failed due to an rsync error. The error message displayed is as follows:

[2024-01-15 19:44:28.906] [error] [ipcMainStep] Error in operation SITE_PUSH, step rsync: Error: Encountered an error in child process 9100: 255. 
rsync: [sender] write error: Broken pipe (32)
rsync error: unexplained error (code 255) at io.c(848) [sender=3.2.7]

Unfortunately, the error message doesn’t provide specific information about which folder/file is causing the problem. Rsync errors can occur when there are broken symbolic links.

To resolve the issue, I suggest that you review your local site folders/files and remove any possible broken symbolic links.

We will keep an eye on this thread and wait for your updates.

I am very much a newbie to all of this. How would I review my files to find symbolic links?

Hello Chris,

Since you’re using Windows 11, you can try and review the symlinks in the site’s directory on your local machine using this approach.,directory%20will%20be%20returned.

However, I would like to suggest a different approach as reviewing symlinks can be misleading and even impossible in some cases when it comes to Windows Subsystem for Linux.

What we know from the second log you’ve sent is that rsync is failling due to a file or folder. The current logs don’t reveal more unfortunately.

However, you can do a selective push from Devkinsta to staging site and see which folder is causing it. Pushing one file/directory at a time is too time consuming, but you can do a process of elimination by pushing one half of the files/folders and if it doesn’t fail, then the other. Then you would eliminate further until you find the culprit.

While we are planning to get more detailed logs in the future, this is not available at the moment unfortunately and the process of elimination described above is the best way forward.

When choosing to sync, click on this arrow to select which files you are pushing. It might require a number of syncs to narrow it down.

I tried pushing half the files- that failed. I then tried 5- that failed as well. I then tried individual files just to see if any would succeed. Every single file I’ve tried fails with the DK0065 error. Log attached.
main (1).log (551.6 KB)

Please ensure that there are no security apps or programs running on your computer that could be causing any conflicts with the rsync process.

In addition, you can try creating a fresh WordPress site from Devkinsta and then push it to your staging environment for further testing. This will help us identify whether the issue is with your site code or with the Devkinsta application.

If you are still encountering issues with pushing a new site build to Kinsta, I recommend that you create a backup of your current build site in Devkinsta. You can do this by creating a zip file of both the site files and the database (.sql). Then, uninstall and reinstall both Devkinsta and Docker Desktop.

Once you have reinstalled both Devkinsta and Docker Desktop, you can import your site back to Devkinsta using the ‘Add Site > Custom Site > Import backup’ option.

Alternatively, you can request a free basic migration through your Kinsta account for us to migrate your local site backup (zip) to your Kinsta staging. Migrations - Kinsta Migration - Kinsta® Docs

I think requesting migration is the way to go!

If I already have the site working in DevKinsta, I am assuming I can use those files for the migration?

I consulted the documentation you provided but I don’t see a migration option on my MyKinsta dashboard, where do I find this?

Thanks for all the prompt help!

Yes, you can manually create an archive/zip of your WordPress folder and files from Devkinsta. I found this Microsoft article that might help with creating a zip file.

In addition to that, you’ll also need to export the site’s database. You can do this by going to “Your site” > “Database Manager” > “Export” section in Devkinsta.

Once you have both the zip file and exported database file (.sql) for your WordPress site from Devkinsta, you can proceed with submitting a free migration request through your Kinsta account. However, I suggest contacting our Support team through chat for the best assistance with migration.

I hope this clarifies things for you!