HTTP ERROR 500 & missing .php files

hi, I just tried to pull our staging site [] down to my local machine and after it completed the build when i try and launch the site i get an “HTTP ERROR 500” message. Also, when i look in the wp-includes folder it looks like the .php files were not transferred over successfully. any idea how i can rectify this? thanks!

hi @michael - just wondering if anyone’s had a chance to look into this issue for us. thank you so much in advance!

Hi @aaronblomberg . I’m sorry for the wait here. I don’t have an update yet to provide I’m afraid. Developers here are still looking into this from this topic here. Could you confirm that your DevKinsta is on the latest version 2.2.0?

hi @michael - correct, i’m running the latest version of 2.2.0 [see attached]. Let me know if there’s anything else i can provide, thanks!

Screen Shot 2021-11-09 at 7.43.16 AM

Hi @aaronblomberg . We just released 2.3.0. Could you let us know if this continues on that as well?

hi @michael - i updated to 2.3.0 and attempted another pull from kinsta and the same issue is happening. the wp-includes folders is still not copying over any of the files - see attached. could it be a permissions issue? any idea on what we could try? hopefully can get this resolved soon or might need to look into an entirely different solution since this is pretty time-sensitive. Thanks in advance!

this is what i see when i try to launch the local build:

Thank you for that @aaronblomberg . We’re still looking into this here.

hi @michael - so i was able to pull the site down to my local machine by deactivating all the plugins from staging, then pulling the site down, and then re-activating the plugins. There is an insane amount of plugins being used on the site right now and i am hoping to eliminate the need for most of them so hopefully this will no longer be an issue. Here is a list of all the plugins that are currently being used [again, i will be removing as many as possibe] but do you see any plugins on this list that may have directly caused the issue? Thanks!

  1. ACF Content Analysis for Yoast SEO
  2. Advanced Custom Fields PRO
  3. Advanced Editor Tools (previously TinyMCE Advanced)
  4. Ajax Upload for Gravity Forms
  5. Akismet Anti-Spam
  6. ARVE Advanced Responsive Video Embedder
  7. ARVE Pro Addon
  8. Better Search Replace
  9. Broken Link Checker
  10. Classic Editor
  11. Custom Post Type UI
  12. Disable auto-update Email Notifications
  13. Disable Comments
  14. Duplicator
  15. Duplicator Pro
  16. Email Address Encoder
  17. Enable Media Replace
  18. Facebook for WordPress
  19. FacetWP
  20. Gravity Forms
  21. Hide YouTube Related Videos
  22. HyperArts Announcement Images for PacBio
  23. Imagify
  24. Imagify | No Auto-Optimization for PDFs
  25. Magic Liquidizer Responsive Table
  26. Master Slider Pro
  27. PacBio Genomic Project Builder
  28. Pardot
  29. Post Expirator
  30. Public Post Preview
  31. Really Simple SSL
  32. Redirection
  33. Revisionize
  34. SearchWP
  35. SearchWP Boolean Query
  36. Share Buttons by AddThis
  37. Shared Counts
  38. SVG Support
  39. WordPress Backup & Security Plugin - BlogVault
  40. WordPress Importer
  41. WP 2FA - Two-factor authentication for WordPress
  42. WP All Export Pro
  43. WP All Import - ACF Add-On
  44. WP All Import Pro
  45. WP File Manager - PRO
  46. WP Migrate DB Pro
  47. WP Migrate DB Pro Media Files
  48. WP Rocket
  49. Yoast SEO

@aaronblomberg That’s very strange. The transfers are done via sFTP so not sure how a plugin would have anything to do with it. The only thing that comes to mind is that the site is rather large. We’ve had reports in the past that large sites failed to import, but it wasn’t specific to PHP files and has seen been resolved with the last couple updates. We’ll run some more tests on this with large sites but if you learn anything else with the plugins, please do let us know! I really appreciate you sharing this information!

thanks @michael - i’ll let you know if i find or figure out more as to what the issue may be as i’m working on the new build and will keep you posted. thanks!

Just want to add that this exact problem just occurred for me. The files in wp-includes were missing.

I am on Windows version 2.3.0.

Welcome to DevKinsta @Kato and thanks for letting us know! Would you mind privately messaging me here on the forums and letting me know your site address so I can take a look at what’s being imported?

I’m having the same issue. Things were working for me a few months ago. Then I attempted to redownload the site and I get the 500 errors, there is not wp-includes folder. Just installed 2.3 and the latest Docker. Running MacOS 11.6, 32 GB Ram.

After using SFTP to download the wp-includes files I now get this error

here’s what keeps getting put in the access log
[16/Nov/2021:03:00:01 +0000] “GET /wp-signup.php?new=mindfulstagingp.local HTTP/2.0” 302 0 “-” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36” “-”

Welcome to DevKinsta @mbonanno ! I’m sorry to hear you’re having the same issue here.

This appears to be a separate issue related to having a WordPress Multisite. You’ll need to ensure that the wp-config.php file has the proper configuration for a Multisite, and any additional domains are included in the host file.