I can't access Dev site > it redirects me to live site

I recently updated to 2.3.0 on Windows, and at first, everything worked as always with my current dev site.

But since I deleted the site to make a pull from staging (creating a new site, since there is no pull feature yet), when I try to access the site it redirects me to the staging site.

So when I try to access to mysite.local, it redirects me to staging-mysitecom.kinsta.cloud.

My etc/host file is correct. I’ve tried to change the site and home URL in MySQL (wp_options) and it’s not working (although all the links there are pointing to staging, so the replacement seems to not be working).

I’ve deleted everything, including the site and Docker, and installed everything again, creating the site, and still the same issue.

Docker version is 4.2.0

Any ideas?

Hi @dgrueda! Would you happen to have the URL entered into the wp-config.php? There is likely a setting somewhere within WordPress or a file that is causing it to redirect to another URL. Renaming the plugins directory will eliminate any possibility that it’s coming from a plugin.

Hi Michael,

Somehow renaming the plugins directory and renaming it back, worked. Not sure why but maybe something cache-related.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.