Linux (non-.deb) download availability

Hello. The news that DevKinsta is finally available for Linux is great news! I’m an openSUSE user. Are there downloads available for non Debian based Linux distributions? I’ve searched the website but was unable to find anything but .deb downloads. I know the officially supported Linux distribution is Ubuntu 20.04 LTS but I would love to run in this on openSUSE. Thanks!

1 Like

Welcome to DevKinsta @chadmccullough ! I’m afraid at the moment we’re only officially supporting Ubuntu thus do not have download options available for other distros. I’ve gone ahead and moved this thread over to our Feature Requests area as well so our devs see this :slight_smile: . Let me know if you need anything else. :+1:

1 Like

Thank you so much!! I’ve been waiting for this for quite a while so I will install Ubuntu 20.04 and run it there.

Thanks again!

Since openSUSE is my main Linux distribution that I run on all of my hardware, I’ve decided to wait until there is a release that will work on this distribution. Thanks and I’ll keep an eye on this post to see if there are any updates.

Hi @chadmccullough,

Try this link for a .rpm file. We’re working to get this up on our downloads page soon.

1 Like

Thank you!!! Downloading right now. :grinning:

Downloaded, but during install it’s telling me that it needs a library (libXtst) that is already installed on my machine. Finished the install, anyway, since I know the library is installed and it “appears” to have worked. I’ll get Docker installed and running to see if it’s actually working. Thanks again!!

1 Like

Just a quick follow-up, post-install. It appeared to install okay even though it complained of a missing library. Installed Docker and have it set to start at boot. Attempted to create site but it wouldn’t complete the build. Said it failed at installing WordPress, or, at least, that seemed to be the part of building a site it was on.

Do you have any logs that might help us pinpoint where exactly its failing?

Yes. Would it be the error log that you are looking for?

Hi @chadmccullough . You can find it over at /Users/user/DevKinsta. More on that here. You may attach it here, or direct message it to me on this platform. Thanks again!

Edit: Apologies for I just remembered you’re on Linux thus the path may be different than what’s provided above. Would you be able to also provide a screenshot on the spot that it has stopped?

1 Like

Sadly, the error logs for both sites that I attempted to create are empty. I’ve attached a screenshot of what I’m seeing.


Hi @chadmccullough . Our logs indicate the following error occurring on your DevKinsta:

EACCES: permission denied, rmdir '/home/chad/DevKinsta/public/chadmccullough1'

Looks like there may be a permission issue preventing DevKinsta from creating the necessary files and directories. Try running DevKinsta under sudo and let us know if that helps.

1 Like

Thanks! That definitely looks like a permissions issue. I’ll follow up after I run it as sudo.


1 Like

I tried running it with sudo on both of my openSUSE machines, but with no luck. Decided to reinstall and rebuild Docker and reinstall DevKinsta but that didn’t help, either. Even tried changing permissions a few times.

Thanks for all of your help trying to resolve this issue but I don’t want to waste any more of your time. I’m going to have to look for another solution, which, for Linux, there really aren’t any.


I’m on Fedora 33 and tried to install the .rpm supplied in the thread here, it seems to have installed without any quirks. Docker was installed previously on my system and is started on boot.

It seems that DevKinsta hangs at “Starting Docker” for whatever reason upon startup. I can’t get past it anyway…

1 Like

I definitely don’t want to give up on it because I really do need a WordPress development environment. I really wish I could figure out why it’s not liking any Linux distribution but Ubuntu.

Is there any progress on this?

I would really love an RPM package that works. To be honest I think it’s completely dishonest to advertise a “Linux” version and then on release it actually only works on Ubuntu. You should call it “Ubuntu support” and not “Linux support”.

So, I was finally able to get it working on openSUSE Linux and Fedora Linux. But I’ll be honest, I tried so many different things to get it working over the past month that I’m not exactly sure what I did to get it working. I do know that with an .rpm based distribution, you will need to install and configure Docker manually. Definitely not a difficult thing to do on Fedora or openSUSE. The documentation from both distributions is extremely easy to follow.

I used the following documentation to get Docker installed on both openSUSE and Fedora:

Not yet I’m afraid. Thank you for the feedback!

@chadmccullough Thank you for sharing what you’ve learned!

1 Like