MySQL Dump Error DK0029

imported a site
made changes
pushed to staging
pushed live

Then added my first additional site(It’s a multisite)

Deleted local

Tried to import again and get the DK0029 error

Tried to import a different site, works fine.

Deleted additional site i’d added


I’m stuck here… I need to be able to edit multisite, but cant even get the site as it existed.
I’d expected to be able to add sites to the multisite locally, then push… but when I clicked network admin it goes to the live site… so my only idea was delete local and re-import… but that doesn’t work

Hi @todrick . I’m sorry for the issues here. When it worked prior to adding your first additional site, am I understanding this correctly that only the main site existed and it wasn’t until you added a subsite that it started to cause issues?

yes, @michael, that’s correct.

I had set it up as a multisite… and when I pulled it down on devkinsta i set it as a subdirectory multisite… even though it was only the primary site at that point.

then after adding the first multisite, it won’t download.

Also of note, the new multisite, does not display correctly… the site, on the kinsta live host, displays as if it has no CSS file. though the original master site works fine

OK, I nuked the entire site off Kinsta and started over…

Seems to work again… But I’m right at the stage where i want to add that new site to the multisite.

Is there no “pull” to update the local site with whatever exists on the live server?

AND… it broke the download again… back to where I started.


Thanks for the info. Our developers will take a look at this further.

At this time DevKinsta will only pull the staging site.

I’m having the same issue as Todrick outlined:

imported a site
made changes
pushed to staging
pushed to live
deleted existing local copy
attempted to import from live (DK0029 error: Can’t create mysql dump)

In my case though, the site is not a multisite.

imported the site from staging without error

1 Like

Hi @robert . Sorry for the trouble! We’ll have more on this shortly.

I am also experiencing the same issue of DK0029.
Only on one of the two sites that I have pulled. One of them had no issue from the jump and still seems to be working fine but even after 24 hours of trying to pull it will not allow me to pull the staging site.

I got the same issue. I have contacted Mykinsta support. This is what they said “On our end however the mysqldump issue seems to be resolve but there are still some issue that could not troubleshoot as only the DevKinsta team have access to it.”

Hi @ahonshaw . Welcome to DevKinsta. I’m sorry for the issues here. That’s correct that the two mysqldump issues are separate. We’ll work on resolving this on DevKinsta.

Hi guys!
I was trying to clone/copy a site using DevKinsta and I got a DK0029 error: Can’t create mysql dump.
The thing is that the database it’s large (~ 2.5 gb). Is there any way I can solve this? I’ve tried to execute like 4 times, but I got DK0029.


Hi @anon90552464 . Thanks for reaching out and welcome to DevKinsta :slight_smile:
Sorry for the issues you’re experiencing there. Does this occur on all sites pulled from Kinsta? Do you happen to have more than one site you’d be able to test with?

Thanks for your reply @michael. I only tested with this site. I will test with another one and will let you know. The issue is that this was the one I needed and I think it is because of the database size.

I am having the same issue. One site pulled totally fine. The other does not want to pull at all and continues to get stuck on the mysql dump as well


I did manage to figure out the issue for my particular case.

if you do not have wp_ as the only prefix it will not allow you to download the database.
There seemed to have been wp_ and an additional prefix duplicate in my DB and removing the duplicates resolved the issue.

Great find @aidenberzins ! Thanks for reporting back your findings. We’ll research this more closely and provide an update here.

hi @michael ,

I’m also having a similar issue while importing the site on DevKinsta.

Thing is we have custom views created on our database (they also have “wp_” prefix).

But it looks like DevKinsta is unable to import database having views other than standard WP tables.

I’m able to import the site if I manually drop views first.

Can you please have a look into it?


Welcome to DevKinsta @aphantasianetwork ! Thank you for the additional information. I’ll pass this on to the devs here.

Hi, I got also same issue and can’t create mysql dump, mysql size is around 600Mb