MySQL Dump Error DK0029

The latest version on Mac M1 mini.

Hi @zkoo . Welcome to DevKinsta! I’m sorry to hear you’re having trouble. There’s a known bug we’re currently investigating on this issue thus have merged your issue over to the bug report. We’ll update this thread when we have more to share on this issue.

What worked for me was connecting to the local database and changing priviledges

This just gets the install to finish I still have to export the database using phpMyAdmina and importing locally

1 Like

I’m a Kinsta customer trying to create a new site in DevKinsta by downloading my site. During the setup process I can’t get past the downloading site step as it continually errors out with the following:

I’ve clicked the retry button multiple times without any success. I’ve also tried deleting the site and starting again as well as closing DevKinsta completely and starting again. I’ve also tried this on both a live site and a staging site with the same issues. Given the limited error information I’m not sure what else to try and of course the regular Kinsta support chat is unable to help.

Thank you,

Hi @kent . Thanks for joining us here at DevKinsta! I’m happy to help :wave: . Others have reported the same issue here as well. We’re still researching all the possible issues on this. Could you verify whether you have any antivirtus software installed and if so if you could try testing it with it disabled?

Hi all, I’m trying to get my website to work on DevKinsta — but keep getting the DK0029 error (“Can’t create mysql dump”). I’ve looked into other threads on this error and tried the workaround I saw (docker exec -it devkinsta_fpm /bin/rm /root/.ssh/known_hosts) — but to no avail (/bin/rm: cannot remove '/root/.ssh/known_hosts': No such file or directory).

Is there any news on this bug? Any chance it’ll be resolved any time soon?


Hey @shlema . Welcome to DevKinsta! Sorry for the issues there. I merged your thread with others here that have had issues with this. I’m not sure if you’ve seen this thread already but others posted similar issues and solutions. The first thing to check is if you have any other software possibility blocking it from importing.

I have a website that is on Kinsta. When I go to pull it there is a DK0029 error. I can manually download it but obviously, this is not ideal as that’s the point of DevKinsta. How might I go about troubleshooting this?

EDIT: I did find another thing on here that stated to run:
docker exec -it devkinsta_fpm /bin/rm /root/.ssh/known_hosts

I tried this just in case with no luck.

Hi @Andrew_Fair . I’ve merged your post over with others that are having similar issues with DK0029 . I’m sorry for the trouble there!

1 Like

Hi, just wanted to add that I am also experiencing this issue - we signed up yesterday, created a test site and am trying to download it using DevKinsta. “Can’t create mysqldump DK0029”. Have pressed “retry” a few times but not getting any further. I have 10+ sites that I need to work on regularly so don’t want to go down the manual import process. Would appreciate any advice. Many thanks.

As an update here, I have not found this issue happening again. Even the website that had this issue initially no longer is a problem. I’m assuming this has been fixed but not sure if anyone else having the problem anymore. I think it stopped like 3-4 days after I posted this.

Thanks for the update @Andrew_Fair !
@paulg Are you still seeing the issue with the latest version? DevKinsta 2.1.0 has been released.

Hi @michael - thanks for letting me know, I have just installed v2.1.0 and can successfully import sites into my local environment using devkinsta. Thanks very much for your help!

1 Like

Same issue here. DevKinsta Version 2.1.0 (

Site created on Kinsta yesterday.

DK0029 Can’t create MySQL dump.

No antivirus software or anything else running that might block this.

Any ideas?

Hello @curiousways and welcome to DevKinsta. I’m very sorry for the trouble here. It appears there’s a connectivity issue on your machine which is resulting in a failed attempt to pull the site. Anything else running on the machine that may be preventing connectivity to Kinsta to pull the sites?

Thanks, no I don’t have anything running beyond a standard Mac configuration. How might I test for apps / configuration that might be causing a connectivity issue?

@curiousways :disappointed: I suspect the issue you’re seeing is the same issue reported here. I’m working with the developers as we speak and will provide further updates here soon.

Hi - is there any update on this?

Hi @curiousways Not yet :disappointed: . I’m sorry for the wait here.

Add me to the list. I’m using 2.1.0, and getting this same error. I tried the terminal trick, but also got the “No such file or directory” error. Also confirmed I’m not running antivirus software.