MySQL Dump Error DK0029

I have a website that is on Kinsta. When I go to pull it there is a DK0029 error. I can manually download it but obviously, this is not ideal as that’s the point of DevKinsta. How might I go about troubleshooting this?

EDIT: I did find another thing on here that stated to run:
docker exec -it devkinsta_fpm /bin/rm /root/.ssh/known_hosts

I tried this just in case with no luck.

Hi @Andrew_Fair . I’ve merged your post over with others that are having similar issues with DK0029 . I’m sorry for the trouble there!

1 Like

Hi, just wanted to add that I am also experiencing this issue - we signed up yesterday, created a test site and am trying to download it using DevKinsta. “Can’t create mysqldump DK0029”. Have pressed “retry” a few times but not getting any further. I have 10+ sites that I need to work on regularly so don’t want to go down the manual import process. Would appreciate any advice. Many thanks.

As an update here, I have not found this issue happening again. Even the website that had this issue initially no longer is a problem. I’m assuming this has been fixed but not sure if anyone else having the problem anymore. I think it stopped like 3-4 days after I posted this.

Thanks for the update @Andrew_Fair !
@paulg Are you still seeing the issue with the latest version? DevKinsta 2.1.0 has been released.

Hi @michael - thanks for letting me know, I have just installed v2.1.0 and can successfully import sites into my local environment using devkinsta. Thanks very much for your help!

1 Like

Same issue here. DevKinsta Version 2.1.0 (

Site created on Kinsta yesterday.

DK0029 Can’t create MySQL dump.

No antivirus software or anything else running that might block this.

Any ideas?

Hello @curiousways and welcome to DevKinsta. I’m very sorry for the trouble here. It appears there’s a connectivity issue on your machine which is resulting in a failed attempt to pull the site. Anything else running on the machine that may be preventing connectivity to Kinsta to pull the sites?

Thanks, no I don’t have anything running beyond a standard Mac configuration. How might I test for apps / configuration that might be causing a connectivity issue?

@curiousways :disappointed: I suspect the issue you’re seeing is the same issue reported here. I’m working with the developers as we speak and will provide further updates here soon.

Hi - is there any update on this?

Hi @curiousways Not yet :disappointed: . I’m sorry for the wait here.

Add me to the list. I’m using 2.1.0, and getting this same error. I tried the terminal trick, but also got the “No such file or directory” error. Also confirmed I’m not running antivirus software.

In case it’s helpful, here’s the full error in the log (I XXX’ed out the IP address):

[2021-09-15 15:13:44.744] [info] [containerExec] Stream row: Dssh: connect to host 35.XXX.XX.XXX port 46205: Connection refused
[2021-09-15 15:13:44.773] [error] Error - DK0029: MYSQL_DUMP_COMMON: Dssh: connect to host 35.XXX.XX.XXX port 46205: Connection refused

Mac OS 10.14.6
Docker 3.5.2
DevKinsta 2.10

Welcome to DevKinsta @lsterling03 . I’m sorry for the trouble here. We’re working on a solution and will provide an update soon. The issue you’re experiencing is occurring on select sites on US East.

One of our devs on Windows is having the same issues. We’re not having them on Mac but he’s having this problem on Windows. Seems to be a long-term problem and not just a minor bug at this point since it’s about a year old and still having the same issues? Has anyone solved this yet?

Hi @muletowndigital and welcome! I’m really sorry for the trouble there. We’re aware of the issue that’s resulting in DK0029 error during imports. We’re working on solving that as quickly as possible here and have escalated it to the developers here.

Hi @muletowndigital . I’m sorry for the wait here. Could you try re-importing the site? You’ll need to delete the site on DevKinsta that you’re attempting to import first, then try a new import process.

We are 10 months further and this is still not resolved for me, i updated to all the latest versions. Deleted all the old websites and tried re-importing them. Keep getting that error. Devkinsta for windows has not been stable since its release. First it was mega slow, there are maney toppics on that matter. I thought to try it again after a year. Now i keep getting this error. I think you should place a side note in the documentation that devkinsta is not properly working for windows.

Hi @AlbertVR, I myself use DevKinsta on Windows 10/11 Pro and I believe the issue in this thread should have been resolved a while ago. Please feel free to create a new Bug Report if you would like us to review what could be going wrong. You could also just need to try using Hyper-V with Docker instead of WSL to see if that helps your issue.