New website is not pushed to stage

I have recently installed Devkinsta and build a new WP website from scratch. I have now signed up for Kinsta and want to push it to staging.

I have created the staging environment and I push to staging envonrinment, but once the push is 100% complete and i go to the URL, it just shows me the WP installation page.

I have also tried to install WP on the page and then pushed it afterwards. It seemed like some plugins were pushed, but content and files were not.

I contacted support, but they could not help on this.

Hello @Heisel :wave:

It’s difficult to say from the information provided what the cause could be there, apologies. May I have you share your main.log file with us so we can take a closer look? You can attach it to your response here.

You should be able to find it using the following path depending on your Operating System:

Looking forward to hearing back from you!

Hi, thanks.
I can see it includes information such as IP address and passwords. Is there a way to upload it privately so it is not open to the public?

Hi @Heisel . You can privately message me here on the DevKinsta forums with the main.log file. Could you also tell me how large the site is and what version of DevKinsta you’re using?

I have shared it now with you.
I am using the latest version (2.1.0).
The website is 3.8 GB

Thank you for sharing the log file.

I took a look at the site that’s on Kinsta. It appears the files are uploaded, but not the database :thinking: . Could you try updating DevKinsta to 2.2.0 and let me know if that helps? It can be downloaded here.

I have tried now and it did not work either.

@Heisel I’m sorry for the trouble here. It looks like it’s the same issue where the files appear to be uploading correctly, but the database is not. I’ll continue to review this with the developers here to see if we can find anything else.

In the meantime, you can manually upload the database via the following method:

  1. Use the Database Manager to export the database: Database Manager - DevKinsta - Kinsta®
  2. Then use phpMyAdmin on MyKinsta to import it: WordPress phpMyAdmin - Login Info and How to Access It
1 Like

I have tried that now, but still does not seem to work either. It shows the data but not no frontend.

Hi @Heisel. Could you reach out to us via chat support? I may be wrong, but I think the prefix for the database table differs than what’s used in wp-config. Be sure to link to this thread to the support engineer to provide context. Thanks!

1 Like

Thanks, I have reached out and they should have left you a message :slight_smile:

Got it! Thanks @Heisel . We’ll take a look at this further and will let you know.

Hi @Heisel Apologies for the wait here! Could you let us know if this is still occurring with the latest version of DevKinsta 2.3.0?

1 Like

Sorry my late response. Have been dealing with the issue through support.
It does not work with 2.3.0 either and i still suffer with the problem.

It pushes the files, but not the DB.

Just did a test with Chad from your support and did a complete fresh installation. This worked fine to push, so i need to find what is blocking it on my website. I have a relatively large database as I have over 32,000 articles to push. Would there be any logs or ways to see what is blocking the push?

Somehow got it to work. Here’s what i did:
I tried to pull WP from staging as a new local WP in DevKinsta, then cleaned parts of Wp-options in MySQL and then pushed it again. This time it was way faster and it looks like has been succesful

1 Like