Push Site Only Pushes Site to Staging Partially

I just tried to push a site to a staging environment on MyKinsta.
Can’t seem to get a 1-on-1 exact copy to the staging though… lots of sections on pages are missing as well as the “live” (staging) site being much smaller.

Does anybody know what’s causing this and how I can fix it?

Thanks so much in advance.

Kind regards,

Hi @coenm, welcome!

Have you tried pushing the site again to see if there was just an issue with the initial attempt?

If its still not fully transferring, could you DM me your sitename in MyKinsta, and the main.log (and main.log.old) so we can look for any failures that may be showing?
You can find a link to open the directory containing these logs in the Support page within DevKinsta.

I haven’t seen this happen before so I don’t have much advice without having a look, unfortunately.
The only thing that comes to mind is an unstable connection when the files are being rsync’ed up to MyKinsta causing it to fail.
The main.log should have some indication of this.


Hi @David_Greene,

I sent you a DM 2 days ago. Could you let me know if you received that?
Thanks so much.

Kind regards,

Hi @coenm, I’m taking this over from David and have checked your log files. When I check your current Staging site, the file size/database are just a bit smaller than what you have on your local site (based on your screenshot), but I don’t think that’s the issue.

By concentrating on the visual issues you are reporting, I found that the CSS files that are generated by your theme are still referencing the .local domain.

Can you search your theme name + “clear css cache” and follow the instructions there? That might actually fix all of your issues.