No response in procesbars DevKinsta

It is a bit faster this time. But I’m getting this error.

Resulting in not downloading it anymore

Please leave it as it is and send via DM the latest main.log file


This is it, but I already started the “opnieuw proberen” button. Because I read the message too late.

We just experiencing the same problem:

I can share my log again via PM

Please delete the main.log file, then click the retry button and send the new copy of the log that gets created once the process fails again

We’ve shared the new fresh main.log file. Same error occurs.

Thank you for the log @NP_vision we’ll review it and give you an update here.


Do you have any updates?

Not yet I am afraid, our devs are still looking into the possible causes.


We are still waiting. Can you give us an update?

Hello @NP_vision ,
our developers are still looking into the issue. Unfortunately without being able to reproduce the issue on this side, troubleshooting this kind of error is not easy.

If you want to try a workaround in the meantime, you can access your site in MyKinsta, move to the Backups page, and request a downloadable backup. Once the backup is ready you can download a copy of your site as .zip folder and import it manually in DevKinsta.
You can follow this guide on how to import the .zip backup


Hello NP,

We’ve got an update from 1 of our developers, and he suggested to run the following command line (on your Mac terminal) as a workaround to perform the site’s files transfer (via rsyc ) from your hosting account on Kinsta server to your local site’s folder on your computer/Mac :

docker run --rm -i \
  -v "/home/USERNAME/DevKinsta/public/THESITENAME":/target \
  -v "devkinsta_ssh":/tmp/.ssh \
  kinsta/devkinsta_rsync-ssh:1.3.0 \
  rsync --delete --timeout=60 -rz -L -e "ssh -p SSHPORT -o 'StrictHostKeyChecking no'" --info=progress2 --no-i-r SSHUSERNAME@REMOTEHOSTIP:/www/SITEUSERNAME/public/. /target/


  • Replace the USERNAME with your actual user name used on your local computer/Mac

  • Replace the THESITENAME with your actual site name used on your local computer/Mac

  • Replace the SSHPORT, SSHUSERNAME and REMOTEHOSTIP with the actual SSH/SFTP port, username and the host IP shown in your MyKinsta for this specific site ( You can find this information under the SFTP/SSH section of each site’s Info tab within MyKinsta.)

  • Replace SITEUSERNAME with the actual path of your site hosted on Kinsta server (that can be found under the “Environment details” path section in that site’s info tab within MyKinsta )

so that might look similar like this for example:

 docker run --rm -i \
  -v "/home/myuser/DevKinsta/public/amberscript":/target \
  -v "devkinsta_ssh":/tmp/.ssh \
  kinsta/devkinsta_rsync-ssh:1.3.0 \
  rsync --delete --timeout=60 -rz -L -e "ssh -p 20777 -o 'StrictHostKeyChecking no'" --info=progress2 --no-i-r amberusername@ /target/

Also, if necessary, you may need to setup your valid SSH Key to your MyKinsta -> User Settings -> My Account -> SSH keys > Add SSH key as shown here (and here ).

It will then start to connect to the remote host (Kinsta server) and will start processing the rsync process to get/download the files from the remote server to your local computer (this may take some time, and files will be stored in that /home/myuser/DevKinsta/public/amberscript site folder with the example above).

Once completed, you may want to check the files/folders ownership under that site’s folder in question (might be set to root:root ). If that’s the case, you may want to perform this command line on your terminal to set it with your proper user/group ownership, something like this:

sudo chown -R myuser:myuser /home/myuser/DevKinsta/public/amberscript

Please give it a try and see if this manual rsync command will work and help to download your site’s files/folders to your local site’s folder on your computer.


Hey @Agus , we have just tested the code you’ve sent.

This is the result in my terminal:

The first docker run command is not complete I guess?
If we try the second nothing happend.

Scherm­afbeelding 2023-01-30 om 14.56.32

Please let us know what we can do!

Heya NP :slight_smile:

I’m sorry for the confusion, but that command should be executed at once (that’s actually a one-line command but was written with multi-line format, that has the " \ " at the end of the first 4 lines, for better readability) - so you would just need to copy and paste those whole (5) lines to your terminal and execute at once, instead of copy-paste and execute each of them 1 by 1.

Please be sure to change/edit the correct path/USERNAME and some other Variables as well (that should match with your actual local site path/folder, and with the SSH connection details, port, username, path) as I noted before.

Please give it a try and see the results. I’ve tested that command line on my local computer (with my own test account) and it worked just fine.


Hi Agus, it’s not working can you please let me know what to do?

I’ve send you a private message with sensitive information.

Heya NP,

I got your PM/DM and have just replied you there with the proper command line. Please check it and give it a try :slight_smile:

About that error showed in your screenshot, I didn’t get that on my local computer when I tried the similar command line with my test account.
So that seems something need to be configured on your Docker settings/preferences under the File sharing maybe? (it does not seem to be DevKinsta related issue though)

docker: Error response from daemon: Mounts denied: The path /home/niels/DevKinsta/public/amberscript is not shared from the host and is not known to Docker.
You can configure shared paths from Docker → Preferences… → Resources → File Sharing.

See if you can try to go in Docker and locate for that File sharing option, and add access to that path in question, then run the docker command line I shared with you in DM/PM.