Oxygen Builder - Fatal Error Out of Memory

Evening all,

Does anyone use Oxygen builder?

Just trying it out for the first time - I’m using DevKinsta on an M1 Macbook Pro.

Other DevKinsta sites are ok, and Oxygen runs fine when I installed it on an empty site slot in my hosting account.

" Fatal error : Out of memory (allocated 9347072) (tried to allocate 5152768 bytes) in /www/kinsta/public/oxygen/wp-content/plugins/oxygen/component-framework/oxygen-main-template.php on line 256

There has been a critical error on this website."

Any help much appreciated! Thanks

Hi @James_Vector . Thanks for posting here and welcome to DevKinsta. We’re working on increasing the default PHP limit in a future version. In the meantime, you can enter the following into Terminal to manually increase the PHP limit. docker exec -it devkinsta_fpm bash then navigate to cd /etc/php/7.x(change this)/fpm/ and your PHP version. The php.ini will be located there to edit the memory_limit line.

Edit: Apologies! Lastly, be sure to restart the container via docker restart devkinsta_fpm.

Hi Michael,

Thanks a lot for your reply - I tried that but didn’t have any luck unfortunately. Interesting using docker for the first time though - I verified 512M using a phpinfo() page and tried PHP 8 as well. Not sure what else I could try?

I’m not sure if this is an M1 Macbook bug!

Thanks again

Hm, perhaps try a much higher value. 1024M maybe?

Still the same issue I’m afraid!

Had to post twice as new users can only upload 1 pic per post

Do you happen to have WP_MEMORY_LIMIT on your wp-config.php file? Try updating that as well. Here’s a guide to help with updating that value too.

Tried that too I’m afraid Michael!

Also this in php-fpm.conf

php_admin_value[memory_limit] = 1024M

Sorry for the trouble there @James_Vector . I’ll do further testing here and get back to you soon.

No problem Michael - thanks a lot for looking into it.

Looks like a great tool and I’m sure we’ll be using it full time soon.

Could you tell us the value you see under Site Health > Info > Server for PHP memory limit? A screenshot is below on where to find it exactly.

Hi Michael,

Thanks for continuing to look into this.

Looks ok on that page too


Does the same occur on PHP 7.4 and 7.3?

Yep - same issue I’m afraid! Very strange.

Tried removing other sites, and downloading a site from Kinsta that’s working and still no luck.

Would you be able to create a brand new site on DevKinsta and let me know if this issue occurs there as well?

Hi @James_Vector . Just checking in on how things are going. Were you able to get this resolved? If you continue to see issues, please let us know and create a new thread here so we can assist further. Also be sure to update DevKinsta if you haven’t already :slight_smile: